Project

General

Profile

Actions

bug #8954

closed

Details and Supplemental Data View do not save the expansion state of sections again

Added by Andreas Müller over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

The regression described in #8260 occurs again for me. Details view and supplemental data view and maybe others do not remember their state anymore.
Also the factual data view has an unexpected (and unwanted) behavior in terms of state saving.


Related issues

Related to EDIT - bug #8260: Details and Supplemental Data View do not save the expansion state of sectionsClosedPatrick Plitzner

Actions
Related to EDIT - bug #8903: Remember expansion state in factual data viewClosedKatja Luther

Actions
Copied to EDIT - feature request #9057: Remember expansion state in factual data view when changing focusNewKatja Luther

Actions
Actions #1

Updated by Andreas Müller over 2 years ago

  • Related to bug #8260: Details and Supplemental Data View do not save the expansion state of sections added
Actions #2

Updated by Katja Luther over 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50
Actions #3

Updated by Katja Luther over 2 years ago

this should be fixed, please review.

Actions #4

Updated by Katja Luther over 2 years ago

  • Assignee changed from Katja Luther to Andreas Müller
Actions #5

Updated by Andreas Müller over 2 years ago

  • Description updated (diff)
Actions #6

Updated by Andreas Müller over 2 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

For the supplemental data view and the details view the behavior seems to be fixed.

Did you also work on the factual data view? If yes, can you explain how the expected behavior looks like? (If this is not yet fixed we should maybe split this ticket)

Actions #7

Updated by Andreas Müller over 2 years ago

  • Related to bug #8903: Remember expansion state in factual data view added
Actions #8

Updated by Katja Luther over 2 years ago

Andreas Müller wrote:

For the supplemental data view and the details view the behavior seems to be fixed.

Did you also work on the factual data view? If yes, can you explain how the expected behavior looks like? (If this is not yet fixed we should maybe split this ticket)

The factual data view remembers the expansion state when deleting a fact or a description. When changing the views the expansion state is not saved. This is much more difficult. If we want to remember this state as well, I would create a new ticket.

Actions #9

Updated by Andreas Müller over 2 years ago

  • Copied to feature request #9057: Remember expansion state in factual data view when changing focus added
Actions #10

Updated by Andreas Müller over 2 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

OK, I moved the factual data issue to a new ticket #9057

Actions

Also available in: Atom PDF