Project

General

Profile

bug #8939

Exception when opening Distribution Editor because of missing Preference

Added by Katja Luther about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
04/06/2020
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

Dear Andreas,

I would like to report an error, when I try "Opening in..." "Distribution editor", I get the message:

picture816-1.png

and, if I click "ok", the sceen is like this:
picture816-2.png

The error details are as follows:

last remote method : http://api.cybertaxonomy.org:80/flora-greece/remoting/vocabulary.service
last remote request client time : 2020-04-04T21:40:48.794
last remote request response header time : Sat, 04 Apr 2020 20:40:52 GMT
client error time : 2020-04-04T21:40:49.524
login : constantia
editor version : 5.13.1
server : api.cybertaxonomy.org (cybertaxonomy.org) / flora-greece
schema version : 5.12.0.0.20191202
os : Windows 7 6.1 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:288)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
                at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
                at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
                at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
                at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
                at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
                at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
                at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
                at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
                at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
                at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
                at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
                at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
                at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
                at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
                at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
                at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
                at eu.etaxonomy.taxeditor.preference.PreferencesUtil.getIntValue(PreferencesUtil.java:373)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.StatusDataCellEditor.<init>(StatusDataCellEditor.java:44)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.DistributionCellEditorDataConversionConfiguration.configureRegistry(DistributionCellEditorDataConversionConfiguration.java:76)
                at org.eclipse.nebula.widgets.nattable.layer.AbstractLayer.configure(AbstractLayer.java:167)
                at org.eclipse.nebula.widgets.nattable.layer.CompositeLayer.configure(CompositeLayer.java:126)
                at org.eclipse.nebula.widgets.nattable.layer.CompositeLayer.configure(CompositeLayer.java:121)
                at org.eclipse.nebula.widgets.nattable.NatTable.configure(NatTable.java:653)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.DistributionEditor.configureNatTable(DistributionEditor.java:353)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.DistributionEditor.createTable(DistributionEditor.java:366)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.DistributionEditorPart.init(DistributionEditorPart.java:150)
                at eu.etaxonomy.taxeditor.editor.EditorUtil.openDistributionEditor(EditorUtil.java:121)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.handler.OpenChecklistEditorHandlerE4.open(OpenChecklistEditorHandlerE4.java:40)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.handler.OpenChecklistEditorHandlerE4.open(OpenChecklistEditorHandlerE4.java:1)
                at eu.etaxonomy.taxeditor.handler.defaultHandler.e4.DefaultOpenSetBaseHandler.execute(DefaultOpenSetBaseHandler.java:62)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
                ... 37 more

Best regards,
Constantia

picture816-1.png View - exception (90.6 KB) Katja Luther, 04/06/2020 09:48 AM

picture816-2.png View (76 KB) Katja Luther, 04/06/2020 09:48 AM


Related issues

Related to Edit - task #8047: Remaining issues in TaxDistributionEditor Feedback 01/31/2019

Associated revisions

Revision c6df97c5 (diff)
Added by Katja Luther about 2 months ago

fix #8939: fix getIntValue for preference with no db and no local preference

History

#1 Updated by Katja Luther about 2 months ago

  • Description updated (diff)

#2 Updated by Katja Luther about 2 months ago

  • Category set to taxeditor
  • Status changed from New to In Progress
  • Assignee set to Katja Luther
  • Target version changed from Unassigned CDM tickets to Release 5.14

#3 Updated by Katja Luther about 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

#4 Updated by Katja Luther about 2 months ago

  • Assignee changed from Katja Luther to Andreas Müller

please review

#5 Updated by Andreas Müller about 2 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

Seems to work as expected

#6 Updated by Andreas Müller about 2 months ago

But handling of defaults (as implemented for most other preferences) is still not missing. This is mentioned in #8047#note-56

#7 Updated by Andreas Müller about 2 months ago

  • Related to task #8047: Remaining issues in TaxDistributionEditor added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)