Project

General

Profile

bug #8917

NPE when opening Acacia in Name bulk editor (from search)

Added by Andreas Müller about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
03/30/2020
Due date:
% Done:

100%

Severity:
major
Found in Version:

Description

in FoG.

  • Search for Acacia ( in FoG)
  • Open the pure name (orphaned name) via context menu -> bulk editor
  • => exception

(Directly opening the bulk editor and searching for Acacia* works)

last remote method : http://api.cybertaxonomy.org:80/flora-greece/remoting/common.service
last remote request client time : 2020-03-30T15:04:54.298
last remote request response header time : Mon, 30 Mar 2020 15:05:10 GMT
client error time : 2020-03-30T15:04:56.952
login : admin
editor version : 5.13.1
server : api.cybertaxonomy.org (cybertaxonomy.org) / flora-greece
schema version : 5.12.0.0.20191202
os : Windows 10 10.0 amd64
java : 1.8.0_241
org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:288)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.bulkeditor.input.BulkEditorInputType.getInput(BulkEditorInputType.java:132)
    at eu.etaxonomy.taxeditor.bulkeditor.input.AbstractBulkEditorInput.NewInstance(AbstractBulkEditorInput.java:96)
    at eu.etaxonomy.taxeditor.bulkeditor.input.AbstractBulkEditorInput.NewInstance(AbstractBulkEditorInput.java:114)
    at eu.etaxonomy.taxeditor.bulkeditor.handler.defaultHandler.OpenBulkEditorForIdentifiableEntityE4.open(OpenBulkEditorForIdentifiableEntityE4.java:36)
    at eu.etaxonomy.taxeditor.handler.defaultHandler.e4.DefaultOpenHandlerBaseE4.execute(DefaultOpenHandlerBaseE4.java:47)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    ... 37 more

Associated revisions

Revision 163a48b0 (diff)
Added by Katja Luther about 2 months ago

fix #8917: fix open_in Bulkeditor

History

#1 Updated by Andreas Müller about 2 months ago

  • Description updated (diff)

#2 Updated by Andreas Müller about 2 months ago

  • Description updated (diff)

#3 Updated by Andreas Müller about 2 months ago

Please delete the orphaned name after fixing this ticket.

#4 Updated by Katja Luther about 2 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#5 Updated by Katja Luther about 2 months ago

  • Assignee changed from Katja Luther to Andreas Müller
  • Priority changed from New to Highest
  • Severity changed from major to blocker

this should be fixed, please review

#6 Updated by Andreas Müller about 2 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100
  • Severity changed from blocker to major

works as expected

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)