Project

General

Profile

bug #8911

LazyInitializationException (LIE) in portal/description/{uuid}

Added by Andreas Kohlbecker 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib-remote
Target version:
Start date:
03/27/2020
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

http://api.cybertaxonomy.org/caryophyllales_spp/portal/description/f4fc4b11-90c7-4a02-b236-2d58f5891e6e.json

Caused by: org.hibernate.LazyInitializationException: could not initialize proxy - no Session
    at org.hibernate.proxy.AbstractLazyInitializer.initialize(AbstractLazyInitializer.java:148)
    at org.hibernate.proxy.AbstractLazyInitializer.getImplementation(AbstractLazyInitializer.java:266)
    at org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer.invoke(JavassistLazyInitializer.java:68)
    at eu.etaxonomy.cdm.model.agent.TeamOrPersonBase_$$_jvst5ab_6e.getNomenclaturalTitle(TeamOrPersonBase_$$_jvst5ab_6e.java)
    at eu.etaxonomy.cdm.strategy.cache.name.TaxonNameDefaultCacheStrategy.getAuthorAndExAuthor(TaxonNameDefaultCacheStrategy.java:254)
    at eu.etaxonomy.cdm.strategy.cache.name.TaxonNameDefaultCacheStrategy.getNonCacheAuthorshipCache(TaxonNameDefaultCacheStrategy.java:196)
    at eu.etaxonomy.cdm.strategy.cache.name.TaxonNameDefaultCacheStrategy.getAuthorshipCache(TaxonNameDefaultCacheStrategy.java:170)
    at eu.etaxonomy.cdm.strategy.cache.name.TaxonNameDefaultCacheStrategy.getTaggedTitle(TaxonNameDefaultCacheStrategy.java:411)
    at eu.etaxonomy.cdm.model.name.TaxonName.getTaggedName(TaxonName.java:1477)
    at eu.etaxonomy.cdm.remote.json.processor.bean.TaxonNameBeanProcessor.processBeanSecondStep(TaxonNameBeanProcessor.java:66)
    at eu.etaxonomy.cdm.remote.json.processor.bean.TaxonNameBeanProcessor.processBeanSecondStep(TaxonNameBeanProcessor.java:25)
    at eu.etaxonomy.cdm.remote.json.processor.bean.AbstractBeanProcessor.processBean(AbstractBeanProcessor.java:167)
    at net.sf.json.JSONObject._fromBean(JSONObject.java:676)
    ... 107 more

Related issues

Related to Edit - bug #8881: Use pure last names (without initials) for in-references of taxon names Closed 03/06/2020

Associated revisions

Revision f4bffe1d (diff)
Added by Andreas Kohlbecker 7 months ago

fix #8911 fixing initstrategy for Taxon Descriptions

History

#1 Updated by Andreas Kohlbecker 7 months ago

  • Priority changed from New to Highest

#2 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Andreas Kohlbecker 7 months ago

  • Assignee changed from Andreas Kohlbecker to Andreas Müller

please review

#4 Updated by Andreas Müller 7 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Andreas Kohlbecker

The above link already works on production. Has this issue been hotfixed already?

#5 Updated by Andreas Müller 7 months ago

  • % Done changed from 50 to 90

Andreas Müller wrote:

The above link already works on production. Has this issue been hotfixed already?

upps, no, this fix was on cdmlib so it can't be hotfixed yet.
So maybe the data has changed?
However, the fix seems to be correct so I think we can close the ticket.

Have you checked if there might be other init strategies which require the same hotfix (the issue might be caused by the fix for #8881)?

#6 Updated by Andreas Müller 7 months ago

  • Related to bug #8881: Use pure last names (without initials) for in-references of taxon names added

#7 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 90 to 100

there are no other suspect spots.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)