Project

General

Profile

bug #8903

Remember expansion state in factual data view

Added by Andreas Müller 7 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
03/26/2020
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

When removing a description from factual data view afterwards all remaining descriptions are expanded. They should better keep there old expansion state.

Same seems to happen if saving the according specimen (for specimen descriptions) and maybe also for other actions


Related issues

Related to Edit - bug #8954: Details and Supplemental Data View do not save the expansion state of sections again Closed 04/16/2020
Related to Edit - feature request #9057: Remember expansion state in factual data view when changing focus New 06/09/2020

Associated revisions

Revision 39fb1444 (diff)
Added by Katja Luther 6 months ago

ref #8903: fix remember expand level in factual data view

Revision 31b2a7eb (diff)
Added by Katja Luther 5 months ago

ref #8903: fix exception in deletehandler

History

#1 Updated by Andreas Müller 6 months ago

  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.15

Moving to additivity milestone. But in general remembering of expansion state currently does not work correctly in the TaxEditor and should be fixed soon.

#2 Updated by Katja Luther 6 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 0 to 50

This should be fixed now. Please review.

#3 Updated by Andreas Müller 5 months ago

  • Related to bug #8954: Details and Supplemental Data View do not save the expansion state of sections again added

#4 Updated by Andreas Müller 5 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

When testing on TaxonDescriptions I got an CCE:

last remote method : http://test.e-taxonomy.eu:80/cdmserver/rem_conf_am/remoting/description.service
last remote request client time : 2020-06-03T12:22:45.598
last remote request response header time : Wed, 03 Jun 2020 12:22:46 GMT
client error time : 2020-06-03T12:22:45.864
login : admin
editor version : 5.15.0.202006022252
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 5.15.0.0.20200510
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: java.lang.ClassCastException: eu.etaxonomy.cdm.model.description.TaxonDescription cannot be cast to eu.etaxonomy.cdm.model.description.SpecimenDescription
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.ClassCastException: eu.etaxonomy.cdm.model.description.TaxonDescription cannot be cast to eu.etaxonomy.cdm.model.description.SpecimenDescription
    at eu.etaxonomy.taxeditor.editor.view.descriptive.e4.handler.DeleteHandlerE4.execute(DeleteHandlerE4.java:166)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    ... 36 more

#5 Updated by Andreas Müller 5 months ago

For SpecimenDescriptions it seems to work as expected.

#6 Updated by Andreas Müller 4 months ago

  • Related to feature request #9057: Remember expansion state in factual data view when changing focus added

#7 Updated by Katja Luther 4 months ago

  • Status changed from Feedback to Resolved

this should be fixed now.

#8 Updated by Katja Luther 4 months ago

  • Assignee changed from Katja Luther to Andreas Müller

#9 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

works now

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)