Project

General

Profile

bug #8899

NullPointerException (NPE) in ManifestController

Added by Andreas Kohlbecker 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib-remote
Target version:
Start date:
03/25/2020
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

Mostly happens in flora-malesiana, see below and also in

  • /flora-guianas/iiif/taxon/2bc3831d-c5bd-435e-8058-8d62af25e238/manifest
[flora-malesiana] 2020-03-25 14:24:50,863 INFO [qtp1018547642-2400] [eu.etaxonomy.cdm.remote.controller.iiif.ManifestController] - doGetMedia() GET: /flora-malesiana/iiif/taxon/3adf1537-11cf-42b8-b341-3645da08bef7/manifest?type=ImageFile&relationships=&relationshipsInvers=&includeTaxonDescriptions=1&includeOccurrences=&includeTaxonNameDescriptions=&includeTaxonomicChildren=
2020-03-25 14:24:50,864 WARN [qtp1018547642-2400] [org.eclipse.jetty.server.HttpChannel] - /flora-malesiana/iiif/taxon/3adf1537-11cf-42b8-b341-3645da08bef7/manifest
org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NullPointerException
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:981)
        at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:860)
...
        at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.NullPointerException
        at eu.etaxonomy.cdm.remote.controller.iiif.ManifestController.doTaxonMedia(ManifestController.java:145)
        at sun.reflect.GeneratedMethodAccessor9547.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.springframework.web.method.support.InvocableHandlerMethod.doInvoke(InvocableHandlerMethod.java:222)
        at org.springframework.web.method.support.InvocableHandlerMethod.invokeForRequest(InvocableHandlerMethod.java:137)
        at org.springframework.web.servlet.mvc.method.annotation.ServletInvocableHandlerMethod.invokeAndHandle(ServletInvocableHandlerMethod.java:110)
        at org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerAdapter.invokeHandlerMethod(RequestMappingHandlerAdapter.java:814)
        at org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerAdapter.handleInternal(RequestMappingHandlerAdapter.java:737)
        at org.springframework.web.servlet.mvc.method.AbstractHandlerMethodAdapter.handle(AbstractHandlerMethodAdapter.java:85)
        at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:959)
        at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:893)
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:969)
        ... 78 more
:

Associated revisions

Revision 9fc7d8af (diff)
Added by Andreas Kohlbecker about 2 months ago

fix #8899 fixing 4 NPEs in ManifestController

History

#1 Updated by Andreas Kohlbecker 2 months ago

  • Description updated (diff)

#2 Updated by Andreas Kohlbecker about 2 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Andreas Kohlbecker about 2 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

solved and tested at the example given in the description

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)