Project

General

Profile

bug #8860

Sec reference not inherited from classification anymore

Added by Andreas Müller 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
02/24/2020
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

When adding a (root) child node to a classification it used to be that the sec reference for the new taxon was taken from the reference of the classification. This is not the case anymore. Instead no sec reference is added anymore.
This regression needs to be reverted so the classification references is taken as sec again (if a reference exists).

picture556-1.png View (111 KB) Andreas Kohlbecker, 03/19/2020 09:59 PM

picture556-2.png View (28.3 KB) Andreas Kohlbecker, 03/19/2020 09:59 PM

Associated revisions

Revision e9069de4 (diff)
Added by Katja Luther 7 months ago

ref #8860: fix add classification ref as sec reference

History

#1 Updated by Katja Luther 8 months ago

  • Status changed from New to Resolved

This seems to be fixed already. I tested on rem_conf_am and the new taxon has the reference of the classification as sec reference.

#2 Updated by Katja Luther 8 months ago

  • Assignee changed from Katja Luther to Andreas Müller

#3 Updated by Andreas Kohlbecker 7 months ago

For me this is still not working.

The new Taxon dialog shows the sec.-reference:

But is is not being persisted:

I suggest moving this issue to the next target version.

#4 Updated by Katja Luther 7 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Kohlbecker

#5 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Kohlbecker to Katja Luther
  • % Done changed from 0 to 100

Ok, this is definitely fixed.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)