Project

General

Profile

feature request #8798

description page: Show character hierarchy

Added by Andreas Kohlbecker 6 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
New
Category:
cdm-dataportal
Target version:
Start date:
01/07/2020
Due date:
% Done:

50%

Severity:
normal
Tags:

Description

The hierarchy character of the characters in the chracter tree should be visualized in the description table

picture839-1.png View (2.5 KB) Andreas Müller, 04/22/2020 06:24 PM


Related issues

Related to Edit - bug #8739: remaining issues for description detail page Closed
Related to Edit - feature request #8657: Order description element in portal according to CharacterTree Closed 11/07/2019
Related to Edit - task #8973: [DISCUSS] Should description tables reflect the feature tree hierarchy and/or empty feature nodes? New 04/22/2020
Related to Edit - task #8974: [DISCUSS] Should freetext descriptions reflect the feature tree hierarchy and/or empty feature nodes? New 04/22/2020

Associated revisions

Revision 209feb13 (diff)
Added by Andreas Kohlbecker 6 months ago

ref #8739 indenting description table entries by chraracter hierarchy

Revision 88e622d2 (diff)
Added by Andreas Kohlbecker 6 months ago

ref #8739 indenting description table entries by character hierarchy - bugfix

History

#1 Updated by Andreas Kohlbecker 6 months ago

  • Tracker changed from bug to feature request

#2 Updated by Andreas Kohlbecker 6 months ago

  • Related to bug #8739: remaining issues for description detail page added

#3 Updated by Andreas Kohlbecker 6 months ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Kohlbecker to Andreas Müller
  • % Done changed from 0 to 50

done

#4 Updated by Andreas Müller 3 months ago

#5 Updated by Andreas Müller 3 months ago

This seems to be closely related to #8657 Maybe it is even a duplicate.

#6 Updated by Andreas Müller 3 months ago

Andreas K., can you please check if the existing identation is caused by (wrong) handling of tree hierarchy or by a wrong general formatting/css?

I could image that it reflects the 2nd level of hierarchy but in the given case (e.g. http://caryophyllales.org/cactaceae/cdm_dataportal/description/f4fc4b11-90c7-4a02-b236-2d58f5891e6e) it does not make sense as there are no 1st level data. This is also strongly related #8973 then.

This is the only open issue which is not handled in other tickets yet. So we can close this ticket once the indentation is checked.

#7 Updated by Andreas Müller 3 months ago

#8 Updated by Andreas Müller 3 months ago

  • Related to task #8973: [DISCUSS] Should description tables reflect the feature tree hierarchy and/or empty feature nodes? added

#9 Updated by Andreas Müller 3 months ago

  • Related to task #8974: [DISCUSS] Should freetext descriptions reflect the feature tree hierarchy and/or empty feature nodes? added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)