Project

General

Profile

bug #8791

Measurement units are not assigned to quantitative data in matrix

Added by Andreas Müller 8 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Highest
Category:
taxeditor
Target version:
Start date:
12/20/2019
Due date:
% Done:

100%

Severity:
critical
Found in Version:
Tags:

Description

In a first quick fix we should implement it such that if the feature has exactly 1 recommended measurment unit this unit is automatically attached.

In a further step we should show this unit either in the matrix cell or in an explicit header line.
Also we should show it in the enter dialog (only 1x as it is part of quantitative data, not of each single value)

In a next step we may then implement a dropdown menu, to choose from all recommended measurement units in case >1 such unit exists.

picture190-1.png View (9.39 KB) Andreas Müller, 03/06/2020 01:34 PM

picture191-1.png View (5.24 KB) Andreas Müller, 03/06/2020 01:34 PM

picture125-1.png View (28.7 KB) Andreas Müller, 03/06/2020 01:38 PM


Related issues

Related to Edit - bug #8790: Update measurement units for existing quantitative data missing a unit Closed 12/20/2019

Associated revisions

Revision 0e8f77ab (diff)
Added by Katja Luther 7 months ago

ref #8791: add unit to rowWrapperDto when actualise quantitative data

Revision b0127ea9 (diff)
Added by Katja Luther 7 months ago

ref #8791: add unit to quantitative data dialog

Revision 3209a251 (diff)
Added by Katja Luther 5 months ago

fix #8791: set unit when only one unit is possible

History

#1 Updated by Andreas Müller 8 months ago

  • Tags set to additivity
  • Subject changed from Meas to Measurement units are not assigned to quantitative data in matrix
  • Description updated (diff)
  • Category set to taxeditor
  • Assignee set to Katja Luther
  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.12
  • Severity changed from normal to critical

This urgent as the current implementation creates incomplete data that needs to be repaired manually (see #8790)

#2 Updated by Andreas Müller 8 months ago

  • Related to bug #8790: Update measurement units for existing quantitative data missing a unit added

#3 Updated by Katja Luther 7 months ago

  • Target version changed from Release 5.12 to Release 5.13

#4 Updated by Katja Luther 7 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

please review.

#5 Updated by Andreas Müller 5 months ago

#6 Updated by Andreas Müller 5 months ago

#7 Updated by Andreas Müller 5 months ago

  • File picture125-1.png View added
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Data does not seem to be saved yet.

In Dialog the unit appears

In the matrix it is not shown:

And in details view the field is empty:

#8 Updated by Andreas Müller 5 months ago

Ahh, it seems to work, if I have to explicitly select from a list of multiple units (if >1 units are attached to the feature)

But n=1 is the default and needs to work too.

#9 Updated by Katja Luther 5 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 50

#10 Updated by Katja Luther 5 months ago

  • Assignee changed from Katja Luther to Andreas Müller

#11 Updated by Andreas Müller 5 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)