Project

General

Profile

bug #8767

Workflow support for publish flag

Added by Andreas Müller almost 2 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
12/13/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

When changing an unpublished synonym to a MAN aftwards the MAN is published. This is not correct. The publish flag should have the same value as the synonym before.

Please also check for similar operations.

These operations are:

  • swap synonym and accepted taxon - works
  • change synonym to MAN - works
  • change MAN to synonym - works
  • change accepted to synonym - works
  • change synonym to accepted taxon - works
  • move synonym/homotypic group to another taxon - works, but open issue: check synonyms of the homotypic group
  • move accepted to new parent - works

Related issues

Related to Edit - bug #9426: Set publish flag for Synonyms in accordance with accepted taxon publish flag Closed 01/28/2021
Related to Edit - bug #9516: Check publish flag of all homotypic synonyms when moving New 03/05/2021

Associated revisions

Revision 037a20f8 (diff)
Added by Katja Luther 9 months ago

fix publish handling for synonyms and misapplied names and add sec handling for switch syn to accepted

Revision db73ee9a (diff)
Added by Katja Luther 9 months ago

publish also should be cloned in TaxonBase.clone

Revision 8b233e12 (diff)
Added by Katja Luther 9 months ago

revert setting publish in clone

Revision 373576f7 (diff)
Added by Katja Luther 8 months ago

ref #8767: add information when publish flag of the new taxon differs from the parent

Revision 0afdad42 (diff)
Added by Katja Luther 8 months ago

ref #8767: add information when publish flag of the new taxon differs from the parent - continue

Revision 73c98fbf (diff)
Added by Katja Luther 8 months ago

ref #8767: add warning also for move syn and swap syn and accepted

Revision fef9b989 (diff)
Added by Katja Luther 8 months ago

ref #8767: add warning dialog instead of info dialog

Revision 8f180179 (diff)
Added by Katja Luther 8 months ago

ref #8767: add warning dialog instead of info dialog

Revision 84d9b190 (diff)
Added by Katja Luther 8 months ago

ref #8767: fix publish flag when swap syn and accepted

Revision 8bc0e09e (diff)
Added by Katja Luther 8 months ago

ref #8767: fix publish flag when change accepted to syn

Revision 7c96f526 (diff)
Added by Katja Luther 8 months ago

ref #8767: add warning dialog for change acc to syn for different puplish flags

Revision 7eaf3bb5 (diff)
Added by Katja Luther 8 months ago

ref #8767: add warning dialog for change acc to syn for different puplish flags - continue

Revision 492fde02 (diff)
Added by Katja Luther 8 months ago

ref #8767: label issues

Revision d170d72d (diff)
Added by Katja Luther 8 months ago

ref #8767: fix publish flag when change man to syn

Revision f92f7076 (diff)
Added by Katja Luther 8 months ago

ref #8767: add publish status to taxonnodedto

Revision db1b9b38 (diff)
Added by Katja Luther 8 months ago

ref #8767: keep publish flag for MAN -> syn

Revision 60558f86 (diff)
Added by Katja Luther 8 months ago

ref #8767: keep publish flag for MAN -> syn

Revision 61e77456 (diff)
Added by Katja Luther 8 months ago

ref #8767: check for publish when moving taxon

Revision 7ff96e13 (diff)
Added by Katja Luther 8 months ago

ref #8767: fix warning for same publish flag when moving taxa

Revision 778ddd5e (diff)
Added by Katja Luther 8 months ago

ref #8767: adapt message for different publish flags in swap acc/syn

History

#1 Updated by Katja Luther almost 2 years ago

  • Target version changed from Release 5.12 to Release 5.13

#2 Updated by Katja Luther over 1 year ago

  • Target version changed from Release 5.13 to Release 5.14

#3 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.14 to Release 5.15

#4 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.15 to Release 5.18

#5 Updated by Katja Luther 11 months ago

  • Target version changed from Release 5.18 to Release 5.19

#6 Updated by Andreas Müller 9 months ago

  • Target version changed from Release 5.19 to Release 5.21

#7 Updated by Andreas Müller 9 months ago

  • Related to bug #9426: Set publish flag for Synonyms in accordance with accepted taxon publish flag added

#8 Updated by Andreas Müller 9 months ago

  • Tags changed from euro+med to euro+med, fast

#9 Updated by Katja Luther 9 months ago

This is fixed, also for pp synonyms.

I also adapted the changeSynonymToAcceptedTaxon, the newly created taxon has the same publish state as the synonym, is this the wanted behaviour?

And the clone method of TaxonBase also clones the publish flag now.

#10 Updated by Katja Luther 9 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 0 to 60

#11 Updated by Andreas Müller 9 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Katja Luther wrote:

I also adapted the changeSynonymToAcceptedTaxon, the newly created taxon has the same publish state as the synonym, is this the wanted behaviour?

Yes I think this is ok. Maybe only in case the publish Flag of the new taxon differs from the publish flag of the parent of the new taxon we could add a warning dialog saying that it differs and that it should be checked for correctnes.

#12 Updated by Katja Luther 8 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote:

Katja Luther wrote:

I also adapted the changeSynonymToAcceptedTaxon, the newly created taxon has the same publish state as the synonym, is this the wanted behaviour?

Yes I think this is ok. Maybe only in case the publish Flag of the new taxon differs from the publish flag of the parent of the new taxon we could add a warning dialog saying that it differs and that it should be checked for correctnes.

now there is a message box when the publish flags differ.

#13 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

The message pops up 2x now

#14 Updated by Andreas Müller 8 months ago

Also swapping synonym with accepted has strange behavior: only the names swap but the publish flag stays. E.g. if old accepted is published the new accepted is also published and if the old synonym is unpublished the new synonym is also unpublished. This I think is unwanted.
In the rare case that the both status differ, we should keep the flag with the according taxon but warn that the flags differ.

#15 Updated by Andreas Müller 8 months ago

Accordingly we should check ALL operations to handle the publish flag correctly.

#16 Updated by Katja Luther 8 months ago

Andreas Müller wrote:

The message pops up 2x now

With the actual nightly build I can not reproduce this.

#17 Updated by Andreas Müller 8 months ago

Andreas Müller wrote:

The message pops up 2x now

I can not reproduce this anymore.

#18 Updated by Andreas Müller 8 months ago

Andreas Müller wrote:

Accordingly we should check ALL operations to handle the publish flag correctly.

E.g. also move synonym to another accepted taxon should do the same check as synonymToAccepted. If the old accepted taxon has a different publish flag then the new accepted taxon a warning should appear.

#19 Updated by Andreas Müller 8 months ago

By the way, currently this is handled as an info (i) but I think a warning would be better.

#20 Updated by Katja Luther 8 months ago

Changing an unpublished accepted to a synonym of an published accepted taxon, how should we handle this? Keep the publish flag from the old accepted taxon and warn?

#21 Updated by Andreas Müller 8 months ago

Katja Luther wrote:

Changing an unpublished accepted to a synonym of an published accepted taxon, how should we handle this? Keep the publish flag from the old accepted taxon and warn?

Yes, I think a warning is needed here. In general we should always warn if not all related taxa (taxon/syn itself, old parent/accepted, new parent/accepted) do have the same pub. status.

#22 Updated by Katja Luther 8 months ago

  • Status changed from Feedback to Resolved

implemented the publish check also for accepted to syn.

#23 Updated by Katja Luther 8 months ago

  • Assignee changed from Katja Luther to Andreas Müller

#24 Updated by Katja Luther 8 months ago

  • Description updated (diff)

#25 Updated by Katja Luther 8 months ago

  • Description updated (diff)

#26 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Testing swap:

  • if parent taxon has state 1 and old+new taxon state 2 no warning appears
  • if warning appears it says mentions only 2 taxa not all 3. To not to have a warning for each different case we should have 1 warning saying "Parent taxon, old accepted taxon and new accepted taxon do not all have the same ..."

#27 Updated by Andreas Müller 8 months ago

Katja, can you please test correct functionality for each of the above operations and leave a message in this ticket what you have tested.

E.g.

swap: parent 0, taxon 0, syn 1 => message appears (OK)
swap: parent 1, taxon 0, syn 1 => no message (FALSE)
swap: parent 1, taxon 1, syn1 => no message (OK)
...

#28 Updated by Katja Luther 8 months ago

For operations like swap I do not see the need to test for the parent if the old and the new accepted have the same publish status, because the status of the child is still the same.

#29 Updated by Andreas Müller 8 months ago

Katja Luther wrote:

For operations like swap I do not see the need to test for the parent if the old and the new accepted have the same publish status, because the status of the child is still the same.

OK, you are right. In this special case it is not really needed to check all 3 related taxa.

#30 Updated by Andreas Müller 8 months ago

  • Description updated (diff)

#31 Updated by Andreas Müller 8 months ago

Tested Syn => MAN/ppSyn

acc 1, syn 0 => MAN 0 (OK)
acc 0, syn 1 => MAN 1 (OK)
acc 0, syn 0 => MAN 0 (OK)

#32 Updated by Andreas Müller 8 months ago

Tested MAN/ppSyn => Syn

acc 1, MAN 0 => Syn 0 (OK)
acc 1, MAN 1 => Syn 0 (FALSE)
acc 0, MAN 0 => Syn 0 (OK)
acc 0, MAN 1 => Syn 0 (FALSE)

The new synonym always looses its state when publish flag was checked. But it should keep the state (without warning in this case).

#33 Updated by Andreas Müller 8 months ago

Tested change accepted to synonym

Old parent 1, old acc 1, new acc 1 => new syn 0, w/o warning (FALSE, should be 1 w/o warning)
Old parent 1, old acc 1, new acc 0 => new syn 0, with warning (OK)
Old parent 1, old acc 0, new acc 1 => new syn 1, w/o warning (FALSE, should be 1 with warning)
Old parent 1, old acc 0, new acc 0 => new syn 0, with warning (FALS, should be 0 w/o warning)

#34 Updated by Andreas Müller 8 months ago

Andreas Müller wrote:

Tested change accepted to synonym

Old parent 1, old acc 1, new acc 1 => new syn 0, w/o warning (FALSE, should be 1 w/o warning)
Old parent 1, old acc 1, new acc 0 => new syn 0, with warning (OK)
Old parent 1, old acc 0, new acc 1 => new syn 1, w/o warning (FALSE, should be 1 with warning)
Old parent 1, old acc 0, new acc 0 => new syn 0, with warning (FALS, should be 0 w/o warning)

The evaluation assumes that the state of the old parent does not matter as discussed via email.

#35 Updated by Andreas Müller 8 months ago

change synonym to accepted taxon

Old acc 1, old syn 1, new parent 1 => new acc 1 w/o warning (OK)
Old acc 1, old syn 0, new parent 1 => new acc 0 with warning (OK)
Old acc 1, old syn 1, new parent 0 => new acc 1 with warning (OK)
Old acc 1, old syn 0, new parent 0 => new acc 0 w/o warning (OK)
Old acc 0, old syn 1, new parent 1 => new acc 1 w/o warning (OK), old acc should have no influence

This operation looks ok.

#36 Updated by Katja Luther 8 months ago

Andreas Müller wrote:

Tested MAN/ppSyn => Syn

acc 1, MAN 0 => Syn 0 (OK)
acc 1, MAN 1 => Syn 0 (FALSE)
acc 0, MAN 0 => Syn 0 (OK)
acc 0, MAN 1 => Syn 0 (FALSE)

The new synonym always looses its state when publish flag was checked. But it should keep the state (without warning in this case).

this is fixed.

#37 Updated by Andreas Müller 8 months ago

Tested move synonym/homotypic group to another taxon

Old acc 1, old syn 1, new acc 1 => new syn 1 w/o warning (OK)
Old acc 1, old syn 0, new acc 1 => new syn 0 with warning (OK)
Old acc 1, old syn1 1, old syn2 0, new acc 1 => new syn1 1, new syn2 0 w/o warning (FALSE, the homotypic synonym syn2 should also be checked) - if any of the synonyms in the HG differs from state of the new acc taxon the warning should come
Old acc 1, old syn 1, new acc 0 => new syn 1 with warning (OK)
Old acc 1, old syn 0, new acc 0 => new syn 0 w/o warning (OK)

Generally correct, but not yet implemented for full homotypic group

#38 Updated by Andreas Müller 8 months ago

Katja, can you do the same check for "move accepted to new parent". I don't if this is already fully fixed, committed and build in nightly

#39 Updated by Katja Luther 8 months ago

Andreas Müller wrote:

Andreas Müller wrote:

Tested change accepted to synonym

Old parent 1, old acc 1, new acc 1 => new syn 0, w/o warning (FALSE, should be 1 w/o warning)
Old parent 1, old acc 1, new acc 0 => new syn 0, with warning (OK)
Old parent 1, old acc 0, new acc 1 => new syn 1, w/o warning (FALSE, should be 1 with warning)
Old parent 1, old acc 0, new acc 0 => new syn 0, with warning (FALS, should be 0 w/o warning)

The evaluation assumes that the state of the old parent does not matter as discussed via email.

I think the warnings should come when the new accepted taxon and the synonym have different publish flags and I checked it again and it looks like this:

old acc 1, new acc 1 => new syn 1
old acc 1, new acc 0 => new syn 1 with warning
old acc 0, new acc 1 => new syn 0 with warning
old acc 0, new acc 0 => new syn 0

#40 Updated by Katja Luther 8 months ago

Andreas Müller wrote:

Katja, can you do the same check for "move accepted to new parent". I don't if this is already fully fixed, committed and build in nightly

moved acc 0, new parent 1 => warning
moved acc 0, new parent 0 => no warning
moved acc 1, new parent 1 => warning -> false

#41 Updated by Katja Luther 8 months ago

Katja Luther wrote:

Andreas Müller wrote:

Katja, can you do the same check for "move accepted to new parent". I don't if this is already fully fixed, committed and build in nightly

moved acc 0, new parent 1 => warning
moved acc 0, new parent 0 => no warning
moved acc 1, new parent 1 => warning -> false

this is fixed, now:

moved acc 0, new parent 1 => warning
moved acc 0, new parent 0 => no warning
moved acc 1, new parent 1 => no warning
moved acc 1, new parent 0 => warning

#42 Updated by Andreas Müller 8 months ago

  • Subject changed from Change Synonym to Misapplied Name handles publish flag not correctly to Workflow support for publish flag

#43 Updated by Andreas Müller 8 months ago

Katja Luther wrote:

Andreas Müller wrote:

Tested MAN/ppSyn => Syn

acc 1, MAN 0 => Syn 0 (OK)
acc 1, MAN 1 => Syn 0 (FALSE)
acc 0, MAN 0 => Syn 0 (OK)
acc 0, MAN 1 => Syn 0 (FALSE)

The new synonym always looses its state when publish flag was checked. But it should keep the state (without warning in this case).

this is fixed.

for me it does not work yet

#44 Updated by Andreas Müller 8 months ago

Katja Luther wrote:

Andreas Müller wrote:

Andreas Müller wrote:

Tested change accepted to synonym

Old parent 1, old acc 1, new acc 1 => new syn 0, w/o warning (FALSE, should be 1 w/o warning)
Old parent 1, old acc 1, new acc 0 => new syn 0, with warning (OK)
Old parent 1, old acc 0, new acc 1 => new syn 1, w/o warning (FALSE, should be 1 with warning)
Old parent 1, old acc 0, new acc 0 => new syn 0, with warning (FALS, should be 0 w/o warning)

The evaluation assumes that the state of the old parent does not matter as discussed via email.

I think the warnings should come when the new accepted taxon and the synonym have different publish flags and I checked it again and it looks like this:

old acc 1, new acc 1 => new syn 1
old acc 1, new acc 0 => new syn 1 with warning
old acc 0, new acc 1 => new syn 0 with warning
old acc 0, new acc 0 => new syn 0

I agree about the handling of the warning and I tested again and everything works, except for 1x for the second case (no warning appeared) but I could not reproduce, so I guess in general it works. However, we should watch it a bit.

P.S: Looks like I mixed case 2 and 3 somehow in my original message

#45 Updated by Katja Luther 8 months ago

Andreas Müller wrote:

Katja Luther wrote:

Andreas Müller wrote:

Tested MAN/ppSyn => Syn

acc 1, MAN 0 => Syn 0 (OK)
acc 1, MAN 1 => Syn 0 (FALSE)
acc 0, MAN 0 => Syn 0 (OK)
acc 0, MAN 1 => Syn 0 (FALSE)

The new synonym always looses its state when publish flag was checked. But it should keep the state (without warning in this case).

this is fixed.

for me it does not work yet

maybe I missed to commit, I try again, when jenkins is ready.

#46 Updated by Katja Luther 8 months ago

Katja Luther wrote:

Andreas Müller wrote:

Katja Luther wrote:

Andreas Müller wrote:

Tested MAN/ppSyn => Syn

acc 1, MAN 0 => Syn 0 (OK)
acc 1, MAN 1 => Syn 0 (FALSE)
acc 0, MAN 0 => Syn 0 (OK)
acc 0, MAN 1 => Syn 0 (FALSE)

The new synonym always looses its state when publish flag was checked. But it should keep the state (without warning in this case).

this is fixed.

for me it does not work yet

maybe I missed to commit, I try again, when jenkins is ready.

tested again with nightly on test server:

acc 1, MAN 0 => Syn 1 (FALSE)
acc 1, MAN 1 => Syn 1 (OK)
acc 0, MAN 0 => Syn 0 (OK)
acc 0, MAN 1 => Syn 0 (FALSE)

but with local server with same TaxonServiceImpl it is:

acc 1, MAN 0 => Syn 0 (OK)
acc 1, MAN 1 => Syn 1 (OK)
acc 0, MAN 0 => Syn 0 (OK)
acc 0, MAN 1 => Syn 1 (OK)

#47 Updated by Katja Luther 8 months ago

Now also MAN -> Synonym works as expected:

acc 1, MAN 0 => Syn 0 (OK)
acc 1, MAN 1 => Syn 1 (OK)
acc 0, MAN 0 => Syn 0 (OK)
acc 0, MAN 1 => Syn 1 (OK)

#48 Updated by Katja Luther 8 months ago

  • Description updated (diff)
  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

I think we can close this ticket, I checked all operations mentioned above.

#49 Updated by Katja Luther 8 months ago

  • Description updated (diff)

create follow up ticket for the publish check of the whole homotypic group

#50 Updated by Katja Luther 8 months ago

  • Related to bug #9516: Check publish flag of all homotypic synonyms when moving added

#51 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • Priority changed from New to Highest
  • % Done changed from 60 to 100

Yes this can be closed.

#52 Updated by Andreas Müller 5 months ago

  • Tags changed from euro+med, fast to euro+med

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)