Project

General

Profile

feature request #8755

Show all structure/property trees in CharacterEditor

Added by Patrick Plitzner 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
12/09/2019
Due date:
% Done:

100%

Severity:
normal
Tags:

Description

Currently you can only choose one tree for each term type


Related issues

Related to Edit - feature request #8756: Refresh button for structure tree and property tree in Character Editor Resolved 12/10/2019
Copied to Edit - feature request #8773: [DISCUSS] Allow editing structure and properties tree in Character Editor New 12/17/2019

Associated revisions

Revision 6803fca4 (diff)
Added by Patrick Plitzner 6 months ago

fix #8755 Show all structure/property trees in CharacterEditor

History

#1 Updated by Patrick Plitzner 6 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Patrick Plitzner 6 months ago

  • Assignee changed from Patrick Plitzner to Andreas Kohlbecker

#3 Updated by Andreas Müller 6 months ago

We tested intensively today during the integrated taxonomy course. It worked fine.

2 questions:

1) with the current state of the structure tree it is sometimes wanted to extend this tree by adding further structures. This is currently not possible by simply d&d structures (or properties) here. Was this ever possible? If yes, then it is a regression. If no, than this missing feature is only a nice-to-have. But with an increasing default structure tree in future it will maybe not be so urgent to add many structures to tree WHILE editing with the character editor.

2) if 1) is not implemented than at least a refresh button would be helpful. So whenever I externally added a new structure to the structure tree(s) I can immediately use them afterward in the character editor without reopening it. => #8756

#4 Updated by Andreas Kohlbecker 6 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Kohlbecker to Patrick Plitzner

I am passing this ticket to you since the questions in comment 3 are addressed to the implementer.

#5 Updated by Patrick Plitzner 6 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Andreas Müller wrote:

We tested intensively today during the integrated taxonomy course. It worked fine.

2 questions:

1) with the current state of the structure tree it is sometimes wanted to extend this tree by adding further structures. This is currently not possible by simply d&d structures (or properties) here. Was this ever possible? If yes, then it is a regression. If no, than this missing feature is only a nice-to-have. But with an increasing default structure tree in future it will maybe not be so urgent to add many structures to tree WHILE editing with the character editor.

2) if 1) is not implemented than at least a refresh button would be helpful. So whenever I externally added a new structure to the structure tree(s) I can immediately use them afterward in the character editor without reopening it. => 8756

Ticket #8756 is implemented

#6 Updated by Andreas Müller 5 months ago

  • Copied to feature request #8773: [DISCUSS] Allow editing structure and properties tree in Character Editor added

#7 Updated by Andreas Müller 5 months ago

  • Related to feature request #8756: Refresh button for structure tree and property tree in Character Editor added

#8 Updated by Andreas Müller 5 months ago

  • Status changed from Feedback to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner
  • % Done changed from 50 to 100

Follow up issues are moved to extra tickets so we can close this one.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)