Project

General

Profile

bug #8731

BioCase Specimenimport: empty result list and SWTException:Invalid thread access in search results

Added by Andreas Kohlbecker 12 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Highest
Category:
taxeditor
Target version:
Start date:
11/28/2019
Due date:
% Done:

100%

Severity:
blocker
Found in Version:

Description

I am not sure about the timing of the situation in which this exception occurred.

I was searching the http://ww3.bgbm.org/biocase/pywrapper.cgi?dsa=Herbar for TaxonName=Bupleurum falcatum* after clicking finish one the Search result view has appeared I clicked the Configuration button. At about this time the below exception has been thrown.

This problem is reprocucible without the need to click the Configuration button

!ENTRY org.eclipse.core.jobs 4 2 2019-11-28 15:34:48.626
!MESSAGE An internal error occurred during: "Query specimen provider".
!STACK 0
org.eclipse.swt.SWTException: Invalid thread access
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.SWT.error(SWT.java:4419)
    at org.eclipse.swt.widgets.Widget.error(Widget.java:483)
    at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:421)
    at org.eclipse.swt.widgets.Text.setText(Text.java:2595)
    at eu.etaxonomy.taxeditor.view.dataimport.e4.SpecimenImportViewE4.query(SpecimenImportViewE4.java:127)
    at eu.etaxonomy.taxeditor.view.dataimport.e4.SpecimenSearchWizardE4$QueryJob.run(SpecimenSearchWizardE4.java:192)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
2019-11-28 15:35:15,745 ERROR [eu.etaxonomy.taxeditor.model.MessagingUtils$1] - This is an unexpected error.
Please contact EDIT Support (EditSupport@bgbm.org) with the error trace below (click on the 'Details' button).
java.lang.Exception: login : 
editor version : 5.12.0.qualifier
server :  ()
schema version : 
os : Linux 5.0.0-36-generic amd64
java : 1.8.0_131
org.eclipse.swt.SWTException: Invalid thread access
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.SWT.error(SWT.java:4419)
    at org.eclipse.swt.widgets.Widget.error(Widget.java:483)
    at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:421)
    at org.eclipse.swt.widgets.Text.setText(Text.java:2595)
    at eu.etaxonomy.taxeditor.view.dataimport.e4.SpecimenImportViewE4.query(SpecimenImportViewE4.java:127)
    at eu.etaxonomy.taxeditor.view.dataimport.e4.SpecimenSearchWizardE4$QueryJob.run(SpecimenSearchWizardE4.java:192)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

    at eu.etaxonomy.taxeditor.model.MessagingUtils$1.run(MessagingUtils.java:286)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4536)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4154)
    at org.eclipse.jface.window.Window.runEventLoop(Window.java:818)
    at org.eclipse.jface.window.Window.open(Window.java:794)
    at eu.etaxonomy.taxeditor.view.dataimport.e4.DataImportViewE4$1.widgetSelected(DataImportViewE4.java:183)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:5227)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1340)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4561)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4151)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

!ENTRY org.eclipse.core.jobs 4 0 2019-11-28 15:35:15.747
!MESSAGE This is an unexpected error.
Please contact EDIT Support (EditSupport@bgbm.org) with the error trace below (click on the 'Details' button).
!STACK 0
java.lang.Exception: login : 
editor version : 5.12.0.qualifier
server :  ()
schema version : 
os : Linux 5.0.0-36-generic amd64
java : 1.8.0_131
org.eclipse.swt.SWTException: Invalid thread access
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.SWT.error(SWT.java:4419)
    at org.eclipse.swt.widgets.Widget.error(Widget.java:483)
    at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:421)
    at org.eclipse.swt.widgets.Text.setText(Text.java:2595)
    at eu.etaxonomy.taxeditor.view.dataimport.e4.SpecimenImportViewE4.query(SpecimenImportViewE4.java:127)
    at eu.etaxonomy.taxeditor.view.dataimport.e4.SpecimenSearchWizardE4$QueryJob.run(SpecimenSearchWizardE4.java:192)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

    at eu.etaxonomy.taxeditor.model.MessagingUtils$1.run(MessagingUtils.java:286)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4536)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4154)
    at org.eclipse.jface.window.Window.runEventLoop(Window.java:818)
    at org.eclipse.jface.window.Window.open(Window.java:794)
    at eu.etaxonomy.taxeditor.view.dataimport.e4.DataImportViewE4$1.widgetSelected(DataImportViewE4.java:183)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:5227)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1340)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4561)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4151)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

Associated revisions

Revision 5adfd05a (diff)
Added by Katja Luther 12 months ago

ref #8731: minor

History

#1 Updated by Andreas Kohlbecker 12 months ago

  • Description updated (diff)
  • Priority changed from New to Highest
  • Severity changed from normal to blocker

An import of specimens is not possible wit the current code base in the development branch.

#2 Updated by Andreas Kohlbecker 12 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.12

#3 Updated by Katja Luther 12 months ago

  • Status changed from New to In Progress

This is strange, I can not reproduce this with an editor started from the workspace, also when using the actual git develop version and connected to rem_conf_am. So it is difficult to debug.

#4 Updated by Katja Luther 12 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Kohlbecker

now it works again with the nightly build.

#5 Updated by Katja Luther 12 months ago

  • % Done changed from 0 to 50

#6 Updated by Andreas Kohlbecker 10 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

obviously works since this import has been used very often in the preparation phase for the workshop and in the workshop itself.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)