Project

General

Profile

bug #8684

ITaxonService.findTaxaByName misses initStrategy Parameter

Added by Andreas Kohlbecker 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
11/14/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

ITaxonService.findTaxaByName misses initStrategy Parameter causing unsolvable LIEs when using via the portal service

once implemented, pass an initStrategy from the portal controller


Related issues

Related to Edit - bug #8676: TaxonDaoHibernateImpl.countTaxaByName misses parameter authorship Closed 11/12/2019
Related to Edit - task #8683: TaxonDaoHibernateImpl.countTaxaByName rename parameter authorship authorshipCache Closed 11/12/2019

Associated revisions

Revision 36a4a34f (diff)
Added by Andreas Kohlbecker 5 months ago

fix #8684 adding initStratery to ITaxonService.findTaxaByName

Revision 18d9b6eb (diff)
Added by Andreas Müller 5 months ago

ref #8684 fixing compile errors in cdmlib-persistence

Revision 83146769 (diff)
Added by Andreas Müller 5 months ago

ref #8684 fixing compile errors in cdm-pesi

Revision 76b9084e (diff)
Added by Andreas Kohlbecker 3 months ago

ref #8684 fixing bean collection initialization in TaxonDaoHibernateImpl.findTaxaByName

History

#1 Updated by Andreas Kohlbecker 5 months ago

  • Priority changed from New to Highest

#2 Updated by Andreas Kohlbecker 5 months ago

  • Related to bug #8676: TaxonDaoHibernateImpl.countTaxaByName misses parameter authorship added

#3 Updated by Andreas Kohlbecker 5 months ago

  • Related to task #8683: TaxonDaoHibernateImpl.countTaxaByName rename parameter authorship authorshipCache added

#4 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#5 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from Resolved to In Progress

testing the web service (locally with the caryophlalles_spp database):

http :8081/portal/taxon/doFindByNameParts.json genusOrUninomial==Selenicereus infragenericEpithet=='*' infraspecificEpithet=='*' specificEpithet=='*' authorshipCache=='*'

causes an exception:

Caused by: 
java.lang.RuntimeException: Collection no longer expected in 'initializeNodeWildcard()'. Therefore an exception is thrown.
    at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNodeWildcard(AdvancedBeanInitializer.java:140)
    at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNode(AdvancedBeanInitializer.java:123)
    at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNodeRecursive(AdvancedBeanInitializer.java:105)
    at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNodeRecursive(AdvancedBeanInitializer.java:107)
    at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeAll(AdvancedBeanInitializer.java:85)
    at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initialize(AdvancedBeanInitializer.java:57)
    at eu.etaxonomy.cdm.persistence.dao.hibernate.taxon.TaxonDaoHibernateImpl.findTaxaByName(TaxonDaoHibernateImpl.java:995)
    at eu.etaxonomy.cdm.api.service.TaxonServiceImpl.findTaxaByName(TaxonServiceImpl.java:514)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:302)

#6 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 90

the webservice is now working, tested with:

 http :8081/portal/taxon/doFindByNameParts.json genusOrUninomial==Selenicereus infragenericEpithet=='*' infraspecificEpithet=='macdonaldeae' specificEpithet=='pteranthus' authorshipCache=='*'

#7 Updated by Andreas Kohlbecker 3 months ago

also tested on t edit-test and confirmed that the service is working now

http http://test.e-taxonomy.eu/cdmserver/caryo_spp/portal/taxon/doFindByNameParts.json genusOrUninomial==Selenicereus infragenericEpithet=='*' infraspecificEpithet=='macdonaldeae' specificEpithet=='pteranthus' authorshipCache=='*'

#8 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)