Project

General

Profile

feature request #8673

Allow OriginalSource to link to other CDM objects

Added by Andreas Müller 12 months ago. Updated 12 months ago.

Status:
Closed
Priority:
New
Category:
cdm
Target version:
Start date:
11/09/2019
Due date:
% Done:

100%

Severity:
critical

Description

Currently links are only available to Reference and (external) URIs. However, especially for adding sources to aggregated data it is a requirement to also link to other CDM objects such as (Specimen- or Taxon-) Descriptions.

The problem is that adding a link to each Cdm Object will make the class very large. A solution might be to use the same principle as for IntextReferences (#4719), having an in-between class "CdmLink" which allows links to a number of CdmBase classes and which is referred from OriginalSource. It could be even merged with the IntextReference implementation.


Related issues

Related to Edit - feature request #4719: [MASTER] Implement IntextReference New 03/12/2015 03/18/2015
Related to Edit - feature request #8686: Support CdmLink sources in bibliography Closed 11/15/2019
Related to Edit - feature request #8724: Allow OriginalSource to link to Taxon Closed 11/27/2019

Associated revisions

Revision 93ad7e54 (diff)
Added by Andreas Müller 12 months ago

fix #8673 Add CdmLinkSource to OriginalSourceBase

Revision 5e7c747f (diff)
Added by Andreas Müller 12 months ago

fix #8673 update TaxEditor test DB to CdmLinkSource changes

Revision ade857dd (diff)
Added by Andreas Müller 12 months ago

fix #8673 update Vaadin test DB to CdmLinkSource changes

Revision 186cf7ed (diff)
Added by Andreas Müller 12 months ago

ref #8673 add Cascade.Delete and orphanRemoval and handle getter/setter on target directly

Revision c1217ecf (diff)
Added by Andreas Müller 12 months ago

ref #8673 Fix NPE for OriginalSourceBase.getCdmSource

Revision c32e83c4 (diff)
Added by Patrick Plitzner 12 months ago

ref #8673 Extend property path for CdmSources

Revision 065e965b (diff)
Added by Patrick Plitzner 12 months ago

ref #8673 Adapt portal to CdmSource for aggregation clones

Revision 1e2fd81a (diff)
Added by Andreas Müller 12 months ago

ref #8673 make cdmSource Eager to avoid LIEs

Revision 453261d0 (diff)
Added by Patrick Plitzner 12 months ago

ref #8673 Extend property path for CdmSources

Revision 67ab92f3 (diff)
Added by Patrick Plitzner 12 months ago

ref #8673 Adapt portal to CdmSource eager loading

Revision 019036d1 (diff)
Added by Andreas Kohlbecker 12 months ago

ref #8673 CdmLinkSourceBeanProsessor to serialize CdmLinkSource as TypedEntityReference

Revision 628c6976 (diff)
Added by Andreas Kohlbecker 12 months ago

ref #8673 CdmLinkSourceBeanProsessor to serialize CdmLinkSource as TypedEntityReference

Revision 2412e7b6 (diff)
Added by Andreas Kohlbecker 12 months ago

ref #8673 CdmLinkSourceBeanProsessor proper null handling

Revision 79e61daa (diff)
Added by Patrick Plitzner 12 months ago

ref #8673 Adapt more specific description type

Revision 4e506608 (diff)
Added by Patrick Plitzner 12 months ago

ref #8673 Fix description title display on taxon page

Revision f6a63f8b (diff)
Added by Andreas Kohlbecker 12 months ago

ref #8673 CdmLinkSourceBeanProsessor disabled and init strategy for cdmSource.target

Revision f31fdd6b (diff)
Added by Patrick Plitzner 12 months ago

ref #8673 Fix description title display on taxon page

Revision b6f0e806 (diff)
Added by Andreas Kohlbecker 11 months ago

ref #8673 extend initstrategy by cdmSource for ref #8686

History

#1 Updated by Andreas Müller 12 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Andreas Müller 12 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

Can you please review?

Please also have in mind that webservices should not deliver the full cdmobject and maybe even not the CdmLinkSource object at all but only the OriginalSourceBase.cdmSource attribute formatted as TypedEntity(?). Maybe we can implement this within this ticket. Otherwise open new one.

#3 Updated by Andreas Müller 12 months ago

#4 Updated by Patrick Plitzner 12 months ago

  • Assignee changed from Patrick Plitzner to Andreas Kohlbecker

#5 Updated by Andreas Müller 12 months ago

We still need to check if the empty constructor of CdmLinkSource also could be protected. Patrick could you do this?

#6 Updated by Andreas Kohlbecker 12 months ago

  • Assignee changed from Andreas Kohlbecker to Patrick Plitzner

CdmLinkSourceBeanProsessor implemented but cannot test since i can't find data with CdmLinkSource

@Patrick: please review

#7 Updated by Patrick Plitzner 12 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 100

works as expected

#8 Updated by Andreas Müller 12 months ago

#9 Updated by Andreas Müller 11 months ago

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)