Project

General

Profile

feature request #8657

Order description element in portal according to CharacterTree

Added by Patrick Plitzner about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Category:
cdm-dataportal
Target version:
Start date:
11/07/2019
Due date:
% Done:

100%

Severity:
normal
Tags:

picture552-1.png View (2.5 KB) Andreas Müller, 04/22/2020 06:12 PM


Related issues

Related to Edit - feature request #8798: description page: Show character hierarchy Resolved 01/07/2020
Copied to Edit - task #8973: [DISCUSS] Should description tables reflect the feature tree hierarchy and/or empty feature nodes? New 04/22/2020
Copied to Edit - task #8974: [DISCUSS] Should freetext descriptions reflect the feature tree hierarchy and/or empty feature nodes? New 04/22/2020

Associated revisions

Revision 7af2c900 (diff)
Added by Patrick Plitzner about 1 year ago

ref #8657 Add (remote) service for ordered description elements by tree

Revision c5fa3edd (diff)
Added by Patrick Plitzner about 1 year ago

ref #8657 Add webservice call to cdm_api.module

Revision a38c0718 (diff)
Added by Patrick Plitzner about 1 year ago

ref #8657 Retain hierarchy information of description elements

  • remove web service for flat ordered list

Revision d3ac3ea7 (diff)
Added by Patrick Plitzner about 1 year ago

ref #8657 Extend property path for description init strategy

Revision ea0ae3c7 (diff)
Added by Patrick Plitzner about 1 year ago

ref #8657 Add descriptive data set information to description detail page

Revision 7e99b1ac (diff)
Added by Patrick Plitzner about 1 year ago

ref #8657 Remove $linkText parameter

Revision 875d5c3b (diff)
Added by Patrick Plitzner about 1 year ago

ref #8657 Add taxon information to description detail page

Revision 1e16407a (diff)
Added by Patrick Plitzner about 1 year ago

ref #8657 Use link icon for descriptions, taxa and specimens

Revision 9705e44e (diff)
Added by Patrick Plitzner about 1 year ago

ref #8657 Avoid null in URL

Revision 9b434f6a (diff)
Added by Andreas Kohlbecker about 1 year ago

ref #8657 moving description methods to description.inc

History

#1 Updated by Patrick Plitzner about 1 year ago

  • Target version changed from Unassigned CDM tickets to 287

#2 Updated by Patrick Plitzner about 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Patrick Plitzner 12 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Assignin to you Andreas M.
But maybe also Andreas K. needs to look at the code

#4 Updated by Andreas Müller 12 months ago

Can you provide an example url?

#5 Updated by Andreas Müller 11 months ago

  • Target version changed from 287 to Release 5.12

#7 Updated by Andreas Müller 7 months ago

Maybe this ticket also covered the "freetext" description ordering like on http://caryophyllales.org/cactaceae/cdm_dataportal/taxon/b15ec01d-b909-4143-b197-e752b6f34d5b

#8 Updated by Andreas Müller 7 months ago

Currently only a flat list is created. I opened a new ticket to discuss if also the hierarchical structure should be reflected: #8973

#9 Updated by Andreas Müller 7 months ago

  • Copied to task #8973: [DISCUSS] Should description tables reflect the feature tree hierarchy and/or empty feature nodes? added

#10 Updated by Andreas Müller 7 months ago

  • Copied to task #8974: [DISCUSS] Should freetext descriptions reflect the feature tree hierarchy and/or empty feature nodes? added

#11 Updated by Andreas Müller 7 months ago

  • File picture552-1.png View added
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Andreas Kohlbecker

Andreas K., can you please check if the existing identation is caused by (wrong) handling of tree hierarchy or by a wrong general formatting/css?

I could image that it reflects the 2nd level of hierarchy but in the given case (e.g. http://caryophyllales.org/cactaceae/cdm_dataportal/description/f4fc4b11-90c7-4a02-b236-2d58f5891e6e) it does not make sense as there are no 1st level data. This is also strongly related #8973 then.

This is the only open issue which is not handled in other tickets yet. So we can close this ticket once the indentation is checked.

=> move this to #8798

#12 Updated by Andreas Müller 7 months ago

  • % Done changed from 50 to 80

#13 Updated by Andreas Müller 7 months ago

#14 Updated by Andreas Müller 7 months ago

  • Status changed from Feedback to Closed
  • Assignee changed from Andreas Kohlbecker to Patrick Plitzner
  • % Done changed from 80 to 100

I move the indentation issue to #8798 as it fits better there. And close this ticket.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)