Project

General

Profile

Actions

bug #8653

closed

NullPointerException (NPE) when focusing Taxon Name Editor

Added by Andreas Kohlbecker over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
blocker
Found in Version:

Description

  • I did the same ABCD import of Arenaria_ABCD_one_unit.xml three times
  • Then search for Arenaria serpyllifoli*
  • Open taxon Navigator
  • Toggle tree open to reveal "Acatocarpus Triana"
  • Open Taxon Name Editor for this taxon
  • Focus on Editor --> Exceprtion

The problem persists even after restartig of the editor

login : admin
editor version : 5.11.0.201911052350
server : 160.45.63.230 (edit-WS I) / caryophyllales_demo_01
schema version : 5.11.0.0.20191104
os : Linux 5.0.0-32-generic amd64
java : 1.8.0_131
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4536)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4154)
    at org.eclipse.jface.window.Window.runEventLoop(Window.java:818)
    at org.eclipse.jface.window.Window.open(Window.java:794)
    at org.eclipse.jface.dialogs.ErrorDialog.open(ErrorDialog.java:346)
    at eu.etaxonomy.taxeditor.model.MessagingUtils$1.run(MessagingUtils.java:279)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4536)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4154)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.ui.section.name.NonViralNameDetailElement.createControls(NonViralNameDetailElement.java:103)
    at eu.etaxonomy.taxeditor.ui.section.name.NonViralNameDetailElement.createControls(NonViralNameDetailElement.java:1)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailElement.updateContent(AbstractCdmDetailElement.java:107)
    at eu.etaxonomy.taxeditor.ui.section.name.NonViralNameDetailElement.updateContent(NonViralNameDetailElement.java:117)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailElement.setEntity(AbstractCdmDetailElement.java:94)
    at eu.etaxonomy.taxeditor.ui.section.name.NonViralNameDetailElement.setEntity(NonViralNameDetailElement.java:134)
    at eu.etaxonomy.taxeditor.ui.section.name.NonViralNameDetailElement.setEntity(NonViralNameDetailElement.java:1)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailSection.setEntity(AbstractCdmDetailSection.java:145)
    at eu.etaxonomy.taxeditor.ui.section.name.NonViralNameDetailSection.setTaxonBase(NonViralNameDetailSection.java:140)
    at eu.etaxonomy.taxeditor.view.detail.CdmSectionPart.setFormInput(CdmSectionPart.java:99)
    at org.eclipse.ui.forms.ManagedForm.setInput(ManagedForm.java:210)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4.refresh(AbstractCdmDataViewerE4.java:162)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4.setInput(AbstractCdmDataViewerE4.java:143)
    at eu.etaxonomy.taxeditor.view.e4.details.DetailsViewerE4.setInput(DetailsViewerE4.java:190)
    at eu.etaxonomy.taxeditor.view.e4.details.DetailsViewerE4.setInput(DetailsViewerE4.java:161)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4.showViewer(AbstractCdmEditorPartE4.java:262)
    at eu.etaxonomy.taxeditor.view.e4.details.DetailsPartE4.selectionChanged_internal(DetailsPartE4.java:107)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4$DelaySelection.run(AbstractCdmEditorPartE4.java:92)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 32 more
Actions #1

Updated by Andreas Kohlbecker over 4 years ago

  • Description updated (diff)
Actions #2

Updated by Andreas Kohlbecker over 4 years ago

  • File cdm_caryophyllales_demo_01.sql.bz2 added
  • Priority changed from New to Highest

Attaching dump of the DB: attachment.cdm_caryophyllales_demo_01.sql.bz2

Actions #3

Updated by Andreas Kohlbecker over 4 years ago

  • Target version changed from Unassigned CDM tickets to Release 5.11
Actions #4

Updated by Andreas Müller over 4 years ago

  • Severity changed from normal to blocker

As far as I can see this came with one of the latest changes. Should be easy to fix. Important before release.

Actions #5

Updated by Andreas Müller over 4 years ago

Please remove milestone afterwards. It is an milestone internal bugfix.

Actions #6

Updated by Katja Luther over 4 years ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Kohlbecker
  • Target version deleted (Release 5.11)
Actions #7

Updated by Andreas Kohlbecker over 4 years ago

  • File deleted (cdm_caryophyllales_demo_01.sql.bz2)
Actions #8

Updated by Andreas Kohlbecker over 4 years ago

Dump deleted as it was not crucial to understand the problem.

Actions #9

Updated by Andreas Kohlbecker over 3 years ago

this ticket should still be in Release 5.11 but this MS has been closed, so it will be without until closed

Review is pending, hope to have time for it next week

Actions #10

Updated by Andreas Müller over 3 years ago

  • Target version set to Release 5.11
Actions #11

Updated by Andreas Müller over 3 years ago

I moved it to 5.11

Actions #12

Updated by Andreas Müller over 2 years ago

  • Subject changed from NullPointerException (NPE) when focusing Taxion Name Editor to NullPointerException (NPE) when focusing Taxon Name Editor
Actions #13

Updated by Andreas Müller over 2 years ago

  • % Done changed from 0 to 50
Actions #14

Updated by Andreas Müller over 2 years ago

  • Assignee changed from Andreas Kohlbecker to Andreas Müller

For further review.

Actions #15

Updated by Andreas Müller over 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

This issue was obiously not related to the import but to code changes related to preferences. The fix looks reasonable so I close the ticket.

Actions

Also available in: Atom PDF