Project

General

Profile

bug #8440

specimen accession numbers link to specimen page

Added by Andreas Kohlbecker about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Highest
Category:
cdm-dataportal
Target version:
Start date:
08/02/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

The specimen accession numbers, aka specimen labels, should be clickable links to the specimen page.

This is needed for the following pages

  • Name page
  • Taxon page
  • Registration page

Related issues

Copied to Edit - task #8455: Show specimen preferredStableURL as external link icon? New 08/12/2019

Associated revisions

Revision 48468c67 (diff)
Added by Andreas Kohlbecker about 2 months ago

ref #8440 specimen accession numbers link to specimen page

Revision e69c4103 (diff)
Added by Andreas Kohlbecker about 1 month ago

ref #8440 consistent display of type specimens: link to specimen page and showing preferredStableUri

Revision d80b3059 (diff)
Added by Andreas Kohlbecker about 1 month ago

ref #8440 adapting and extending tests

History

#1 Updated by Andreas Kohlbecker about 1 month ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 0 to 50

please review

#2 Updated by Wolf-Henning Kusber about 1 month ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 70

Tested for Registration page, name page, and specimen page.

Example: Gomphonella acsiae

Links are working.

Warning in Test portal
Notice: Array to string conversion in theme_item_list() (line 2226 of /var/www/drupal-7.32/includes/theme.inc).

Question: Users could see the difference between the internal and external (stable identifier) link by checking the URL. Is this enough?

#3 Updated by Andreas Kohlbecker about 1 month ago

  • Status changed from Resolved to Closed
  • % Done changed from 70 to 100

Wolf-Henning Kusber wrote:

Warning in Test portal
Notice: Array to string conversion in theme_item_list() (line 2226 of /var/www/drupal-7.32/includes/theme.inc).

This is caused by a bug in the specimen page and is already handled in another ticket.

Question: Users could see the difference between the internal and external (stable identifier) link by checking the URL. Is this enough?

Links which are not marked otherwise are always internal links. For external links we are using the font awesome icon external-link-alt. We should think about replacing the preferredLinkURL as link text by this icon.

As this should subject of another ticket #8455 and I will close this issue now

#4 Updated by Andreas Kohlbecker about 1 month ago

  • Copied to task #8455: Show specimen preferredStableURL as external link icon? added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)