Project

General

Profile

task #8406

specimens and occurrence code cleaning and harmonization

Added by Andreas Kohlbecker 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-dataportal
Target version:
Start date:
07/25/2019
Due date:
% Done:

100%

Severity:
normal

Description

cdmlib-remote

issues copied to #8414

data portal

  • There are different kinds of "views" on specimens lists, --> #8419
    • some of them provide a pager others do not
    • do operate on different webservice response types (FieldUnitDto, ...) and are thus not exchangeable.
  • The kind of representation of specimens lists needs to be selectable via a set of radio buttons. --> #8420
  • cdm_dataportal_specimen_by_accession_number_page_view() - DONE
    • ... must not reuse cdm_dataportal_specimen_page_view(), the cdm_dataportal_specimen_page_view() must only be used as 'page callback' argument. --> create a specific implementation of cdm_dataportal_specimen_by_accession_number_page_view(). cdm_dataportal_specimen_page_view() correctly calls cdm_dataportal_specimen_view() - DONE
    • ... must not return just an empty string in case the accession number is not matching any specimen. Better respond with an appropriate message.
  • Why does cdm_dataportal_specimen_page_view() create two different representations depending on whether $uuid or $specimenDTOis being passed? This, by the way is anyway a bad idea. Better pass only one parameter. DONE
  • Specimen Page:
    • Derivate links: must not have a target attribute - DONE #8418

Related issues

Related to Edit - bug #8421: icons in compose_specimen_table_top_down() are not visible New 07/30/2019
Copied to Edit - task #8414: occurrence controller code cleaning and harmonization Closed 07/25/2019
Copied to Edit - task #8418: specimens and occurrence links must not have a target=_blank attribute Closed 07/25/2019
Copied to Edit - task #8419: harmonization of the different specimen representations New 07/25/2019
Copied to Edit - task #8420: improve admin settings for specimens representations New 07/25/2019

Associated revisions

Revision 84849c31 (diff)
Added by Andreas Kohlbecker 4 months ago

ref #8403 extracting method compose_specimens_table_bottom_up()

Revision ca7468b6 (diff)
Added by Andreas Kohlbecker 4 months ago

ref #8403 moving compose_specimens_table_bottom_up() to occurences.inc and renaming parameter in compose_specimen_array()

Revision 70b053e4 (diff)
Added by Andreas Kohlbecker 4 months ago

ref #8406 cleaning up occurrence controller code

Revision 961319fe (diff)
Added by Andreas Kohlbecker 4 months ago

ref #8406 clenaing and harmonization of the specimen related code in the dataportal

Revision a0be8d7e (diff)
Added by Andreas Kohlbecker 4 months ago

ref #8406 dapting portal to renamed controller endpoint: taxon/{uuid}/specimensOrObservationDTOs --> taxon/{uuid}/fieldUnitDTOs

Revision ff51c1cd (diff)
Added by Katja Luther 3 months ago

ref #8406: fix the view for the specimen hierarchy to a genetic acc nr

Revision c1639218 (diff)
Added by Andreas Kohlbecker 3 months ago

ref #8406 removing commented dead code

History

#1 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#2 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#3 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#4 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#5 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#6 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#7 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#8 Updated by Andreas Kohlbecker 4 months ago

  • Copied to task #8414: occurrence controller code cleaning and harmonization added

#9 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)
  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.9

#10 Updated by Andreas Kohlbecker 4 months ago

  • Copied to task #8418: specimens and occurrence links must not have a target=_blank attribute added

#11 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#12 Updated by Andreas Kohlbecker 4 months ago

  • Copied to task #8419: harmonization of the different specimen representations added

#13 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#14 Updated by Andreas Kohlbecker 4 months ago

  • Copied to task #8420: improve admin settings for specimens representations added

#15 Updated by Andreas Kohlbecker 4 months ago

  • Related to bug #8421: icons in compose_specimen_table_top_down() are not visible added

#16 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 30

#17 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#18 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Andreas Kohlbecker to Katja Luther
  • % Done changed from 30 to 50

Hi Katja,

can you please have a look if everything is as it was intended?

#19 Updated by Katja Luther 3 months ago

the view for the search for the genetic accession number did not work anymore. I fixed it. Please have a look.

#20 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from Resolved to Feedback

thank you for fixing this.

there are two commented code parts in this method:

//            $specimen_table['#rows'][] = array(
//                // An array of table rows. collapsible row
//                'data' => "",
//                'class' => array('expand_column')
//            );
//        $render_array['specimens'] = array(
//            '#prefix' => '<div id="specimens" class="page-part">' . ($page_part == 'all' ? '<h2>' . t(cdm_taxonpage_tab_label('Specimens')) . '</h2>' : ''),
//            'content' => $specimen_table, // returns render array
//            '#suffix' => '</div>',
//        );

can these be removed, or is there some reason for keeping 'em?

#21 Updated by Katja Luther 3 months ago

  • Assignee changed from Katja Luther to Andreas Kohlbecker

Andreas Kohlbecker wrote:

thank you for fixing this.

there are two commented code parts in this method:

//            $specimen_table['#rows'][] = array(
//                // An array of table rows. collapsible row
//                'data' => "",
//                'class' => array('expand_column')
//            );
//        $render_array['specimens'] = array(
//            '#prefix' => '<div id="specimens" class="page-part">' . ($page_part == 'all' ? '<h2>' . t(cdm_taxonpage_tab_label('Specimens')) . '</h2>' : ''),
//            'content' => $specimen_table, // returns render array
//            '#suffix' => '</div>',
//        );

can these be removed, or is there some reason for keeping 'em?

I think thas can be removed.

#22 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

dead code removed.

I think we can close this issue now since all open tasks have been copied to other tickets.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)