Project

General

Profile

bug #8365

DerivedUnitFacadeCacheStrategy should remove collection codes from accession numbers

Added by Andreas Kohlbecker about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
07/11/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

Users frequently enter the collection code with the accession number which can cause to code to appear duplicated in the portal and elsewhere.

To avoid this duplicate appearance the code should be stripped from the accession number in the DerivedUnitFacadeCacheStrategy

picture686-1.png View (33.7 KB) Andreas Kohlbecker, 07/12/2019 11:59 AM

picture406-1.png View (27 KB) Wolf-Henning Kusber, 07/16/2019 06:18 PM

picture171-1.png View (67.4 KB) Andreas Kohlbecker, 07/17/2019 09:02 AM

picture171-2.png View (65.9 KB) Andreas Kohlbecker, 07/17/2019 09:02 AM


Related issues

Copied from AlgenRegistrierung - task #8361: release portal vs. test portal Resolved 07/11/2019

Associated revisions

Revision f1248e50 (diff)
Added by Andreas Kohlbecker about 2 months ago

ref #8365 stripping collection code from accession number in DerivedUnitFacadeCacheStrategy

Revision a9b9edad (diff)
Added by Andreas Kohlbecker about 2 months ago

ref #8365 removing parentheses from code + accession number

Revision 3000a28d (diff)
Added by Andreas Kohlbecker about 1 month ago

ref #8365 stripping collection code from accession number only if followed by whitespace

Revision 35a38115 (diff)
Added by Andreas Kohlbecker about 1 month ago

ref #8365 putting parentheses back

Revision 12516e6b (diff)
Added by Andreas Kohlbecker about 1 month ago

ref #8365 removing parentheses from code + accession number - again

Revision 13581ffc (diff)
Added by Andreas Kohlbecker about 1 month ago

ref #8365 removing parentheses from code + accession number - again, adapting test

Revision 7449720a (diff)
Added by Andreas Kohlbecker 23 days ago

ref #8365 adding combination of collection code and unit number as specimenLabel to DerivedUnitFacade

Revision ab6c57c0 (diff)
Added by Katja Luther 19 days ago

ref #8365: fix NPE in abcd tests

History

#1 Updated by Andreas Kohlbecker about 2 months ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Kohlbecker to Andreas Müller
  • % Done changed from 0 to 50

We should also consider removing the parentheses from the accession number since this seems to be useless in most sitations.

#2 Updated by Andreas Kohlbecker about 2 months ago

  • Copied from task #8361: release portal vs. test portal added

#3 Updated by Andreas Kohlbecker about 2 months ago

  • Copied from deleted (task #8361: release portal vs. test portal)

#4 Updated by Andreas Kohlbecker about 2 months ago

  • Parent task set to #8361

#5 Updated by Andreas Kohlbecker about 2 months ago

  • Parent task deleted (#8361)

#6 Updated by Andreas Kohlbecker about 2 months ago

  • Copied from task #8361: release portal vs. test portal added

#7 Updated by Andreas Kohlbecker about 1 month ago

  • File picture686-1.png View added
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Wolf-Henning Kusber

I removed the parentheses but these now causes inconsistent display:

What do you think Henning?

#8 Updated by Wolf-Henning Kusber about 1 month ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

Reviewing the screen shot:
First representation: Lectotype (reference) gathering(Code accession number)
Second representation: Registration Name Type: gathering. Lectotype, Code accession number

I cannot see a problematic inconsitency because both are different representations with overlapping information. Both make sense, both are justified.

I would leave this as is (because it's fine).

#9 Updated by Andreas Kohlbecker about 1 month ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

OK, parentheses are removed again.

#10 Updated by Wolf-Henning Kusber about 1 month ago

  • File picture406-1.png View added
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 80

Quote

"OK, parentheses are removed again."

The brackets are reinstated not removed but should be removed, see Screen shot:

#11 Updated by Andreas Kohlbecker about 1 month ago

removing the parentheses would affect all portals. Before doing this we should keep the effect on other portals in mind and discuss this step with other users.

For example the Cichorieae synonym portal page for Youngia atripappa looks now like:

this would be changed to

The visual separation of the accession numbers from the preceding text is no less good without the parentheses.

#12 Updated by Andreas Kohlbecker about 1 month ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

#13 Updated by Wolf-Henning Kusber about 1 month ago

  • File picture714-1.png added
  • File picture714-2.png added

In the Youngia example the version with brackets is clearer.

#14 Updated by Andreas Kohlbecker about 1 month ago

  • File deleted (picture714-1.png)

#15 Updated by Andreas Kohlbecker about 1 month ago

  • File deleted (picture714-2.png)

#16 Updated by Andreas Kohlbecker about 1 month ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

ok, so i am closing this issue now

#17 Updated by Andreas Müller about 1 month ago

Andreas Kohlbecker wrote:

Users frequently enter the collection code with the accession number which can cause to code to appear duplicated in the portal and elsewhere.

This is not fully correct I think. The problem is that the collection code is sometimes part of the accession number (e.g. "B") which causes these problems.

#18 Updated by Andreas Müller about 1 month ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

To me there seems to be a misunderstanding. My understanding of #8365#note-8 is that is fine to have brackets for typification but NOT to have them for registration formatting. Only removing them for registration would not brake with any other portals.
So to me this seems to be the wanted behavior. But I don't know if this is possible or if both formattings work with the same formatter.

Just in case there is still any open question here.

#19 Updated by Andreas Müller about 1 month ago

One last question: is the original task of the ticket to deduplicate collection code if necessary now implemented in the cacheStrategy itself? This might be interesting to know as I think deduplication has also be done elsewhere in Portal and/or TaxEditor (by PP). Might be interesting to check if this is still needed then. Add PP and KL in cc for this.

#20 Updated by Andreas Müller about 1 month ago

Andreas Müller wrote:

To me there seems to be a misunderstanding. My understanding of #8365#note-8 is that is fine to have brackets for typification but NOT to have them for registration formatting. Only removing them for registration would not brake with any other portals.
So to me this seems to be the wanted behavior. But I don't know if this is possible or if both formattings work with the same formatter.

Just in case there is still any open question here.

I just see that on the name page it has been implemented correctly already. This was just reported in the ticket therefor my above comment.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)