Project

General

Profile

bug #8349

NPE in ParseHandler when parsing name without nomencl reference

Added by Katja Luther 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
07/04/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

when parsing name without nomenclatural reference the following NPE is thrown:

Caused by: java.lang.NullPointerException
               at eu.etaxonomy.taxeditor.parser.ParseHandler.resolveDuplicateReferences(ParseHandler.java:216)
               at eu.etaxonomy.taxeditor.parser.ParseHandler.resolveDuplicates(ParseHandler.java:181)
               at eu.etaxonomy.taxeditor.parser.ParseHandler.parseAndResolveDuplicates(ParseHandler.java:165)
               at eu.etaxonomy.taxeditor.editor.name.e4.container.AbstractGroupedContainerE4.persistName(AbstractGroupedContainerE4.java:446)
               at eu.etaxonomy.taxeditor.editor.name.e4.TaxonNameEditorE4.save(TaxonNameEditorE4.java:393)
               at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
               at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
               at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
               at java.lang.reflect.Method.invoke(Unknown Source)
               at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
               ... 48 more

Associated revisions

Revision 9ce386b8 (diff)
Added by Katja Luther 3 months ago

fix NPE in ParseHandler

History

#1 Updated by Katja Luther 3 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Patrick Plitzner
  • % Done changed from 0 to 80

please review, we need an hotfix because this error is always thrown if someone wants to create a new name without the nomencl reference

#2 Updated by Patrick Plitzner 3 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Patrick Plitzner to Katja Luther
  • % Done changed from 80 to 100

Tested local hotfix branch. Created a new taxon and, in the name editor, added and edited misapplications and synonyms with and without nomenclatural references. No NPE was thrown

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)