Project

General

Profile

bug #8313

Multiple categorical data get deleted when clicked on in Character Matrix

Added by Patrick Plitzner 12 months ago. Updated 5 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
05/28/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

If a cell has mutliple categorical data values and you click on it, the data is completely deleted. This does not happen when there is only a single value.


Related issues

Related to Edit - feature request #8775: Improve (rapid) data entry into characater matrix for categorical data New 12/17/2019
Related to Edit - feature request #8242: Implement filtered combo boxes for state selection in CharacterMatrix Closed 04/15/2019

Associated revisions

Revision 74e7e3df (diff)
Added by Patrick Plitzner 6 months ago

ref #8313 Return a collection of strings for display value

Revision a1171a3c (diff)
Added by Patrick Plitzner 6 months ago

ref #8313 Adapt display converter to Collection display value

History

#1 Updated by Patrick Plitzner 11 months ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Tilo Henning
  • % Done changed from 0 to 50

#2 Updated by Patrick Plitzner 11 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Tilo Henning to Patrick Plitzner
  • % Done changed from 50 to 100

Tilo tested on nightly. Works as expected.

#3 Updated by Andreas Müller 10 months ago

  • Target version changed from Release 5.10 to Release 5.8

Move back to 5.8 as this seems to be ready in 5.8 milestone

#4 Updated by Andreas Müller 6 months ago

  • Status changed from Closed to Feedback
  • Target version changed from Release 5.8 to Release 5.12

Reopen as it happens again.

How to reproduce: in any categorical cell select 2 states. Leafe the cell (it shows both states in the label) reenter => label field is empty (only [])

#5 Updated by Patrick Plitzner 6 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 100 to 90

#6 Updated by Andreas Müller 5 months ago

  • Related to feature request #8775: Improve (rapid) data entry into characater matrix for categorical data added

#7 Updated by Andreas Müller 5 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner
  • % Done changed from 90 to 100

This seems to work now. There are issues with the general (rapid) data entry of categorical data into the matrix. These are handled in #8775

#8 Updated by Andreas Müller 5 months ago

  • Related to feature request #8242: Implement filtered combo boxes for state selection in CharacterMatrix added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)