Project

General

Profile

bug #8260

Details and Supplemental Data View do not save the expansion state of sections

Added by Patrick Plitzner 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
05/07/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

This is a regression as it worked before. This may have to do with the revamp of the preferences in general.

Associated revisions

Revision 544be2e6 (diff)
Added by Katja Luther 7 months ago

ref #8260: save expansion state for supplemental data

Revision a2fa71cf (diff)
Added by Katja Luther 7 months ago

ref #8260: save expansion state for supplemental data

Revision 175fef3e (diff)
Added by Katja Luther 6 months ago

ref #8260: save expansion state for supplemental data

Revision 41baf435 (diff)
Added by Katja Luther 6 months ago

ref #8260: save expansion state for supplemental data

Revision 98db3bf7 (diff)
Added by Patrick Plitzner 6 months ago

ref #8260 Complete refactoring of expansion state saving

Revision dd5402d9 (diff)
Added by Patrick Plitzner 6 months ago

ref #8260 Fix version and UUID/ID section in supp data view

Revision 20b35d99 (diff)
Added by Patrick Plitzner 5 months ago

ref #8260 Fix string comparison

History

#1 Updated by Andreas Müller 7 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.8

#2 Updated by Katja Luther 7 months ago

For SupplementalData the preference for expansion state was not evaluated, this is fixed with revision 544be2e6d53d1b65177dbf3e41cbd8c4b6fe9d63

#3 Updated by Patrick Plitzner 7 months ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 50

#4 Updated by Andreas Müller 6 months ago

Should we add to HFX?

#5 Updated by Andreas Müller 6 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

In most cases it seems to work fine. But it does not seem to work for ScientificName and Authorship which always seem to be expanded (if the complete Name section is expanded) while Hybrid always seems to be collapsed.

#6 Updated by Andreas Müller 6 months ago

The above issues are minor. Katja, can you still cherry pick the up-to-now changes as it already improves the situation a lot.

#7 Updated by Katja Luther 6 months ago

cherry-picked to hotfix/5.7.3

#8 Updated by Katja Luther 6 months ago

  • Target version changed from Release 5.8 to Release 5.7

#9 Updated by Andreas Müller 6 months ago

  • Target version changed from Release 5.7 to Release 5.8

maybe we should keep the milestone here at this is not yet fully fixed.

#10 Updated by Patrick Plitzner 6 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 80

This should now be fixed. The state of all subsections was not saved before.

#11 Updated by Andreas Müller 5 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

Now, nomenclatural reference is never expanded. Maybe it was like this before already and I simply did not recognize.

#12 Updated by Patrick Plitzner 5 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Andreas Müller wrote:

Now, nomenclatural reference is never expanded. Maybe it was like this before already and I simply did not recognize.

The nomenclatural reference should initially be expanded. If you expand it, does it not save the state? Did you clear the preferences?

#13 Updated by Andreas Müller 5 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

Patrick Plitzner wrote:

Andreas Müller wrote:

Now, nomenclatural reference is never expanded. Maybe it was like this before already and I simply did not recognize.

The nomenclatural reference should initially be expanded. If you expand it, does it not save the state? Did you clear the preferences?

No, it does not save the state.
Which preference?
Have yo tested on your machine?

#14 Updated by Patrick Plitzner 5 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Andreas Müller wrote:

Patrick Plitzner wrote:

Andreas Müller wrote:

Now, nomenclatural reference is never expanded. Maybe it was like this before already and I simply did not recognize.

The nomenclatural reference should initially be expanded. If you expand it, does it not save the state? Did you clear the preferences?

No, it does not save the state.
Which preference?
Have yo tested on your machine?

I tested locally and on nightly/rem_conf_am.

Try deleting/renaming/moving EDIT Taxonomic Editor/configuration/.settings/eu.etaxonomy.taxeditor.store.prefs and see if this solves the problem. Maybe there were some incompatibilities with existing local preferences.

#15 Updated by Andreas Müller 5 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner
  • % Done changed from 80 to 90

Fix 20b35d99 seems to solve the problem. I think we can close the ticket.

#16 Updated by Patrick Plitzner 5 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)