Project

General

Profile

feature request #8253

Authors for genus autonyms

Added by Andreas Müller 7 months ago. Updated about 8 hours ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
05/02/2019
Due date:
% Done:

100%

Severity:
normal

Description

ERS:

den Autor bei infragenerischen Taxa hinter den gesamten Namen zu stellen, wie jetzt in Euro+Med, ist mit Sicherheit falsch.

Richtig wäre, das Autorkürzel hinter den Gattungsnamen zu stellen; oft wird darauf in der Literatur aber auch verzichtet. Vielleicht ein Thema für die User Group, was in den einzelnen Portalen gewünscht ist.

====

AM:

ich bin gerade über 2 infragenerische Autonyme gestolpert:

Taraxacum sect. Taraxacum:
http://ww2.bgbm.org/EuroPlusMed/PTaxonDetail.asp?NameCache=Taraxacum%20sect.%20Taraxacum&PTRefFk=7700000

und Orobanche sect. Orobanche

und frage mich wie dort die richtige Verwendung des Autors aussieht.

Bei infraspezifischen Taxa wird der Autor ja hinter das Speciesepithet gestellt. Wird es bei infragenerischen hinter die Gattung gestell oder hinter den gesamten Namen?

In derzeitigen E+M Portal scheint letzteres der Fall zu sein. Im CDM habe ich eine Implementierung ganz ohne Autor, was mir ziemlich sicher falsch zu sein scheint.


Related issues

Copied to Edit - bug #8681: Fix sect. parsing New 11/14/2019

Associated revisions

Revision 6d023e40 (diff)
Added by Andreas Müller 8 days ago

fix #8253 correct parsing and formatting for authors of infra generic autonyms

Revision 6ef5a0b1 (diff)
Added by Andreas Müller 6 days ago

fix #8253 fix problem with infrageneric autonyms full reference parsing

History

#1 Updated by Andreas Müller 7 months ago

  • Tags changed from euro+med to euro+med, formatting

#2 Updated by Andreas Müller 6 months ago

  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.8

#3 Updated by Andreas Müller 4 months ago

  • Target version changed from Release 5.8 to Release 5.10

#4 Updated by Andreas Müller about 2 months ago

  • Target version changed from Release 5.10 to Release 5.11

#5 Updated by Andreas Müller 8 days ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#6 Updated by Andreas Müller 8 days ago

  • Assignee changed from Andreas Müller to Katja Luther

Please review

#7 Updated by Katja Luther 6 days ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Katja Luther to Andreas Müller

when entering Achnanthes Bory sect. Achnanthes in NameEditor the rank and epithets are not parsed correctly.

The editor shows warning "check rank" and "parsing problem"

#8 Updated by Andreas Müller 6 days ago

OK, the problem is I used parseFullName in NonViralNameParserImplTest. But the editor use parseReferencedName I guess. I try to fix this so it runs with the later, too.

#9 Updated by Andreas Müller 6 days ago

  • Status changed from Feedback to Resolved

#10 Updated by Andreas Müller 6 days ago

  • Assignee changed from Andreas Müller to Katja Luther

should be fixed now

#11 Updated by Andreas Müller 6 days ago

Hm, strange, it still doesn't seem to work. Though there is a test with the exact same string "" in NonViralNameParserImplTest.testAutonyms() line 379ff.

Can you please check what is different in TaxEditor compared to the test?

#12 Updated by Andreas Müller 6 days ago

Very strange, it seems to work with Achnanthes Bory subg. Achnanthes but not with Achnanthes Bory sect. Achnanthes. Though the above mentioned test uses the later.

#13 Updated by Katja Luther 3 days ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Katja Luther to Andreas Müller

Creating a section Achnanthes sect. Achnanthes and adding an author also results in Achnanthes sect. Achnanthes Bory, maybe the section is not handled as infrageneric?

#14 Updated by Andreas Müller 2 days ago

Katja Luther wrote:

Creating a section Achnanthes sect. Achnanthes and adding an author also results in Achnanthes sect. Achnanthes Bory, maybe the section is not handled as infrageneric?

Are you sure you selected sect. (bot) and ICNAFP?

The formatter should work correctly with the correct rank and with ICNAFP names.

#15 Updated by Andreas Müller 2 days ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Andreas Müller to Katja Luther

By the way the parser for me now also works with names like "Achnanthes Bory sect. Achnanthes". So can you please check again.

Definetely it is important that the parser nows a INCNAFP name is required, so if the parser does not get this information there might be problems.

#16 Updated by Katja Luther 1 day ago

Katja Luther wrote:

Creating a section Achnanthes sect. Achnanthes and adding an author also results in Achnanthes sect. Achnanthes Bory, maybe the section is not handled as infrageneric?

this works now, maybe cdmlib was not correctly updated

#17 Updated by Katja Luther about 9 hours ago

I found the cause of the parsing problem:

when searching for the rank by Rank.getRankByIdInVoc(infraGenRankMarker) the infraGenRankMarker is normalized to sect.(bot), but in the map of the idInVocMap the idInVocabulary is sect. not sect.(bot).

#18 Updated by Katja Luther about 8 hours ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Katja Luther to Andreas Müller

#19 Updated by Andreas Müller about 8 hours ago

  • Assignee changed from Andreas Müller to Katja Luther

Can you give some more information where to find these things? Especially "map of the idInVocMap "

#20 Updated by Katja Luther about 8 hours ago

Andreas Müller wrote:

Can you give some more information where to find these things? Especially "map of the idInVocMap "

this is in Rank.java and the map idInVocMap is filled with the ranks of the instance. for example in E+M the idInVoc of the rank Section (Botany) is "sect." not "sect.(bot.)" and therefore in this map the key is "sect."

#21 Updated by Andreas Müller about 8 hours ago

  • Status changed from Feedback to Closed
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 50 to 100

I found the place. And probably fixed it but will not commit before release as it needs to be further tested.

Create new ticket for the fix in 5.12: #8681

#22 Updated by Andreas Müller about 8 hours ago

  • Copied to bug #8681: Fix sect. parsing added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)