Project

General

Profile

bug #8252

reference ellypsis must not be applied to all reference types

Added by Wolf-Henning Kusber 6 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
04/30/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description


Journal titles in dropdown list in reference editor must not be truncated.

How to differentiate between "Archiv für Hydrobiologie" und "Archiv für Hydrobiologie und Planktonkunde"?

picture551-1.png View (7.01 KB) Wolf-Henning Kusber, 04/30/2019 03:09 PM

picture017-1.png View (59.2 KB) Wolf-Henning Kusber, 05/07/2019 06:16 PM

picture461-1.png View (14.5 KB) Wolf-Henning Kusber, 05/22/2019 06:08 PM

picture461-2.png View (16.6 KB) Wolf-Henning Kusber, 05/22/2019 06:08 PM

picture461-3.png View (44.2 KB) Wolf-Henning Kusber, 05/22/2019 06:08 PM

picture461-4.png View (55 KB) Wolf-Henning Kusber, 05/22/2019 06:08 PM


Related issues

Related to Edit - task #8209: use ellypsed references for all reference comboboxes Resolved 03/28/2019
Related to Edit - bug #8375: ReferenceEllypsisFormatter produces too long stings in specific cases New 07/17/2019

Associated revisions

Revision 6efa5535 (diff)
Added by Andreas Kohlbecker 6 months ago

ref #8252 improving ReferenceEllypsisFormatter for journals and other references where the main information is in the title

Revision 4724d189 (diff)
Added by Andreas Kohlbecker 6 months ago

ref #8252 improving ReferenceEllypsisFormatter for print series and proceedings

Revision b25e560f (diff)
Added by Andreas Kohlbecker 5 months ago

ref #8252 preserving section authors and better title compentation

History

#1 Updated by Andreas Kohlbecker 6 months ago

  • Subject changed from Journal titles in dropdown list truncated to reference ellypsis must not be applied to all reference types
  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.7

I think the same accounts for book series etc.

the reference title cache ellypsis must not be applied to all reference types.

Which types need to be excluded?

#2 Updated by Wolf-Henning Kusber 6 months ago

reference title cache ellypsis must not be applied to:
Book series
Journal
Proceedings
i.e. all standardised invariable entries selected by many references/items.

#3 Updated by Andreas Kohlbecker 6 months ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 0 to 50

done! please review.

#4 Updated by Wolf-Henning Kusber 6 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

All Titles are given fully up to a length of approx. 60 characters.

This is okay (i) because the the title can be identified, (ii) the full title can be checked by clicking the edit button.

Example:
Abhandlungen der Naturhistorischen Gesellschaft zu Nürnberg
fully given
Mémoires du Muséum National d'Histoire Naturell, Nouvelle ...
truncated, full title is:
Mémoires du Muséum National d'Histoire Naturell, Nouvelle Série, Série B, Botanique

I can live with this.

Further issues:
Proceedings can not tested because of lacking data (ToDo WHK)
Series include Series and Jounals (This should be checked and tested by WHK)

I propose to set this ticket to 100% and close it, agreed?

#5 Updated by Andreas Kohlbecker 6 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

All Titles are given fully up to a length of approx. 60 characters.

This is okay (i) because the the title can be identified, (ii) the full title can be checked by clicking the edit button.

It is also possible to skip the ellipsis completely in this case some titles could exceed the given space, though.
What is the best solution from the user perspective?

#6 Updated by Wolf-Henning Kusber 6 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

"It is also possible to skip the ellipsis completely in this case some titles could exceed the given space, though.
What is the best solution from the user perspective?"

In the following case:
Mémoires du Muséum National d'Histoire Naturell, Nouvelle ...
truncated, full title is:
Mémoires du Muséum National d'Histoire Naturell, Nouvelle Série, Série B, Botanique

it could be that an informative (=distinctive) part comes after the ellipsis. So to be on the safe side it would be better to skip the ellipsis completely for the given Reference types.

#7 Updated by Andreas Kohlbecker 5 months ago

  • Related to task #8209: use ellypsed references for all reference comboboxes added

#8 Updated by Wolf-Henning Kusber 5 months ago

Ellipsis must not be applied to in-authors/nomenclatural author team.
Example:
How to correct
Kulikowski, Metzeltin & Lange-Bert.
to
Kulikowski, Lange-Bert. & Metzeltin ? See screen shot.

(Reference itself is okay)

#9 Updated by Andreas Kohlbecker 5 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

Wolf-Henning Kusber wrote:

Ellipsis must not be applied to in-authors/nomenclatural author team.
Example:
How to correct
Kulikowski, Metzeltin & Lange-Bert.
to
Kulikowski, Lange-Bert. & Metzeltin ? See screen shot.

(Reference itself is okay)

This means implementing the rule that the ellypsis must not be applied to sections having an article as inReference. But what if the list of authors is quite long? I am thinking of cases with ~10 authors in the team. In this case the the text line shown in the combobox would be quite/too long again.

#10 Updated by Wolf-Henning Kusber 5 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

For a pragmatic approach (as of 16 May 2019):
Currently: only 20% authors can be recognized. That means that each needed section author team is newly established and produces duplicats or multiple entries.

If 20% of authorteams have one author, 20% = two authors, 20% = three authors, 20% = four authors, 20% >=five authors:

I need the correct author team, i.e. if nomenclatural authors are section authors, I need these, if nomenclatural authors are identical to bibliographic authors, I need those (but in the latter case, I can check the bibliographic reference)

If cut off after the second author = 40% of author teams can be recognized.
If cut off after the third author = 60% of author teams can be recognized.
If cut off after the fourth author = 80% of author teams can be recognized.
If no cut off = 100% of author teams can be recognized BUT the string is to long.

A pragmatic approach for users would be 80% (60% only if the developer has major problems)

#11 Updated by Andreas Kohlbecker 5 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

Would using the acronyms or truncating the names of the section authors to acronyms be helpful?
e.g.:

  • Kulikowsy M --> K. M.
  • Lange-Bertalot Horst --> H. L-B.

#12 Updated by Wolf-Henning Kusber 5 months ago

not realy, people do not know alle given names.
How I could differentiat between D.M. (= Ditmar Metzeltin) and D.M. (= David Mann)?

But this opens also a new issue:
Why the bibliographic representation of nomencaltural authors is used?

#13 Updated by Andreas Kohlbecker 5 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

#14 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from Feedback to In Progress

During a phone call today we decided to give the following solution a try:

  1. The section author team will be truncated after the 4th author name
  2. Other reference types should be ellypsed 'normally'

IMPORTANT: The nom. reference combobox is showing bibliographic authors instead of the nomenclatural vaviant - this needs to be fixed!

#15 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 50 to 60

The improvement is implemented, please review once the test server is updated.

#16 Updated by Wolf-Henning Kusber 5 months ago


six section nomenclatural authors
three authors "et al." displayed. This should be acceptable by users.
Authors are bibliographic (see above)


In the "Registration Workingset Editor" view the six nomenclatural authors are perfectly displayed.


Selection in the Reference Edior opening a section:
three authors "et al." displayed. This should be acceptable by users.
Authors are bibliographic (see above)

No issue: collector(s) in Specimen Typedesignation editor:

three authors "et al." displayed. This should be acceptable by users.
Authors are bibliographic (here this is perfect, because collectors can be bibliographic without being nomenclatural authors)

#17 Updated by Andreas Kohlbecker 5 months ago

Since there are no more obvious problems with reference ellypsis we can close this issue, agreed?

#18 Updated by Andreas Kohlbecker 5 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 80 to 90

#19 Updated by Wolf-Henning Kusber 5 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 90 to 100

Technically the problem is solved.

As far as we keep the "bibliographic authors" issue in mind, we can close this ticket.

#20 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from Resolved to Closed

The issue of bibliographic authors being displayed for the nomenclatural reference is also fixed now.

#21 Updated by Andreas Kohlbecker 3 months ago

  • Related to bug #8375: ReferenceEllypsisFormatter produces too long stings in specific cases added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)