Project

General

Profile

bug #825

DefinedTermDaoImpl - missleading method names

Added by Andreas Kohlbecker over 12 years ago. Updated 24 days ago.

Status:
Closed
Priority:
New
Category:
cdmlib
Target version:
Start date:
06/22/2009
Due date:
% Done:

100%

Severity:
major
Found in Version:
Tags:

Description

DefinedTermDaoImpl implements

findByTitle(String queryString);
findByTitle(String queryString, CdmBase sessionObject);

which is declared in ITitledDao. The name suggests a search by title the implementation however does a search by label. All other findByTitle methods are implemented correctly.

Associated revisions

Revision 0dd6415a (diff)
Added by Andreas Müller 29 days ago

fix #825 rename method that searches by representation label in term dao

History

#1 Updated by Andreas Kohlbecker over 12 years ago

  • Severity changed from normal to major

#2 Updated by Andreas Müller about 12 years ago

  • Assignee changed from Andreas Müller to Andreas Kohlbecker

Andreas K., could you please check if this has been fixed by Ben's latest work on CdmLibraryConventions?

#3 Updated by Andreas Kohlbecker almost 12 years ago

  • Target version changed from CDM lib Release 2.0 to CDM lib Release 2.3

#4 Updated by Andreas Müller 4 months ago

  • Description updated (diff)
  • Assignee changed from Andreas Kohlbecker to Andreas Müller
  • Target version changed from cdmlib - Old Next Major Release to Release 5.28

This is still an open issue.

#5 Updated by Andreas Müller 4 months ago

  • Tags set to fast

#6 Updated by Andreas Kohlbecker 3 months ago

  • Private changed from Yes to No

#7 Updated by Andreas Müller 29 days ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#8 Updated by Andreas Müller 29 days ago

  • Assignee changed from Andreas Müller to Andreas Kohlbecker

This is fixed. Please review.

As the old method findByTitle which did override the same labeled parent method seems to be only called by test methods there seems to be no danger that this change created a regression as it is not API but dao.

#9 Updated by Andreas Müller 24 days ago

  • Target version changed from Release 5.28 to Release 5.27

#10 Updated by Andreas Kohlbecker 24 days ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Kohlbecker to Andreas Müller
  • % Done changed from 50 to 100

fully solved

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)