Project

General

Profile

feature request #8215

User demand: sorting order in reference editor

Added by Wolf-Henning Kusber about 2 months ago. Updated 23 days ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
04/01/2019
Due date:
% Done:

100%

Severity:
normal
Tags:

Description

Reference editor:
Author and in-Ref are sorting "contains".
User demand: sorting should be "begins with"

Example: Searching for "Witk" works not as expected, giving first Witkowski, than Witkowski & A, Witkowski & B

picture313-1.png View (77.9 KB) Wolf-Henning Kusber, 04/01/2019 11:07 AM


Related issues

Related to Edit - task #8209: use ellypsed references for all reference comboboxes Resolved 03/28/2019

Associated revisions

Revision 5acf0504 (diff)
Added by Andreas Kohlbecker 25 days ago

fix #8215 changing default match mode for reference paging provider to BEGINNING

Revision 7a5312a7 (diff)
Added by Andreas Kohlbecker 24 days ago

ref #8215 using match mode BEGINNING for all AgentBase paging providers, also centralizing the construction

History

#1 Updated by Andreas Kohlbecker about 2 months ago

  • Related to task #8209: use ellypsed references for all reference comboboxes added

#2 Updated by Andreas Kohlbecker about 2 months ago

  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.6

#3 Updated by Andreas Kohlbecker about 1 month ago

  • Target version changed from Release 5.6 to Release 5.7

#4 Updated by Andreas Kohlbecker 25 days ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#5 Updated by Andreas Kohlbecker 25 days ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

done! Please test if the behavior is acceptable now.

#6 Updated by Wolf-Henning Kusber 25 days ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

User demand: sorting should be "begins with" not implemented. Sorting as shown on the screen shot.

#7 Updated by Andreas Kohlbecker 24 days ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

I also worked on the persons and teams please review again

#8 Updated by Wolf-Henning Kusber 24 days ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 100

I tested the respective case. The problem is perfectly solved. The ticket can be closed

#9 Updated by Andreas Kohlbecker 23 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)