Project

General

Profile

bug #8191

ReferencePopupEditor: When coming from NameEdior editing of the inreference should not be blocked

Added by Andreas Kohlbecker 30 days ago. Updated 25 days ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
03/21/2019
Due date:
% Done:

100%

Severity:
critical
Found in Version:
Tags:

Description

By now when opening the ReferenceEditor for inReference of a TaxonName the user can not modify or set a new inreference. This should be allowed however.

originally reported by Henning:


Beim Basionym hatte ich Section=Fritsch in Fritsch 1929 The encrusting algal communities of certain fast–flowing streams. In undefined journal.
Unser User hat versucht, das Journal im Reference editor einzufügen, das ist disabled (Screen shot). Unser User hatte nicht probiert, die Referenz zu bearbeiten, dort geht es das Journal auszuwählen.

picture864-1.png View (35.8 KB) Andreas Kohlbecker, 03/21/2019 06:55 PM

Associated revisions

Revision 78159090 (diff)
Added by Andreas Kohlbecker 29 days ago

ref #8191 intoducing the long awaited EditorFormConfigurator for fine tuning of the inReference button enabled states

Revision 34d43087 (diff)
Added by Andreas Kohlbecker 26 days ago

ref #8191 intoducing the long awaited EditorFormConfigurator for fine tuning of the inReference button enabled states

History

#1 Updated by Andreas Kohlbecker 30 days ago

  • Subject changed from ReferencePopupEditor: When coming from NameEdior editing of the ireference should not be blocked to ReferencePopupEditor: When coming from NameEdior editing of the inreference should not be blocked

#2 Updated by Andreas Kohlbecker 30 days ago

#3 Updated by Andreas Kohlbecker 26 days ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 0 to 50

please review

#4 Updated by Wolf-Henning Kusber 26 days ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 100

I was able to include new journal names in Basionym references. I included sections in the name editor and was able to go to the in-reference and edit it. I think, the problem is solved and the ticket can be closed. If not we could reopen the ticket later.

#5 Updated by Andreas Kohlbecker 25 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)