Project

General

Profile

Actions

bug #8152

closed

ReferencePopupEditor: inReference field allows to select references with type GEN but field validation fails in this case

Added by Andreas Kohlbecker almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Highest
Category:
cdm-vaadin
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Severity:
critical
Found in Version:
Tags:

Description

Heba reported an error which was due the Journal "Rickia" having the Referencetype 'Generic'

The reference could be selected in the inreference field but the fields was "red" afterwards and the editor could not be saved:

The editor should suggest the user to fix the reference type in case the type is "Generic".
In case the reference type is not matching the required type afterwards the selection in the field will fail or the reference just disappears, these cases must be communicated to the user in a proper way.


Files

picture065-1.png (50.3 KB) picture065-1.png Andreas Kohlbecker, 02/28/2019 01:05 PM

Related issues

Is duplicate of EDIT - bug #8149: ReferenceEditor: filter inReferences ONLY by applicable reference type suppess Generic and NULLClosedAndreas Kohlbecker

Actions
Actions #1

Updated by Andreas Kohlbecker almost 4 years ago

  • Subject changed from ReferencePopupEditor: inReference field allows to select references with missing type but field validation fails in this case to ReferencePopupEditor: inReference field allows to select references with type GEN but field validation fails in this case
  • Description updated (diff)
Actions #2

Updated by Andreas Kohlbecker almost 4 years ago

  • Status changed from New to Duplicate
  • Target version deleted (Release 5.6)

Henning: References with type 'Generic' must not be in the list, filter only by matching type

So this is a duplicate of #8149

Actions #3

Updated by Andreas Kohlbecker almost 4 years ago

  • Is duplicate of bug #8149: ReferenceEditor: filter inReferences ONLY by applicable reference type suppess Generic and NULL added
Actions

Also available in: Atom PDF