Project

General

Profile

bug #8050

Create blocking registrations for un-registered names which are to be used in nomenclatural acts

Added by Andreas Kohlbecker 9 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
01/31/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

Implement the policy as defined in #8049:

Wenn in einem nomenklatorischen Akt ein Name verwendet wird, der noch nicht registriert ist, wird eine sog. Bloking-Registration für diesen Namen erzeugt, es sei denn der Name wird in einem WeaklyRelatedEntityField verwendet" (WeaklyRelatedEntityField ist das Eingabe-Element, das für die Genera im Falle von Species im TaxonNamePopupEditor verwendet wird)


Related issues

Related to PhycoBank - task #8049: Blocking registration policy Closed 01/31/2019

Associated revisions

Revision 68afc0ec (diff)
Added by Andreas Kohlbecker 7 months ago

ref #8050 moving transactional code from RegistrationWorkingsetPresenter to new service class

Revision 4e29c10f (diff)
Added by Andreas Kohlbecker 7 months ago

ref #8050 creating blocking registrations for exising names which are used in the context of another registration

Revision eee96dac (diff)
Added by Andreas Kohlbecker 7 months ago

ref #8050 moving transactional code from RegistrationWorkingsetPresenter to new service class

Revision 8af7fcc2 (diff)
Added by Andreas Kohlbecker 7 months ago

ref #8050 creating blocking registrations for exising names which are used in the context of another registration

Revision ee57c0d9 (diff)
Added by Andreas Kohlbecker 7 months ago

ref #8050 fixing bug in reloadRegistrtions() and removing remain from previous conflict

Revision a6edfc5a (diff)
Added by Andreas Kohlbecker 7 months ago

ref #8050 fixing bug in reloadRegistrtions() and removing remain from previous conflict

Revision 6062e4a0 (diff)
Added by Andreas Kohlbecker 7 months ago

ref #8050 validing related name nomenclatural reference to require the user to add missing references when reusing an exising name

Revision 580d5157 (diff)
Added by Andreas Kohlbecker 7 months ago

ref #8050 validing related name nomenclatural reference to require the user to add missing references when reusing an exising name

History

#1 Updated by Andreas Kohlbecker 9 months ago

  • Related to task #8049: Blocking registration policy added

#2 Updated by Andreas Kohlbecker 7 months ago

  • Description updated (diff)

#3 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from New to In Progress

#4 Updated by Andreas Kohlbecker 7 months ago

Wenn man versehentlich einen falschen namen z.B. als Basionym auswählt, würde dann für diesen Namen eine Blocking-Registration erzeugt werden. Das kann bei großer Schusseligkeit lästig werden.

#5 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from In Progress to Feedback
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 0 to 10

There will be situations in which the existing name will not yet have a nomenclatural reference. Creating a Registration for this name will result in a Registration which can not be related to a citation and thus in a broken registration working set.

Solutions:

  1. Require the user to add a reference to the name before the popup editor in which the name is references can be saved.
  2. Extend the RegistrationItemComponents:
    • allow editing names and type even if there is no common citation.
    • add a message box to notify the user about the problem and give a hint towards a solution.

This needs to be discussed.

#6 Updated by Andreas Kohlbecker 7 months ago

  • % Done changed from 10 to 30

#7 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

We agreed on solution 1. from above: "Require the user to add a reference to the name before the popup editor in which the name is references can be saved."

The other potential problem named in comment 4 will be hanled by the curator: The unnecessary registrations will be set to REJECTED

#8 Updated by Wolf-Henning Kusber 7 months ago

Solution 1 should also preclude name duplicates.

#9 Updated by Andreas Kohlbecker 7 months ago

Wolf-Henning Kusber wrote:

Solution 1 should also preclude name duplicates.

this should be handled in a separate ticket: #8207

#10 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 30 to 50

I consider this issue as being completed, please review

#11 Updated by Wolf-Henning Kusber 6 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

Related to #8217
If a name without reference is in the dropdown list, the user is forced to add a reference.
This is true for IAPT imports.

Genera imported for the taxon graph AND species eintered in the TaxEditor as name only are not available.

Tested with new name in field replaced synonym.
Tested with existing name.
Both tests failed.

#12 Updated by Wolf-Henning Kusber 6 months ago

Poposal: Make names (stored in the system) available [as new names as well as for existing names]. For genera, the author team is missing, this can be fixed by adding a reference including authors. Correct?

#13 Updated by Andreas Kohlbecker 6 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

I cannot reproduce the problems mentioned in comment 12 and 13.

#14 Updated by Andreas Kohlbecker 6 months ago

  • Subject changed from Create blocking relations for un-registered names which are to be used in nomenclatural acts to Create blocking registrations for un-registered names which are to be used in nomenclatural acts

#15 Updated by Andreas Kohlbecker 5 months ago

Hi Henning

i could not reproduce the problem that

Genera imported for the taxon graph AND species eintered in the TaxEditor as name only are not available.

is this still valid?
If not, is there anything else to to about this issue?

#16 Updated by Wolf-Henning Kusber 4 months ago

Das Problem in #11 und #12:

Konkret möchte ich für einen existierenden Namen, z.B. "Micrasterias" einen (Namens-)Typus anlegen. Ich gehe in existing names und finde den Namen nicht, da er zwar im System ist, aber keine Referenz und keine Autoren hat. Meine Überlegung war, dass ich dann ein Duplikat "Micrasterias" mit Autor und Referenz erstellen müsste, statt "Micrasterias" aus dem System zu ergänzen.

#17 Updated by Wolf-Henning Kusber 4 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

#18 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from Feedback to Resolved

Wolf-Henning Kusber wrote:

Das Problem in #11 und #12:

Konkret möchte ich für einen existierenden Namen, z.B. "Micrasterias" einen (Namens-)Typus anlegen. Ich gehe in existing names und finde den Namen nicht, da er zwar im System ist, aber keine Referenz und keine Autoren hat. Meine Überlegung war, dass ich dann ein Duplikat "Micrasterias" mit Autor und Referenz erstellen müsste, statt "Micrasterias" aus dem System zu ergänzen.

Das ist ein anderes Problem/Thema als das was in diesem Ticket hier behandelt wird. Ich schlage daher vor dieses Problem gesondert zu diskutieren und dieses Ticket hier zu schließen.

#19 Updated by Wolf-Henning Kusber 4 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

Okay, da offene Punkt auch mit Workflows zu tun hat, sollten wir den kommende Woche diskutieren. Schließe wie besprochen dies Ticket.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)