Project

General

Profile

Actions

bug #7990

closed

Moving a feature via d&d does not make the Feature Tree Editor dirty

Added by Andreas Müller over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

This is because moving feature currently requires prior save and the move operation is handled server side.

As the Feature Tree Editor is not a pure navigator and appears in the Editor part (in the middle) this is unepected behavior. We need to discuss want the best behavior is, either we implement d&d as client side action or we make the Feature Tree Editor more a navigator whith more separated functionality for editing a node and moving nodes as it is in taxon navigator.


Related issues

Related to EDIT - feature request #7873: Implement copy&paste for feature nodes in feature tree editorClosedPatrick Plitzner

Actions
Has duplicate EDIT - bug #8021: d&d in feature tree editor should not require savingDuplicatePatrick Plitzner

Actions
Is duplicate of EDIT - bug #8774: Reimplement term tree editors to implement the general save strategyClosedKatja Luther

Actions
Actions #1

Updated by Andreas Müller over 3 years ago

Actions #2

Updated by Andreas Müller over 3 years ago

  • Has duplicate bug #8021: d&d in feature tree editor should not require saving added
Actions #3

Updated by Patrick Plitzner over 3 years ago

  • Priority changed from New to Highest
Actions #4

Updated by Patrick Plitzner over 3 years ago

  • Tags set to additivity
Actions #5

Updated by Patrick Plitzner over 3 years ago

  • Target version changed from Release 5.6 to Reviewed Next Major Release
Actions #6

Updated by Andreas Müller almost 3 years ago

  • Target version changed from Reviewed Next Major Release to 287
Actions #7

Updated by Andreas Müller almost 3 years ago

  • Assignee changed from Patrick Plitzner to Katja Luther
  • Target version changed from 287 to Release 5.13

In general the feature tree editor should persist data only after pushing save and therefore needs to be refactored. Feal free to open a new ticket or handle this in this ticket, too.

Actions #8

Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.13 to Release 5.14
Actions #9

Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.14 to Release 5.15
Actions #10

Updated by Katja Luther over 2 years ago

  • Target version changed from Release 5.15 to Release 5.18
Actions #11

Updated by Katja Luther over 2 years ago

  • Target version changed from Release 5.18 to Release 5.15
Actions #12

Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.15 to Release 5.18
Actions #13

Updated by Katja Luther almost 2 years ago

  • Target version changed from Release 5.18 to Release 5.19
Actions #14

Updated by Andreas Müller almost 2 years ago

  • Status changed from New to Feedback

Is this still an open issue with the new term tree implementation? If not we should close it as works for me or as duplicate for the term tree ticket.

Actions #15

Updated by Katja Luther almost 2 years ago

  • Status changed from Feedback to Closed

ups no, this issue is solved with the new implementation.

Actions #16

Updated by Andreas Müller almost 2 years ago

  • Is duplicate of bug #8774: Reimplement term tree editors to implement the general save strategy added
Actions

Also available in: Atom PDF