Project

General

Profile

bug #7969

Default Feature Tree created on serverside contains only one featureNode but this is used in a loop

Added by Katja Luther almost 3 years ago. Updated over 2 years ago.

Status:
New
Priority:
Highest
Assignee:
Category:
taxeditor
Start date:
01/07/2019
Due date:
% Done:

0%

Severity:
normal
Found in Version:

Description

When the taxeditor loads the default feature tree with an uuid but the table is empty or the uuid is the uuid of the defaultFeatureTree the tree is created on the fly.This works correctly and a feature tree with all terms of type "feature" is created. But the feature tree used in the editor contains only one FeatureNode, but every Node contains itself as child. And the rootNode contains this node as many times as the original feature tree contained features.

When going through the tree results in an endless loop.

When the default feature tree is created on taxeditor side, it works correctly.


Related issues

Related to Edit - feature request #8432: Improve "default" feature tree handling In Progress 07/31/2019
Related to Edit - feature request #7970: Default Feature Tree Preference New 01/07/2019

History

#1 Updated by Katja Luther over 2 years ago

  • Target version changed from Release 5.5 to Release 5.6

#2 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.6 to Reviewed Next Major Release

#4 Updated by Andreas Müller 4 months ago

#5 Updated by Andreas Müller 4 months ago

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)