Project

General

Profile

bug #7933

Adding a new Term to the "Country" vocabulary leads to corrupt data

Added by Patrick Plitzner about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
11/30/2018
Due date:
% Done:

100%

Severity:
critical
Found in Version:

Description

After adding a new term to the "Country" vocabulary the cdm server throws an exception during startup

Associated revisions

Revision ae0c3aab (diff)
Added by Patrick Plitzner 11 months ago

ref #7933 Disable adding terms to country vocabulary

  • temporary hardcoded fix

History

#1 Updated by Patrick Plitzner about 1 year ago

  • Target version changed from Unassigned CDM tickets to Release 5.5

#2 Updated by Patrick Plitzner about 1 year ago

  • Status changed from New to Feedback
  • Assignee changed from Patrick Plitzner to Andreas Müller

@Andreas: Should it be allowed at all to add a new term to the Country vocabulary?

The problem is in the TermType class which does not have a specific value for Country, thus a new NamedArea is added to the list of Countries which causes the exception.

#3 Updated by Patrick Plitzner about 1 year ago

  • Severity changed from blocker to critical

#4 Updated by Andreas Müller 11 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

Can we handle this special case hardcoded until the terms modul is more elaborated?

E.g. by testing if the vocabulary is explicitly the countries vocabulary and then disallow to add a term at all (adding countries should not be allowed as the vocabulary is managed).

#5 Updated by Patrick Plitzner 11 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 50

Fixed by hardcoding the check for the "Country" vocabulary

#6 Updated by Andreas Müller 11 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner

Ok, this seems to work as expected

#7 Updated by Andreas Müller 11 months ago

  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)