Project

General

Profile

bug #7882

TeamOrPersonField: exception when selecting author

Added by Andreas Kohlbecker 12 months ago. Updated 12 months ago.

Status:
Duplicate
Priority:
New
Category:
cdm-vaadin
Target version:
-
Start date:
10/30/2018
Due date:
% Done:

0%

Severity:
normal
Found in Version:
Tags:

Description

http://api.cybertaxonomy.org/phycobank/app/registration#!workingset/b52f4ef7-5743-44eb-84c9-0b06e67a256d
Produktionssystem Login als w.h.kusber=submitter

Aktion 1

Auswahl von Ehrenberg 1838

Eingabe neu Gattung=Microtheca ->fehlerfrei

Eingabe neu Gattung=Microtheca, epithet=octoceras, detail=168

Kein Zwischenspeichern

Anklicken basionym

Gattung fehlt, Gattung neu geklickt

„Anurea“ eingegeben ohne Referenz, um den Namen zu haben. Speichern.

Wieder bei der Art, Anurea ausgewählt, epitheton octoceras eingegeben.

Referenz=neu

Reference type zunächst auf Generic gelassen.

Date ausgefüllt.

Title ausgefüllt.

Beim Auswählen des Autors Ehrenberg bekam ich den Fehler.

com.vaadin.event.ListenerMethod$MethodException: Invocation of method valueChange in eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField$$Lambda$189/136038786 failed.
               at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:533)
               at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:200)
               at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:163)
               at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1015)
               at com.vaadin.ui.AbstractField.fireValueChange(AbstractField.java:1161)
               at com.vaadin.ui.AbstractField.setValue(AbstractField.java:571)
               at com.vaadin.ui.AbstractField.setValue(AbstractField.java:468)
               at com.vaadin.ui.AbstractField.setValue(AbstractField.java:453)
               at org.vaadin.viritin.fields.TypedSelect.setValue(TypedSelect.java:503)
               at org.vaadin.viritin.fields.TypedSelect$5.valueChange(TypedSelect.java:516)
               at sun.reflect.GeneratedMethodAccessor10409.invoke(Unknown Source)
               at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
               at java.lang.reflect.Method.invoke(Method.java:498)
               at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)
               at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:200)
               at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:163)
               at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1015)
               at com.vaadin.ui.AbstractField.fireValueChange(AbstractField.java:1161)
               at com.vaadin.ui.AbstractField.setValue(AbstractField.java:571)
               at com.vaadin.ui.AbstractSelect.setValue(AbstractSelect.java:735)
               at com.vaadin.ui.AbstractField.setValue(AbstractField.java:468)
               at com.vaadin.ui.ComboBox.changeVariables(ComboBox.java:742)
               at org.vaadin.viritin.fields.LazyComboBox$5.changeVariables(LazyComboBox.java:197)
               at com.vaadin.server.communication.ServerRpcHandler.changeVariables(ServerRpcHandler.java:616)
               at com.vaadin.server.communication.ServerRpcHandler.handleInvocation(ServerRpcHandler.java:463)
               at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:406)
               at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:273)
               at com.vaadin.server.communication.UidlRequestHandler.synchronizedHandleRequest(UidlRequestHandler.java:90)
               at com.vaadin.server.SynchronizedRequestHandler.handleRequest(SynchronizedRequestHandler.java:41)
               at com.vaadin.server.VaadinService.handleRequest(VaadinService.java:1435)
               at com.vaadin.server.VaadinServlet.service(VaadinServlet.java:380)
               at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
               at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:808)
               at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1669)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:316)
               at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:126)
               at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:90)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.access.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:114)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.session.SessionManagementFilter.doFilter(SessionManagementFilter.java:122)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.authentication.AnonymousAuthenticationFilter.doFilter(AnonymousAuthenticationFilter.java:111)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.servletapi.SecurityContextHolderAwareRequestFilter.doFilter(SecurityContextHolderAwareRequestFilter.java:169)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.savedrequest.RequestCacheAwareFilter.doFilter(RequestCacheAwareFilter.java:48)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.authentication.www.BasicAuthenticationFilter.doFilterInternal(BasicAuthenticationFilter.java:158)
               at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.oauth2.provider.authentication.OAuth2AuthenticationProcessingFilter.doFilter(OAuth2AuthenticationProcessingFilter.java:176)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.authentication.logout.LogoutFilter.doFilter(LogoutFilter.java:120)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.header.HeaderWriterFilter.doFilterInternal(HeaderWriterFilter.java:64)
               at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.context.SecurityContextPersistenceFilter.doFilter(SecurityContextPersistenceFilter.java:91)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.context.request.async.WebAsyncManagerIntegrationFilter.doFilterInternal(WebAsyncManagerIntegrationFilter.java:53)
               at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
               at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
               at org.springframework.security.web.FilterChainProxy.doFilterInternal(FilterChainProxy.java:213)
               at org.springframework.security.web.FilterChainProxy.doFilter(FilterChainProxy.java:176)
               at org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:346)
               at org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:262)
               at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1652)
               at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:121)
               at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
               at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1652)
               at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585)
               at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
               at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577)
               at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)
               at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)
               at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)
               at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
               at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)
               at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
               at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:215)
               at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
               at org.eclipse.jetty.server.Server.handle(Server.java:497)
               at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:310)
               at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)
               at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:540)
               at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
               at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
               at java.lang.Thread.run(Thread.java:745)
Caused by: com.vaadin.event.ListenerMethod$MethodException: Invocation of method valueChange in eu.etaxonomy.cdm.vaadin.event.ToOneRelatedEntityReloader failed.
               at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:533)
               at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:200)
               at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:163)
               at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1015)
               at com.vaadin.ui.AbstractField.fireValueChange(AbstractField.java:1161)
               at com.vaadin.ui.AbstractField.setValue(AbstractField.java:571)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.lambda$initContent$6ecb4440$1(TeamOrPersonField.java:120)
               at sun.reflect.GeneratedMethodAccessor10409.invoke(Unknown Source)
               at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
               at java.lang.reflect.Method.invoke(Method.java:498)
               at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)
               ... 88 more
Caused by: com.vaadin.data.fieldgroup.FieldGroup$BindException: The given field is not part of this FieldBinder
               at com.vaadin.data.fieldgroup.FieldGroup.unbind(FieldGroup.java:369)
               at com.vaadin.data.fieldgroup.BeanFieldGroup.unbind(BeanFieldGroup.java:167)
               at eu.etaxonomy.vaadin.component.SwitchableTextField.unbindFrom(SwitchableTextField.java:102)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.setInternalValue(TeamOrPersonField.java:222)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.setInternalValue(TeamOrPersonField.java:55)
               at com.vaadin.ui.AbstractField.setValue(AbstractField.java:526)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.setValue(TeamOrPersonField.java:378)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.setValue(TeamOrPersonField.java:55)
               at eu.etaxonomy.cdm.vaadin.event.ToOneRelatedEntityReloader.valueChange(ToOneRelatedEntityReloader.java:83)
               at sun.reflect.GeneratedMethodAccessor10409.invoke(Unknown Source)
               at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
               at java.lang.reflect.Method.invoke(Method.java:498)
               at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)
               ... 98 more

Viele Grüße,
Henning

image001.png View (79 KB) Andreas Kohlbecker, 10/30/2018 10:42 PM


Related issues

Related to Edit - bug #7881: reference selection combobox broken after error in ... Closed 10/30/2018
Duplicates Edit - bug #7897: TeamOrPersonField: BindException: The given field is not part of this FieldBinder Duplicate 11/08/2018

History

#1 Updated by Andreas Kohlbecker 12 months ago

  • Related to bug #7881: reference selection combobox broken after error in ... added

#2 Updated by Andreas Kohlbecker 12 months ago

  • Status changed from New to Duplicate

#3 Updated by Andreas Kohlbecker 12 months ago

  • Duplicates bug #7897: TeamOrPersonField: BindException: The given field is not part of this FieldBinder added

#4 Updated by Andreas Kohlbecker 12 months ago

  • Target version deleted (Unassigned CDM tickets)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)