Project

General

Profile

bug #7867

FieldGroup$BindException: The given field is not part of this FieldBinder in TeamOrPersonField

Added by Andreas Kohlbecker about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
New
Category:
cdm-vaadin
Target version:
Start date:
10/25/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

[reported by henning]

Testsystem:
http://test.e-taxonomy.eu/cdmserver/phycobank/app/registration#!workingset/537f9b7b-42d4-4b40-949b-1b6f2adc3296
Name mit validated Name,
Bei der neuen Reference des Validated names knallte es bei der Auswahl des Autors

Ich hatte Abas berolinensis A.Braun eingegeben,
dann als validated name noch mal Abas berolinensis neu eingegeben (der ist ja vor speichern nicht in der Auswahl).
Ich glaube dann eine neue Referenz angelegt zu haben und bin in die Auswahl der Autoren gegangen und habe einen vorhandenen ausgewählt.

Habe das mit Abas cerolinensis noch mal probiert und alles lief fehlerfrei.

org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:215)
               at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
               at org.eclipse.jetty.server.Server.handle(Server.java:497)
               at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:310)
               at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)
               at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:540)
               at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
               at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
               at java.lang.Thread.run(Thread.java:748)
Caused by: com.vaadin.event.ListenerMethod$MethodException: Invocation of method valueChange in eu.etaxonomy.cdm.vaadin.event.ToOneRelatedEntityReloader failed.
               at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:533)
               at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:200)
               at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:163)
               at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1015)
               at com.vaadin.ui.AbstractField.fireValueChange(AbstractField.java:1161)
               at com.vaadin.ui.AbstractField.setValue(AbstractField.java:571)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.lambda$initContent$6ecb4440$1(TeamOrPersonField.java:120)
               at sun.reflect.GeneratedMethodAccessor1653.invoke(Unknown Source)
               at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
               at java.lang.reflect.Method.invoke(Method.java:498)
               at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)
               ... 88 more
Caused by: com.vaadin.data.fieldgroup.FieldGroup$BindException: The given field is not part of this FieldBinder
               at com.vaadin.data.fieldgroup.FieldGroup.unbind(FieldGroup.java:369)
               at com.vaadin.data.fieldgroup.BeanFieldGroup.unbind(BeanFieldGroup.java:167)
               at eu.etaxonomy.vaadin.component.SwitchableTextField.unbindFrom(SwitchableTextField.java:102)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.setInternalValue(TeamOrPersonField.java:222)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.setInternalValue(TeamOrPersonField.java:55)
               at com.vaadin.ui.AbstractField.setValue(AbstractField.java:526)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.setValue(TeamOrPersonField.java:378)
               at eu.etaxonomy.cdm.vaadin.component.common.TeamOrPersonField.setValue(TeamOrPersonField.java:55)
               at eu.etaxonomy.cdm.vaadin.event.ToOneRelatedEntityReloader.valueChange(ToOneRelatedEntityReloader.java:83)
               at sun.reflect.GeneratedMethodAccessor1653.invoke(Unknown Source)
               at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
               at java.lang.reflect.Method.invoke(Method.java:498)
               at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)
               ... 98 more

Related issues

Duplicated by Edit - bug #7897: TeamOrPersonField: BindException: The given field is not part of this FieldBinder Duplicate 11/08/2018

Associated revisions

Revision dee4cf65 (diff)
Added by Andreas Kohlbecker about 1 year ago

ref #7867 attempting to avoid FieldGroup in TeamOrPersonField without having any idea why this can happen & better logging for further analyis

History

#1 Updated by Andreas Kohlbecker about 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

this issue is neither reproducible nor comprehensible, I tries to change the code in a way to avoid this issue in future and to get some logging about the reason.

we should close this ticket if this problem is no occurring again until the next release.

#2 Updated by Andreas Kohlbecker 12 months ago

  • Duplicated by bug #7897: TeamOrPersonField: BindException: The given field is not part of this FieldBinder added

#3 Updated by Andreas Kohlbecker 11 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

this issue did not occur again since 3 months, so the issue seems fixed and I am closing it now.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)