Project

General

Profile

bug #7855

PersonField modifies the nomenclaturalTitle forcing users to have the UPDATE permission even if the person was not edited or readonly

Added by Andreas Kohlbecker about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
10/23/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

User with role submitter creates a new specimen typedesignation and adds an existing collector for which the submitter is not having the UPDATE permission.
Saving the new specimen typedesignation is blocked by the system due to:

picture734-1.png View (34 KB) Andreas Kohlbecker, 10/23/2018 05:49 PM

Associated revisions

Revision db262dfa (diff)
Added by Andreas Kohlbecker about 2 months ago

fix #7855 preventing nomenclaturalTitle from being changed in PersonField without user interaction

History

#1 Updated by Andreas Kohlbecker about 2 months ago

the reason for this is that the cache strategy is modifying the nomenclaturalTitle

modified property found: nomenclaturalTitle, previousState: A.M.Monro, currentState: Monro, A.M.

#2 Updated by Andreas Kohlbecker about 2 months ago

  • Tags changed from phycobank to phycobank, permission

#3 Updated by Andreas Kohlbecker about 2 months ago

  • Subject changed from submitter can not save specimen typedesignation with collector to canges to AgentBase.nomenclaturalTitle done by the cachestrategy must not require users to have the UPDATE permission
  • Category changed from cdm-vaadin to cdmlib

I will adapt the subject of this issue since it is not adequately describing the root of the problem.

I feel like remembering that we recently had a very similar problem in the Taxeditor but can not find an according ticket - any hints?

#4 Updated by Andreas Müller about 2 months ago

Why should changes in type designation update the cache? Does it really update, I mean change the value or does it only recompute it again?

By the way, nomenclaturalTitle is a difficult field as it is NOT a cache in Person, but it is a cache field in Team.
However, this may change in future as nomenclaturalTitle may also be cached in Person in case it is not set (only full title is known). Currently the field is filled with the full title if not set explicitly. This is kind of crtical.

#5 Updated by Andreas Kohlbecker about 2 months ago

  • Subject changed from canges to AgentBase.nomenclaturalTitle done by the cachestrategy must not require users to have the UPDATE permission to PersonField modifies the nomenclaturalTitle forcing users to have the UPDATE permission even if the person was not edited or readonly
  • Category changed from cdmlib to cdm-vaadin
  • Target version changed from Release 5.5 to Release 5.4

my last nights impression on the cause of this problem was misled and thus not correct. The real cause is in the PersonField.commit() method.

... changing the subject again ;-)

#6 Updated by Andreas Kohlbecker about 2 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#7 Updated by Andreas Kohlbecker about 2 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)