Project

General

Profile

bug #7836

ClassCastException when invoking cdm light export with wrong selection

Added by Patrick Plitzner 10 months ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
10/19/2018
Due date:
% Done:

100%

Severity:
critical
Found in Version:

Description

Steps to reproduce:

  1. Select a FeatureTree in the FeatureTreeEditor (or e.g. a taxon description in the factual data view)
  2. Invoke the export wizard for CDM light export via the menu General->Export-> CDM ligth (csv)
!ENTRY org.eclipse.ui 4 0 2018-10-19 10:07:58.206
!MESSAGE This is an unexpected error.
Please contact EDIT Support (EditSupport@bgbm.org) with the error trace below (click on the 'Details' button).
!STACK 0
java.lang.Exception: login : admin
editor version : 5.4.0.qualifier
server : localhost (localhost-dev)
schema version : 5.0.0.0.20180514
os : Linux 4.15.0-36-generic amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: java.lang.ClassCastException: eu.etaxonomy.cdm.model.description.FeatureTree cannot be cast to eu.etaxonomy.cdm.persistence.dto.TaxonNodeDto
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:288)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:5227)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1340)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4561)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4151)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.ClassCastException: eu.etaxonomy.cdm.model.description.FeatureTree cannot be cast to eu.etaxonomy.cdm.persistence.dto.TaxonNodeDto
    at eu.etaxonomy.taxeditor.io.e4.out.cdmlight.CdmLightExportWizardE4.init(CdmLightExportWizardE4.java:57)
    at eu.etaxonomy.taxeditor.io.e4.out.AbstractOpenExportWizard.execute(AbstractOpenExportWizard.java:28)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    ... 38 more

Associated revisions

Revision e0f80728 (diff)
Added by Katja Luther 7 months ago

fix #7836: fix classCastException in cdmLight export

History

#1 Updated by Andreas Müller 10 months ago

  • Target version changed from Release 5.4 to Release 5.5

#2 Updated by Katja Luther 7 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Katja Luther 7 months ago

  • Assignee changed from Katja Luther to Patrick Plitzner

please review

#4 Updated by Patrick Plitzner 7 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Patrick Plitzner to Katja Luther
  • Severity changed from major to critical

#5 Updated by Katja Luther 7 months ago

the preference show IO menu is enabled?

#6 Updated by Patrick Plitzner 7 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

this works fine

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)