Project

General

Profile

Actions

bug #7817

closed

Team caches should not show '& al.'

Added by Andreas Müller over 4 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Highest
Category:
cdm
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

If a team is fully defined with all members of the team the caches should not show "at al." if the team is larger then 3 (or any other number).

Otherwise teams can not be distinguished by the cache and they might be selected incorretly.

For this need to adapt the formatter (cache strategies). Team formatter must not have a max member parameter while name formatter, reference formatter (and others like taxon formatter) need to have a max member parameter (or even a max member and an etAl-position parameter, depending on the rules how to use etAl at which position).
This requires that the later formatter partly format the teams on their own which is not so good. Alternatively we may introduce new cache fiels in the teams for caching with and without at al.


Related issues

Related to EDIT - feature request #7799: AM: Parse authorteamsResolvedAndreas Müller

Actions
Related to EDIT - feature request #4311: Improve person representation in CDMClosedAndreas Müller

Actions
Is duplicate of EDIT - task #9624: Centralize team formatting and fix et al. position handlingClosedAndreas Müller

Actions
Is duplicate of EDIT - feature request #9464: Show all team members in agent selection dialogDuplicateKatja Luther

Actions
Actions #1

Updated by Andreas Müller over 4 years ago

Actions #2

Updated by Andreas Müller over 4 years ago

Actions #3

Updated by Andreas Müller over 4 years ago

  • Subject changed from Team caches should not show at al. to Team caches should not show '& al.'
Actions #4

Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 5.5 to Release 5.6
Actions #5

Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 5.6 to Reviewed Next Major Release
Actions #6

Updated by Wolf-Henning Kusber almost 4 years ago

  • Tags changed from euro+med to euro+med, phycobank
Actions #7

Updated by Andreas Müller over 1 year ago

  • Tags changed from euro+med, phycobank to euro+med, phycobank, formatting
  • Status changed from New to Duplicate
  • Target version deleted (Reviewed Next Major Release)
  • % Done changed from 0 to 100

duplicates #9326, #9464 and #9624

Actions #8

Updated by Andreas Müller over 1 year ago

  • Is duplicate of task #9624: Centralize team formatting and fix et al. position handling added
Actions #9

Updated by Andreas Müller over 1 year ago

Actions

Also available in: Atom PDF