Project

General

Profile

bug #7814

Section in Name and section in Basionym, usability

Added by Wolf-Henning Kusber 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
10/09/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

Bedienungsfehler möglich, wenn neuer Name und Basionym jeweils eine In-Zitierung haben.

Vorgehen: Referenz eingeben, neuen Namen eingeben, aus der nomenklatorischen Referenz heraus Sektion anlegen (richtig).

Basionym
Vorgehen: Neuen Namen eingeben, neue Referenz als Artikel eingeben, abspeichern, Record wieder aufmachen, Section anlegen wollen: Falsch, damit kann nur die korrekte bibliographische Referenz abgehängt werden (Screen shot)

Korrektes Vorgehen:
Neuen Namen eingeben, neue Referenz mit Section-Autoren als Section eingeben und von da aus die neue Referenz eingeben.

Das ist genau andersrum als von neuen Namen her gewohnt und kann zu Fehlern führen.

picture811-1.png View (39.2 KB) Wolf-Henning Kusber, 10/09/2018 01:22 PM

picture811-2.png View (39.2 KB) Wolf-Henning Kusber, 10/09/2018 01:22 PM


Related issues

Duplicated by Edit - bug #7813: Basionym without journal Duplicate 10/09/2018

Associated revisions

Revision 23cee55f (diff)
Added by Andreas Kohlbecker 2 months ago

fix #7814 CdmEditor not readlony with un-persisted entities and hiding delete button in this case

Revision 959b2c17 (diff)
Added by Andreas Kohlbecker about 2 months ago

ref #7830 ref #7814 fixing WeaklyRelatedEntityCombobox reset to textfield for genus in name editor

History

#1 Updated by Wolf-Henning Kusber 2 months ago

  1. Screenshot sollte zeigen: You, Q. & Kociolek, J.P. - in You, Q., Kociolek, J.P. & Wang, X., New Gomphoneis Cleve (Bacillariophyceae: Gomphonemataceae) species from Xinjiang Province, China. in Phytotaxa 103(1): 1-24. 2013

#2 Updated by Wolf-Henning Kusber 2 months ago

Es funktioniert nur die erste Version, die für User etwas fehlerhaft wirkt.

Ich kann bei der Basionym-Referenz mit der Section anfangen, bei "in reference" ist dann Schluss, weil ich als User dann keine keine neue Referenz mehr anlegen kann.

Zusammenfassend:
Ich kann vom Basionym aus immer nur einen Referenz-Editor öffnen, von da aus habe ich keine Rechte einen 2. neuen Referenz-Editor zu öffnen, das ist doch eher ein bug.

#3 Updated by Andreas Kohlbecker 2 months ago

  • Tracker changed from report to bug
  • Project changed from AlgenRegistrierung to Edit
  • Category set to cdm-vaadin
  • Priority changed from New to Highest
  • Target version set to Release 5.4
  • Severity set to normal

#4 Updated by Andreas Kohlbecker 2 months ago

  • Duplicated by bug #7813: Basionym without journal added

#5 Updated by Andreas Kohlbecker 2 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#6 Updated by Andreas Kohlbecker about 2 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

this is fixed now, please confirm

#7 Updated by Wolf-Henning Kusber about 2 months ago

Test: New reference, new name, new basionym, new section in new reference - without error

#8 Updated by Wolf-Henning Kusber about 2 months ago

  • Status changed from Resolved to Worksforme
  • % Done changed from 50 to 100

Test 2: Neuer Name, neuer Autor in neuer Referenz, mit neuem Journal, ohne Fehler.

Aber: ich habe noch nicht alle Möglichkeiten getestet.

#9 Updated by Andreas Kohlbecker about 2 months ago

  • Status changed from Worksforme to Closed

the status "worksforme" is applied to bug reports which can not be reproduced. In this context it means that there is nothing to do since it "works for me"

Changing the status so "closed" instead

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)