Project

General

Profile

bug #7794

Update TaxonNodeWizard

Added by Katja Luther 11 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
09/27/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

The taxonnode wizard needs to be updated, the taxon, parent and classification should not be editable and the "open in editor" checkbox should be a third button with "Finish and Open in Editor"

picture585-1.png View (17.2 KB) Andreas Müller, 01/25/2019 03:56 PM


Related issues

Copied to Edit - bug #8088: Open taxon node wizard issues Feedback 02/08/2019

Associated revisions

Revision d607cf23 (diff)
Added by Katja Luther 7 months ago

fix #7794: add finish and open button to taxonnode wizard

Revision 4f18c04e (diff)
Added by Katja Luther 7 months ago

ref #7794: adapt label

Revision 3c401181 (diff)
Added by Katja Luther 7 months ago

ref #7794: externalize strings

Revision e91fb609 (diff)
Added by Katja Luther 7 months ago

ref #7794: fix classification selection combo in taxonnode wizard

History

#1 Updated by Andreas Müller 10 months ago

  • Target version changed from Release 5.4 to Release 5.5

#2 Updated by Katja Luther 7 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Andreas Müller 7 months ago

should I review

#4 Updated by Katja Luther 7 months ago

  • Assignee changed from Katja Luther to Andreas Müller

sorry, yes, please review.

#5 Updated by Andreas Müller 7 months ago

  • File picture585-1.png View added
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Generally it works as expected. Some minor issues:

The "New Taxon" mode should have both labels as "New Taxon". Currently the label in the white area is "Edit taxon node"

The classification chooser is not shown anymore in taxon new mode. Maybe this is on purpose, but sometimes when resizing it appears at a strange position.

Do we need a classification chooser, e.g. for adding a direct child of the classification?
Also in Edit mode it appears. I think there we do not need (to show it), also the sec ref we do not need to show then as it is usually part of the taxon title.

We should think about moving Taxon is public to the taxon part, maybe directly below "New Taxon" or below "Secundum Reference". We could also think about moving parent information down so we have a Taxon part and a taxon node part. The 2 parts could be separated by some additional space or with a label or with boxes around each part.
Furthermore the Parent Child Relation Source could be moved directly below "parent" as it belongs there, same as Detail. With some identation we could then reduce the label to "Relation Source" and "Relation Detail" which makes it more clear what is meant and where it belongs to.

Those issues which are not straight forward to implement could be handled in a separate ticket.

#6 Updated by Katja Luther 7 months ago

Andreas Müller wrote:

Generally it works as expected. Some minor issues:

The "New Taxon" mode should have both labels as "New Taxon". Currently the label in the white area is "Edit taxon node"

The classification chooser is not shown anymore in taxon new mode. Maybe this is on purpose, but sometimes when resizing it appears at a strange position.

how did you get this? I can not reproduce it.

#7 Updated by Katja Luther 7 months ago

Andreas Müller wrote:

Do we need a classification chooser, e.g. for adding a direct child of the classification?
Also in Edit mode it appears. I think there we do not need (to show it), also the sec ref we do not need to show then as it is usually part of the taxon title.

We disabled parent taxon and removed classification because we decided that moving a taxon should be done by the navigator menu.

#8 Updated by Andreas Müller 7 months ago

Katja Luther wrote:

Andreas Müller wrote:

Do we need a classification chooser, e.g. for adding a direct child of the classification?
Also in Edit mode it appears. I think there we do not need (to show it), also the sec ref we do not need to show then as it is usually part of the taxon title.

We disabled parent taxon and removed classification because we decided that moving a taxon should be done by the navigator menu.

I know, but this was only for EDIT mode, I was talking about NEW mode (where parent is not disabled). Here the requirement of a classification selection needs to be discussed. For all taxon nodes not beeing top level taxa it is ok to have only the parent (which includes classification), but for top level taxa (which do only have classification as parent) this does not work.

#9 Updated by Andreas Müller 7 months ago

Katja Luther wrote:

how did you get this? I can not reproduce it.

It seems to be reproducable if you do "New - Taxon", in the dialog you open the parent selection and close it by cancel. Finally you resize the "New Taxon" dialog.

#10 Updated by Katja Luther 7 months ago

Andreas Müller wrote:

Katja Luther wrote:

Andreas Müller wrote:

Do we need a classification chooser, e.g. for adding a direct child of the classification?
Also in Edit mode it appears. I think there we do not need (to show it), also the sec ref we do not need to show then as it is usually part of the taxon title.

We disabled parent taxon and removed classification because we decided that moving a taxon should be done by the navigator menu.

I know, but this was only for EDIT mode, I was talking about NEW mode (where parent is not disabled). Here the requirement of a classification selection needs to be discussed. For all taxon nodes not beeing top level taxa it is ok to have only the parent (which includes classification), but for top level taxa (which do only have classification as parent) this does not work.

Maybe we should think about the possibility to choose the classification as parent in the parent selection dialog.

#11 Updated by Katja Luther 7 months ago

Andreas Müller wrote:

Katja Luther wrote:

how did you get this? I can not reproduce it.

It seems to be reproducable if you do "New - Taxon", in the dialog you open the parent selection and close it by cancel. Finally you resize the "New Taxon" dialog.

this is fixed

#12 Updated by Andreas Müller 7 months ago

Katja Luther wrote:

Andreas Müller wrote:

Katja Luther wrote:

Andreas Müller wrote:

Do we need a classification chooser, e.g. for adding a direct child of the classification?
Also in Edit mode it appears. I think there we do not need (to show it), also the sec ref we do not need to show then as it is usually part of the taxon title.

We disabled parent taxon and removed classification because we decided that moving a taxon should be done by the navigator menu.

I know, but this was only for EDIT mode, I was talking about NEW mode (where parent is not disabled). Here the requirement of a classification selection needs to be discussed. For all taxon nodes not beeing top level taxa it is ok to have only the parent (which includes classification), but for top level taxa (which do only have classification as parent) this does not work.

Maybe we should think about the possibility to choose the classification as parent in the parent selection dialog.

If this is easy to implement, it is a solution.

#13 Updated by Katja Luther 7 months ago

  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote:

Katja Luther wrote:

Andreas Müller wrote:

Do we need a classification chooser, e.g. for adding a direct child of the classification?
Also in Edit mode it appears. I think there we do not need (to show it), also the sec ref we do not need to show then as it is usually part of the taxon title.

We disabled parent taxon and removed classification because we decided that moving a taxon should be done by the navigator menu.

I know, but this was only for EDIT mode, I was talking about NEW mode (where parent is not disabled). Here the requirement of a classification selection needs to be discussed. For all taxon nodes not beeing top level taxa it is ok to have only the parent (which includes classification), but for top level taxa (which do only have classification as parent) this does not work.

can we move this to a new ticket?

#14 Updated by Andreas Müller 7 months ago

  • Status changed from Feedback to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

I moved all open issues to new ticket #8088

#15 Updated by Andreas Müller 7 months ago

  • Copied to bug #8088: Open taxon node wizard issues added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)