Project

General

Profile

bug #7743

test application contexts without <context:annotation-config />

Added by Andreas Kohlbecker 12 months ago. Updated 12 months ago.

Status:
Rejected
Priority:
New
Category:
cdmlib
Target version:
-
Start date:
09/07/2018
Due date:
% Done:

0%

Severity:
normal
Found in Version:

Description

the configuration <context:annotation-config/> to enable the annotation based spring configuration is missing in some test application contexts

It is only configured for:

  • applicationContext-testWithConfigurableNameCacheStrategyGenerators.xml

shouldn't this be the default for all contexts?

History

#1 Updated by Andreas Kohlbecker 12 months ago

add the configuration:

    <context:annotation-config />
    <context:component-scan base-package="eu/etaxonomy/cdm/api/config" />

e.g. for cdmlib-remote/src/test/resources/eu/etaxonomy/cdm/applicationContext-test.xml

causes

Caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [eu.etaxonomy.cdm.api.service.IAuditEventService] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {}

#2 Updated by Andreas Kohlbecker 12 months ago

  • Status changed from New to Rejected
  • Assignee changed from Andreas Müller to Andreas Kohlbecker

rejected since the remote test context is not a full context

#3 Updated by Andreas Kohlbecker 12 months ago

  • Target version deleted (Release 5.3)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)