Project

General

Profile

bug #7721

Contraint Violation Exception on saving Reference Popup Editor

Added by Andreas Kohlbecker about 1 year ago. Updated 10 months ago.

Status:
Rejected
Priority:
Priority14
Category:
cdm-vaadin
Target version:
-
Start date:
09/04/2018
Due date:
% Done:

0%

Severity:
normal
Found in Version:
Tags:

Description

der Fehler trat auf, als in einem Workingset in Vaadin in einer Referenz eine Section angelegt worden war (Submitter), das Section-Team ausgewählt worden war und der Section-Editor gespeichert werden sollte, um den neuen Namen zu Registrieren.

The violated contraint UK_8838j67gyr6frdoefpnabufoi is the unique index on Reference.uuid

Caused by: org.hibernate.exception.ConstraintViolationException: could not execute statement
                at org.hibernate.exception.internal.SQLExceptionTypeDelegate.convert(SQLExceptionTypeDelegate.java:59)
                at org.hibernate.exception.internal.StandardSQLExceptionConverter.convert(StandardSQLExceptionConverter.java:42)
                at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:109)
                at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:95)
                at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.executeUpdate(ResultSetReturnImpl.java:207)
                at org.hibernate.engine.jdbc.batch.internal.NonBatchingBatch.addToBatch(NonBatchingBatch.java:45)
                at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2886)
                at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:3386)
                at org.hibernate.action.internal.EntityInsertAction.execute(EntityInsertAction.java:89)
                at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:560)
                at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:434)
                at org.hibernate.event.internal.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:337)
                at org.hibernate.event.internal.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:39)
                at org.hibernate.internal.SessionImpl.flush(SessionImpl.java:1282)
                at org.hibernate.internal.SessionImpl.managedFlush(SessionImpl.java:465)
                at org.hibernate.internal.SessionImpl.flushBeforeTransactionCompletion(SessionImpl.java:2963)
                at org.hibernate.internal.SessionImpl.beforeTransactionCompletion(SessionImpl.java:2339)
                at org.hibernate.engine.jdbc.internal.JdbcCoordinatorImpl.beforeTransactionCompletion(JdbcCoordinatorImpl.java:485)
                at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl.beforeCompletionCallback(JdbcResourceLocalTransactionCoordinatorImpl.java:147)
                at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl.access$100(JdbcResourceLocalTransactionCoordinatorImpl.java:38)
                at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl$TransactionDriverControlImpl.commit(JdbcResourceLocalTransactionCoordinatorImpl.java:231)
                at org.hibernate.engine.transaction.internal.TransactionImpl.commit(TransactionImpl.java:65)
                at org.springframework.orm.hibernate5.HibernateTransactionManager.doCommit(HibernateTransactionManager.java:581)
                ... 100 more
Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLIntegrityConstraintViolationException: Duplicate entry 'ab627530-d829-4888-87db-f3799e9f5360' for key 'UK_8838j67gyr6frdoefpnabufoi'
                at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
                at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
                at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
                at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
                at com.mysql.jdbc.Util.handleNewInstance(Util.java:404)
                at com.mysql.jdbc.Util.getInstance(Util.java:387)
                at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:932)
                at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3878)
                at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3814)
                at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:2478)
                at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2625)
                at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2551)
                at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:1861)
                at com.mysql.jdbc.PreparedStatement.executeUpdateInternal(PreparedStatement.java:2073)
                at com.mysql.jdbc.PreparedStatement.executeUpdateInternal(PreparedStatement.java:2009)
                at com.mysql.jdbc.PreparedStatement.executeLargeUpdate(PreparedStatement.java:5094)
                at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:1994)
                at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.executeUpdate(NewProxyPreparedStatement.java:384)
                at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.executeUpdate(ResultSetReturnImpl.java:204)
                ... 118 more

History

#1 Updated by Andreas Kohlbecker about 1 year ago

  • Subject changed from Contraint Violation Exception on to Contraint Violation Exception on saving Reference Popup Editor

#2 Updated by Andreas Kohlbecker 11 months ago

  • Target version changed from Release 5.4 to Release 5.5

#3 Updated by Andreas Kohlbecker 10 months ago

  • Status changed from New to Rejected
  • Priority changed from New to Priority14
  • Target version deleted (Release 5.5)

This issue is 3 months old. The cause which lead to this aftereffect has most probably been fixed meanwhile.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)