Project

General

Profile

bug #7711

Bugs in media gallery

Added by Andreas Müller about 3 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
08/31/2018
Due date:
% Done:

70%

Severity:
normal
Found in Version:

Description

  • when removing a Media from image gallery it is immediately saved but should be saved only after save command, instead dirty button should be set
  • if the last image of the image gallery is removed the image gallery itself is removed, this is unexpected behavior
  • if a transient (id>0) media is removed all volatile (id=0) media are also removed automatically
  • deleting takes extremely long, even with a very small data graph (and not URI set) (on test server)
  • TBC

Related issues

Related to Edit - bug #8126: Mediarepresentations should not be shown in Referencing objects view New 02/22/2019
Related to Edit - bug #8129: Load images asynchronously in media details view Closed 02/22/2019
Related to Edit - bug #9360: Parsed hybrids can not be persisted Feedback 12/21/2020

Associated revisions

Revision 5aa8ceb0 (diff)
Added by Katja Luther 10 months ago

ref #7711: delete last media in galery should not delete description

Revision d9837e21 (diff)
Added by Katja Luther 9 months ago

fix #7711: fix delete of media if another not persisted media exist

Revision d5b342dc (diff)
Added by Katja Luther 9 months ago

ref #7711: adapt merge in TaxonEditorInputE4 to avoid exceptions for namerelations

History

#1 Updated by Andreas Müller about 3 years ago

  • Target version changed from Unassigned CDM tickets to Release 5.3

#2 Updated by Katja Luther about 3 years ago

  • Target version changed from Release 5.3 to Release 5.4

#3 Updated by Andreas Müller about 3 years ago

  • Target version changed from Release 5.4 to Release 5.5

#4 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.5 to Release 5.6

#5 Updated by Katja Luther over 2 years ago

  • Priority changed from New to Highest
  • Target version changed from Release 5.6 to Release 5.7

#6 Updated by Andreas Müller over 2 years ago

  • Related to bug #8126: Mediarepresentations should not be shown in Referencing objects view added

#7 Updated by Andreas Müller over 2 years ago

  • Subject changed from Bugs in Media view to Bugs in media gallery

#8 Updated by Andreas Müller over 2 years ago

  • Related to bug #8129: Load images asynchronously in media details view added

#9 Updated by Katja Luther over 2 years ago

  • Target version changed from Release 5.7 to Release 5.8

#10 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.8 to Release 5.10

#11 Updated by Katja Luther about 2 years ago

  • Target version changed from Release 5.10 to Release 5.11

#12 Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 5.11 to Release 5.12

#13 Updated by Katja Luther almost 2 years ago

  • Target version changed from Release 5.12 to Release 5.13

#14 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.13 to Release 5.14

#15 Updated by Katja Luther over 1 year ago

  • Target version changed from Release 5.14 to Release 5.15

#16 Updated by Katja Luther over 1 year ago

  • Target version changed from Release 5.15 to Release 5.18

#17 Updated by Katja Luther 11 months ago

  • Target version changed from Release 5.18 to Release 5.19

#18 Updated by Katja Luther 10 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

#19 Updated by Katja Luther 10 months ago

  • Description updated (diff)

#20 Updated by Katja Luther 10 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

The issues mentioned above are solved except that deleting takes extremely long, I could not reproduce it anymore.

Therefore before review the server needs to be restartet.

#21 Updated by Katja Luther 10 months ago

  • % Done changed from 0 to 50

#22 Updated by Andreas Müller 9 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

When removing the last image of the image gallery I got:

last remote method : http://test.e-taxonomy.eu:80/cdmserver/rem_conf_am/remoting/common.service
last remote request client time : 2021-01-21T15:13:15.223
last remote request response header time : Thu, 21 Jan 2021 15:13:15 GMT
client error time : 2021-01-21T15:13:16.615
login : admin
editor version : 5.19.0.202101211238
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 5.18.6.0.20201124
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.ClassCastException: org.eclipse.ui.forms.widgets.LayoutComposite cannot be cast to org.eclipse.ui.forms.widgets.ScrolledForm)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
    at org.eclipse.swt.widgets.Display.msgFilterProc(Display.java:3541)
    at org.eclipse.swt.internal.win32.OS.TrackPopupMenu(Native Method)
    at org.eclipse.swt.widgets.Menu._setVisible(Menu.java:262)
    at org.eclipse.swt.widgets.Display.runPopups(Display.java:4277)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3818)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.ClassCastException: org.eclipse.ui.forms.widgets.LayoutComposite cannot be cast to org.eclipse.ui.forms.widgets.ScrolledForm
    at eu.etaxonomy.taxeditor.store.StoreUtil.reflowParentScrolledForm(StoreUtil.java:86)
    at eu.etaxonomy.taxeditor.ui.element.ImageElement$1.run(ImageElement.java:102)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 27 more

However, I couldn't repeat this.

#23 Updated by Andreas Müller 9 months ago

if a transient (id>0) media is removed all volatile (id=0) media are also removed automatically

this still happens, in the ID before save they are still there but during save they are removed

How to reproduce:

  • create image with 1 image, save and reopen taxon
  • create a new image without saving
  • delete first image (=> second image is still there)
  • save => second image goes away

#24 Updated by Katja Luther 9 months ago

  • Status changed from Feedback to Resolved

#25 Updated by Katja Luther 9 months ago

  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote:

if a transient (id>0) media is removed all volatile (id=0) media are also removed automatically

this still happens, in the ID before save they are still there but during save they are removed

How to reproduce:

  • create image with 1 image, save and reopen taxon
  • create a new image without saving
  • delete first image (=> second image is still there)
  • save => second image goes away

this should be fixed now.

#26 Updated by Andreas Müller 9 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 70

The image issue seems to be fixed.

There is still one new commented line:

// descriptionElement.getInDescription().removeElement(descriptionElement);

can this be removed or is it still needed?

===

Generally I wonder a bit about the moving up of TaxonNode merge in TaxonEditorInputE4. Isn't this dangerous to do the TaxonName save for related names after the merge? I would expect exceptions but can't test because saving hybrids does not work anyway at the moment #9360 (I work on this).

Can you leave a message why it is moved up and why it is not dangerous?

#27 Updated by Katja Luther 9 months ago

Andreas Müller wrote:

The image issue seems to be fixed.

There is still one new commented line:

// descriptionElement.getInDescription().removeElement(descriptionElement);

can this be removed or is it still needed?

===

Generally I wonder a bit about the moving up of TaxonNode merge in TaxonEditorInputE4. Isn't this dangerous to do the TaxonName save for related names after the merge? I would expect exceptions but can't test because saving hybrids does not work anyway at the moment #9360 (I work on this).

Can you leave a message why it is moved up and why it is not dangerous?

You are right I should only move the operations behind the taxonnode merge, I adapted this.

The commmented line in Deletehandler is removed now.

#28 Updated by Katja Luther 9 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

#29 Updated by Andreas Müller 9 months ago

  • Related to bug #9360: Parsed hybrids can not be persisted added

#30 Updated by Andreas Müller 9 months ago

  • Assignee changed from Andreas Müller to Katja Luther

This should be finally closed only when #9360 is also fixed as the code seems to be related and it needs to be tested if hybrid formula names are correctly saved with the new code.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)