Project

General

Profile

bug #7686

Specimen title cache issues in data portal specimen table

Added by Patrick Plitzner 4 months ago. Updated 3 months ago.

Status:
Feedback
Priority:
New
Category:
cdm-dataportal
Target version:
Start date:
08/27/2018
Due date:
% Done:

50%

Severity:
normal
Found in Version:
Tags:

Description

Walter:

  • Der Name nach Holotype of wird doppelt ausgegeben.
  • Vor dem Link zum Herbarbeleg sollte ein Promt stehen “Link(s) to specimens:”
  • Warum steht eine Leerzeile vor den Links?

Beim folgenden Beispiel stehen die folgenden Daten im Cache:

Philippines, Panay, Antique Prov., Mariliso (= Malalison) Island., male infl or. May–Aug. 1918, McGregor 32313 (holotype: US, isotype: B, photo K, photo PNH)

Das muss auch erstmal so stehen bleiben, da wir noch kein Specimen-unabhängiges Feld für das Originalzitat des Typus und die Typendiskussion haben. Damit aber unter der Überschrift Specimens etwas steht, habe ich Sammler und Nummer (sozusagen der Field Unit) eingetragen, dann kommt folgendes heraus:

Offenbar wird die Zeile “xType of” nur ausgegeben, wenn die Typuskategorie eingegeben wurde? Das ist bei mehrere Specimens umfassenden Cache-Angaben natürlich nicht möglich.
Der unschöne Link wäre ja mit entsprechendem Prompt noch akzeptabel – aber auf der Specimen Seite wird dann der Cache nicht angezeigt:

Ich gehe davon aus, dass die Specimen-Daten, die aus der Literatur hereinkommen, zunächst meist im Cache zitiert werden (besonders die Typen, solange es noch kein unabhängiges Typus-Diskussionsfeld gibt). Da wäre es gut, wenn man sich die Daten auch anzeigen lassen könnte.

picture727-1.png View (25 KB) Patrick Plitzner, 08/27/2018 01:31 PM

picture248-1.png View (12.3 KB) Patrick Plitzner, 08/27/2018 01:33 PM

picture248-2.png View (140 KB) Patrick Plitzner, 08/27/2018 01:33 PM

picture360-1.png View (17.8 KB) Andreas Müller, 09/10/2018 05:31 PM


Related issues

Related to Edit - bug #7692: Empty "Specimens" section Worksforme 08/27/2018
Related to Edit - feature request #7704: Dataportal specimen table should be able to show DerivedUnits without a FieldUnit New 08/30/2018

Associated revisions

Revision 2d6348e5 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Add label to link to specimen page

Revision 01371d61 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Use titleCache if no identifier can be found

Revision cd175378 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Do not ignore types without type status

Revision a5b11885 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 show info for unset type status

Revision 64688697 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Do not use null for keys in map (JSON error)

Revision 76c5c9b7 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Fix check for empty string

Revision 0dd9be37 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Fix check for empty string

Revision 6a660dc3 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Remove citation label

Revision b511fb13 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Better way to check for empty string

Revision 269e42e0 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Better way to check for empty string

Revision 25fc25ca (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Change label of specimen page link

Revision 87bf25dd (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Show titleCache as title of specimen page

Revision 0b4ac33b (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Fix NPE during specimen title generation

Revision 31ab4cf9 (diff)
Added by Patrick Plitzner 3 months ago

ref #7686 Change label for no type status

History

#1 Updated by Patrick Plitzner 4 months ago

#2 Updated by Patrick Plitzner 4 months ago

  • Tags set to campanula
  • Description updated (diff)

#3 Updated by Patrick Plitzner 3 months ago

  • Subject changed from Specimen types issues in data portal specimen table to Specimen title cache issues in data portal specimen table

Walter:

"Hierzu dann gleich auch noch zwei Anmerkungen:

Den Titel mit der ID ist unschön, zumal ja diese ID auch nur intern etwas bedeutet. In der Botanik wäre es schön, hier das Sammler + Sammlernummerzitat im Titel zu haben (kann dann im Text ruhig wiederholt werden).

Den Prompt “Citation” finde ich (auch bei der Tabelle) erstens überflüssig und zudem auch noch (bei Typen) irreführend, da es sich ja gerade nicht um die Originaldaten (die „Type citation“ im Protolog) handelt, sondern um einen von uns zusammengesetzten String."

#4 Updated by Patrick Plitzner 3 months ago

Andreas M.:

  • Gibt der verwendete Webservice grundsätzlich nur Fieldunits oder werden auch DerivedUnits zurückgegeben, aber werden nur nicht ausgewertet? Gegebenenfalls müsste der Webservice entsprechend angepasst werden

  • Gegeben, dass auch DerivedUnits zurückkommen können, müssten diese in eine FieldUnit gewrapped werden (oder etwas ähnliches) und als label lediglich der TitleCache ausgegeben werden

  • Grundsätzlich muss es ein Handling für protectedTitleCache = true geben. Derzeit scheint die Tabelle damit nicht umgehen zu können, egal ob FieldUnit oder DerivedUnit. Im Fall von protected titleCache = true müsste der titleCache wie gespeichert ausgegeben werden, möglichst mit einem column span, da er ja vermutlich länger ist.

  • Das von Walter unten aufgezeigte Handling der DerivedUnit mit protectedTitleCache UND leerer FieldUnit, bei der für das Specimen nur die UUID angezeigt wird, ist völlig unverständlich. Hier muss auf jeden Fall der titleCache angezeigt werden, der in diesem Fall laut DB „Philippines, Panay, Antique Prov., Mariliso (= Malalison) Island., male infl or. May–Aug. 1918, McGregor 32313 (holotype: US, isotype: B, photo K, photo PNH)“ lautet.
    Dieser Cache ist nicht schön, weil er eigentlich ein Typus Cache ist, aber definitiv besser als die UUID. Das Thema Typus Cache werden wir später behandeln.

Link zu Walters Beispielen:

http://caryophyllales.org/nepenthaceae/cdm_dataportal/taxon/90d47d8d-0f76-47d9-a0c8-20b4361080a4

bzw.

http://caryophyllales.org/nepenthaceae/cdm_dataportal/specimen/72e69c38-3e0a-4eb2-9f67-7fd72214a100

#5 Updated by Andreas Müller 3 months ago

  • Related to bug #7692: Empty "Specimens" section added

#6 Updated by Patrick Plitzner 3 months ago

  • Related to feature request #7704: Dataportal specimen table should be able to show DerivedUnits without a FieldUnit added

#7 Updated by Patrick Plitzner 3 months ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 50

All the UI issues have been solved.

The issue with the DerivedUnit with no FieldUnit is handled in #7704

#8 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

Offenbar wird die Zeile “xType of” nur ausgegeben, wenn die Typuskategorie eingegeben wurde? Das ist bei mehrere Specimens umfassenden Cache-Angaben natürlich nicht möglich.

Now it says: "no type status set: Achillea santolinoides". IMO this is also not correct. If the type is written in the cache for the user it becomes unclear why it is not set.
Also it is not correct for a label the primarily wants to say "this is a type for ...".

So I suggest so simply say "Type for: ". Or was there a user requirement for something else?

#9 Updated by Andreas Müller 3 months ago

On the specimen page still the Class UUID formatting occurs.

Also there are 2 warning now.

Example from test.cyprus with type specimen for Achillea santolinoides (created for this review):

#10 Updated by Patrick Plitzner 3 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller

The titleCache issue is fixed.

I do not get the warnings on my local copy of the cyprus data base so I am not able to reproduce the error. Nevertheless I added code to catch the exception which happens most probably due to a null reference. We have to wait for the snapshot build to complete to see if the issue is fixed.

#12 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

There is still a comma missing beetween the types if there are >1 types.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)