Project

General

Profile

Actions

bug #7628

closed

Create registration for existing name (typification only) creates two registratios

Added by Andreas Kohlbecker over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
critical
Found in Version:
Tags:

Description

Start from the working set where the already registered name is listed and and select the name in the existing names combobox:

Click the "Existing Name" button to create a "typification only" registration, after reloading the workingset, the new registration will become visible in the page:

Checking the database shows that there are three registrations now:

Now reload the registration workingset page and see that there are now two registrations for the name:

The formerly shown type only registration is now listed as empty registration since no typification has been added, this refers to issue #7582


Files

picture792-1.png (27.4 KB) picture792-1.png Andreas Kohlbecker, 08/03/2018 08:55 PM
picture792-2.png (34.1 KB) picture792-2.png Andreas Kohlbecker, 08/03/2018 08:55 PM
picture792-3.png (15.2 KB) picture792-3.png Andreas Kohlbecker, 08/03/2018 08:55 PM
picture792-4.png (37.9 KB) picture792-4.png Andreas Kohlbecker, 08/03/2018 08:55 PM

Related issues

Related to EDIT - bug #7582: prevent from creating empty registrations DuplicateAndreas Kohlbecker

Actions
Related to EDIT - bug #7629: creating a typification only registration should not be possible if the names protologue is in the current workingset ClosedAndreas Kohlbecker

Actions
Has duplicate EDIT - bug #7625: RegistrationWorkingsetEditor: if a registered name is selected, the same name seems to be registered newlyDuplicateAndreas Kohlbecker

Actions
Actions #2

Updated by Andreas Kohlbecker over 4 years ago

  • Description updated (diff)
Actions #3

Updated by Andreas Kohlbecker over 4 years ago

  • Description updated (diff)
Actions #4

Updated by Andreas Kohlbecker over 4 years ago

  • Related to bug #7582: prevent from creating empty registrations added
Actions #5

Updated by Andreas Kohlbecker over 4 years ago

  • Related to bug #7629: creating a typification only registration should not be possible if the names protologue is in the current workingset added
Actions #6

Updated by Andreas Kohlbecker over 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50
Actions #7

Updated by Andreas Kohlbecker over 4 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

problem solved.

in the workflow code a blocking registration was created for the typification only registration, this code was intended to create a name registration in case the user chooses a type only registration and the name registration is missing. The according checks for this code where missing but the whole idea was nonsense anyway:

The user should not have the choice to create a typification only registration in the working (publication) set which contains the protologe. This is known from the nomenclatural reference.

Actions #8

Updated by Andreas Kohlbecker over 4 years ago

  • Has duplicate bug #7625: RegistrationWorkingsetEditor: if a registered name is selected, the same name seems to be registered newly added
Actions

Also available in: Atom PDF