Project

General

Profile

bug #7622

RegistrationWorkingsetEditor: navigating to other pages with fresh registrations leaves empty registrations in the system

Added by Andreas Kohlbecker 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
08/03/2018
Due date:
% Done:

100%

Severity:
critical
Found in Version:

Description

The RegistrationWorkinsetEditor leaves empty registrations in the database when a new 'typification only registration' is created without adding a specimen or name type. Navigating away from the RegistrationWorkinsetEditor view leaves an empty Registration in the database.


Related issues

Related to Edit - task #7650: RegistrationFactory implemented New 08/13/2018
Related to Edit - task #7651: RegistrationManager implemented New 08/13/2018
Duplicated by Edit - bug #7582: prevent from creating empty registrations Duplicate 07/24/2018

Associated revisions

Revision 6ed17427 (diff)
Added by Andreas Kohlbecker 4 months ago

ref #7622 preliminarily moving all registration management methods fom cdm-vaadin into the RegistrationService - needs further refactoring

Revision dd3f7f9d (diff)
Added by Andreas Kohlbecker 4 months ago

ref #7622 persisting new registrations only when typeDesignations have been added

Revision 6f1b1416 (diff)
Added by Andreas Kohlbecker 4 months ago

ref #7622 simplyfying code be replacing targetRegistration for type designations by map for popupeditors and reg uuids

Revision 148bdb5b (diff)
Added by Andreas Kohlbecker 4 months ago

ref #7622 addTypeDesignation() to receive registration uuids instead of objects

Revision 0faf24b5 (diff)
Added by Andreas Kohlbecker 4 months ago

ref #7651 #7622 relaxing requirement for an available registration minter

Revision 8648170e (diff)
Added by Andreas Kohlbecker 4 months ago

ref #7651 #7622 using nameService instead of CdmRepository to avoid bean factory problems

History

#1 Updated by Andreas Kohlbecker 4 months ago

  • Subject changed from reference page must not show unpublished Registrations to RegistrationWorkingsetEditor: navigating to other pages with fresh registrations leaves empty registrations in the system

Updating the subject to better reflect the cause

#2 Updated by Andreas Kohlbecker 4 months ago

  • Related to task #7650: RegistrationFactory implemented added

#3 Updated by Andreas Kohlbecker 4 months ago

  • Related to task #7651: RegistrationManager implemented added

#4 Updated by Andreas Kohlbecker 4 months ago

  • Target version changed from Release 5.2 to Release 5.3

#5 Updated by Andreas Kohlbecker 3 months ago

  • Duplicated by bug #7582: prevent from creating empty registrations added

#6 Updated by Andreas Kohlbecker 3 months ago

  • Description updated (diff)
  • Category changed from cdm-dataportal to cdm-vaadin

this was originally a dataportal ticket which has erroneously be overwritten with other information. There is a new ticket #7723 which covers the original meaning of this issue here.

replacing the old issue description with the text from the duplicating issue #7582

#7 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

no empty registrations since this has been fixed.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)