Project

General

Profile

Actions

feature request #7612

closed

CacheStrategy for MediaSpecimens

Added by Andreas Kohlbecker over 4 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
New
Category:
cdmlib
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal

Description

The DerivedUnitFacadeCacheStrategy has no support for MediaSpecimens.

see #7608 for which the creation of a string representation has been implemented in TypeDesignationSetManager.

This implementation makes certain assumptions regarding the data:

  • The reference reference detail of the media is placed in media.sources.citation and the media.sources.citationDetail
  • The media can otherwise be empty
  • A MediaSpecimen without collection is treated as published image/media

Even if this usage is somewhat unorthodox it is a pragmatic solution to store this data despite the fact that media specimens are not fully supported for real usecases.


Related issues

Related to EDIT - bug #7608: TypeDesignationSetManager: string representations for media types are missingClosedAndreas Kohlbecker

Actions
Related to EDIT - feature request #5575: DNA Sample requires CacheStrategyClosedAndreas Müller

Actions
Related to EDIT - feature request #5573: Cache Strategy for Media Specimen requiredClosedAndreas Müller

Actions
Related to EDIT - feature request #4363: Show more informative message for unsupported specimen structures in specimen bulk editorClosedAndreas Müller

Actions
Related to EDIT - task #9594: Use MediaSpecimen as input for MediaSpecimenGeneralDetailElementClosedAndreas Müller

Actions
Related to EDIT - feature request #9597: Improve formatting of MediaSpecimen in TypeDesignationWorkingSet formattingClosedAndreas Müller

Actions
Is duplicate of EDIT - feature request #5573: Cache Strategy for Media Specimen requiredClosedAndreas Müller

Actions
Actions #1

Updated by Andreas Kohlbecker over 4 years ago

  • Related to bug #7608: TypeDesignationSetManager: string representations for media types are missing added
Actions #2

Updated by Andreas Müller almost 2 years ago

  • Status changed from New to In Progress
  • Target version changed from Unassigned CDM tickets to Release 5.19

To me it is a bit unclear what the suggestion is how the MediaSpecimen cache strategy should be implemented.

Actions #3

Updated by Andreas Müller almost 2 years ago

  • % Done changed from 0 to 40

I implemented now a very basic version of the cache strategy to avoid -titleCache not yet implemented- messages

Actions #4

Updated by Andreas Müller almost 2 years ago

Actions #5

Updated by Andreas Müller almost 2 years ago

Actions #6

Updated by Andreas Müller over 1 year ago

  • Related to feature request #4363: Show more informative message for unsupported specimen structures in specimen bulk editor added
Actions #7

Updated by Andreas Müller over 1 year ago

  • Related to task #9594: Use MediaSpecimen as input for MediaSpecimenGeneralDetailElement added
Actions #8

Updated by Andreas Müller over 1 year ago

  • Description updated (diff)
Actions #9

Updated by Andreas Müller over 1 year ago

  • Related to feature request #9597: Improve formatting of MediaSpecimen in TypeDesignationWorkingSet formatting added
Actions #10

Updated by Andreas Müller over 1 year ago

  • Status changed from In Progress to Duplicate
  • % Done changed from 40 to 100

This focus of this ticket is not fully clear. Is it only about MediaSpecimen or about MediaSpecimen used as types.

However, the MediaSpecimen issue is a duplicate for #5573 while the type related issue is finally solved in #7608, #9597 and #9279.

So I guess we can close this ticket as duplicate.

Actions #11

Updated by Andreas Müller 9 months ago

Actions

Also available in: Atom PDF