Project

General

Profile

bug #7555

TaxonServiceImpl.findTaxaAndNames() broken for cichoriae searching for "Lapsana communis"

Added by Andreas Kohlbecker 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
07/16/2018
Due date:
% Done:

100%

Severity:
critical
Found in Version:

Description

the request:

http://api.cybertaxonomy.org/cichorieae/portal/taxon/find.json?doTaxaByCommonNames=1&doMisappliedNames=1&doSynonyms=1&doTaxa=1&pageNumber=0&pageSize=25&query=Lapsana+communis&tree=534e190f-3339-49ba-95d9-fa27d5493e3e

causes:

org.hibernate.QueryException: could not resolve property: teamMembers of: eu.etaxonomy.cdm.model.agent.Person
        at org.hibernate.persister.entity.AbstractPropertyMapping.propertyException(AbstractPropertyMapping.java:62)
        at org.hibernate.persister.entity.AbstractPropertyMapping.toType(AbstractPropertyMapping.java:56)
        at org.hibernate.persister.entity.AbstractEntityPersister.toType(AbstractEntityPersister.java:1753)
        at org.hibernate.hql.internal.ast.tree.FromElementType.getPropertyType(FromElementType.java:393)
        at org.hibernate.hql.internal.ast.tree.FromElement.getPropertyType(FromElement.java:505)
        at org.hibernate.hql.internal.ast.tree.DotNode.getDataType(DotNode.java:660)
        at org.hibernate.hql.internal.ast.tree.DotNode.prepareLhs(DotNode.java:264)
        at org.hibernate.hql.internal.ast.tree.DotNode.resolve(DotNode.java:204)
        at org.hibernate.hql.internal.ast.tree.FromReferenceNode.resolve(FromReferenceNode.java:109)
        at org.hibernate.hql.internal.ast.HqlSqlWalker.createFromJoinElement(HqlSqlWalker.java:376)
        at org.hibernate.hql.internal.antlr.HqlSqlBaseWalker.joinElement(HqlSqlBaseWalker.java:3926)
        at org.hibernate.hql.internal.antlr.HqlSqlBaseWalker.fromElement(HqlSqlBaseWalker.java:3712)
        at org.hibernate.hql.internal.antlr.HqlSqlBaseWalker.fromElementList(HqlSqlBaseWalker.java:3590)
        at org.hibernate.hql.internal.antlr.HqlSqlBaseWalker.fromClause(HqlSqlBaseWalker.java:716)
        at org.hibernate.hql.internal.antlr.HqlSqlBaseWalker.query(HqlSqlBaseWalker.java:572)
        at org.hibernate.hql.internal.antlr.HqlSqlBaseWalker.selectStatement(HqlSqlBaseWalker.java:309)
        at org.hibernate.hql.internal.antlr.HqlSqlBaseWalker.statement(HqlSqlBaseWalker.java:257)
        at org.hibernate.hql.internal.ast.QueryTranslatorImpl.analyze(QueryTranslatorImpl.java:262)
        at org.hibernate.hql.internal.ast.QueryTranslatorImpl.doCompile(QueryTranslatorImpl.java:190)
        at org.hibernate.hql.internal.ast.QueryTranslatorImpl.compile(QueryTranslatorImpl.java:142)
        at org.hibernate.engine.query.spi.HQLQueryPlan.<init>(HQLQueryPlan.java:115)
        at org.hibernate.engine.query.spi.HQLQueryPlan.<init>(HQLQueryPlan.java:76)
        at org.hibernate.engine.query.spi.QueryPlanCache.getHQLQueryPlan(QueryPlanCache.java:150)
        at org.hibernate.internal.AbstractSessionImpl.getHQLQueryPlan(AbstractSessionImpl.java:302)
        at org.hibernate.internal.AbstractSessionImpl.createQuery(AbstractSessionImpl.java:240)
        at org.hibernate.internal.SessionImpl.createQuery(SessionImpl.java:1894)
        at eu.etaxonomy.cdm.persistence.dao.hibernate.common.CdmGenericDaoImpl.getHqlQuery(CdmGenericDaoImpl.java:488)
        at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.bulkLoadLazyBeans(AdvancedBeanInitializer.java:456)
        at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.bulkLoadLazies(AdvancedBeanInitializer.java:433)
        at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNodeNoWildcard(AdvancedBeanInitializer.java:244)
        at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNode(AdvancedBeanInitializer.java:125)
        at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNodeRecursive(AdvancedBeanInitializer.java:105)
        at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNodeRecursive(AdvancedBeanInitializer.java:107)
        at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNodeRecursive(AdvancedBeanInitializer.java:107)
        at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeNodeRecursive(AdvancedBeanInitializer.java:107)
        at eu.etaxonomy.cdm.persistence.dao.initializer.AdvancedBeanInitializer.initializeAll(AdvancedBeanInitializer.java:85)
        at eu.etaxonomy.cdm.persistence.dao.hibernate.taxon.TaxonDaoHibernateImpl.getTaxaByName(TaxonDaoHibernateImpl.java:191)
        at eu.etaxonomy.cdm.api.service.TaxonServiceImpl.findTaxaAndNames(TaxonServiceImpl.java:701)
        at sun.reflect.GeneratedMethodAccessor15131.invoke(Unknown Source)

to be thrown

Associated revisions

Revision 0d707542 (diff)
Added by Andreas Kohlbecker 5 months ago

TeamAutoInitializer only loads members for Teams

History

#1 Updated by Andreas Müller 4 months ago

  • Status changed from New to Feedback
  • Assignee changed from Andreas Müller to Andreas Kohlbecker
  • Target version changed from Unassigned CDM tickets to Release 5.2

I can reproduce this on production with the given URL, but I can NOT reproduce on

Maybe you can again test it with a production copy on a local CDM Server.

Looks like this has been fixed somehow in the meanwhile though I have no idea how it was fixed.

#2 Updated by Andreas Müller 4 months ago

By the way, on production I got 21 results, on test only 20 (with the above tests) so data might have slightly changed.

#4 Updated by Andreas Kohlbecker 4 months ago

fixed in 0d70754

#5 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Andreas Kohlbecker to Andreas Müller

please review

#7 Updated by Andreas Müller 4 months ago

  • Subject changed from TaxonServiceImpl.findTaxaAndNames() broken for cichoriae serching for "Lapsana communis" to TaxonServiceImpl.findTaxaAndNames() broken for cichoriae searching for "Lapsana communis"

#8 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Andreas Kohlbecker

The issue described in the description (as link) seems to be solved.

The 2 later links do return "Required UUID parameter 'taxon' is not present" exception. This is also the case if you go to the webservice link in dataportal debug mode. Strange is, that on first glance the result on http://caryophyllales.org/nepenthaceae/cdm_dataportal/taxon/2cf267ed-66d4-43a8-a98b-826a30872f21 looks ok, though the webservice does not return a result.

@Andreas K.: can you have a look if this is correct as it is or if something needs to be fixed?

#10 Updated by Andreas Kohlbecker 4 months ago

Andreas Müller wrote:

Maybe it is related that for Nepenthes alata no specimen appear: http://caryophyllales.org/nepenthaceae/cdm_dataportal/taxon/fb987766-3ea5-45e0-a606-ca9b9d1253cf , for N. ampullacea no bibliographie appears: http://caryophyllales.org/nepenthaceae/cdm_dataportal/taxon/98002238-4fec-4ac6-997b-1ee9c35c44d3

this seems not to be related as the mentioned pages are still showing the empty sections for bibliography and specimens even if no webservice error occurs. I created new tickets for these cases: #7692, #7691

#11 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from Feedback to Closed

Andreas Müller wrote:

The issue described in the description (as link) seems to be solved.

The 2 later links do return "Required UUID parameter 'taxon' is not present" exception. This is also the case if you go to the webservice link in dataportal debug mode. Strange is, that on first glance the result on http://caryophyllales.org/nepenthaceae/cdm_dataportal/taxon/2cf267ed-66d4-43a8-a98b-826a30872f21 looks ok, though the webservice does not return a result.

The above posted links are incomplete requests, since they are missing the request body. Originally these requests are POST requests. The webservices seem to work properly.

#12 Updated by Andreas Kohlbecker 4 months ago

  • % Done changed from 0 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)