Project

General

Profile

bug #7544

Dragging a misapplication onto itself throws an exception in name editor

Added by Patrick Plitzner 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
07/10/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

When dragging and dropping a misapplication onto itself in the taxon name editor the following exception is thrown and the misapplication disappears

!ENTRY org.eclipse.ui 4 0 2018-07-10 11:13:47.965
!MESSAGE This is an unexpected error.
Please contact EDIT Support (EditSupport@bgbm.org) with the error trace below (click on the 'Details' button).
!STACK 0
java.lang.Exception: login : admin
editor version : 5.2.0.qualifier
server : localhost (localhost-dev)
schema version : 5.0.0.0.20180514
os : Linux 4.4.0-130-generic amd64
java : 1.8.0_25
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.IllegalArgumentException: Argument not valid)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4536)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4154)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.IllegalArgumentException: Argument not valid
    at org.eclipse.swt.SWT.error(SWT.java:4514)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.SWT.error(SWT.java:4419)
    at org.eclipse.swt.widgets.Widget.error(Widget.java:483)
    at org.eclipse.swt.widgets.Widget.checkParent(Widget.java:358)
    at org.eclipse.swt.widgets.Widget.<init>(Widget.java:242)
    at org.eclipse.swt.widgets.Control.<init>(Control.java:104)
    at org.eclipse.swt.widgets.Scrollable.<init>(Scrollable.java:75)
    at org.eclipse.swt.widgets.Composite.<init>(Composite.java:108)
    at org.eclipse.ui.forms.widgets.LayoutComposite.<init>(LayoutComposite.java:25)
    at org.eclipse.ui.forms.widgets.FormToolkit.createComposite(FormToolkit.java:313)
    at org.eclipse.ui.forms.widgets.FormToolkit.createComposite(FormToolkit.java:300)
    at eu.etaxonomy.taxeditor.editor.name.e4.container.AbstractGroupedContainerE4.createControl(AbstractGroupedContainerE4.java:467)
    at eu.etaxonomy.taxeditor.editor.name.e4.container.AbstractGroupedContainerE4.createContent(AbstractGroupedContainerE4.java:131)
    at eu.etaxonomy.taxeditor.editor.name.e4.container.MisappliedGroupE4.createContainers(MisappliedGroupE4.java:44)
    at eu.etaxonomy.taxeditor.editor.name.e4.container.AbstractGroupE4.redraw(AbstractGroupE4.java:161)
    at eu.etaxonomy.taxeditor.editor.name.e4.container.MisappliedGroupE4.redraw(MisappliedGroupE4.java:51)
    at eu.etaxonomy.taxeditor.editor.name.e4.container.AbstractGroupE4.postOperation(AbstractGroupE4.java:155)
    at eu.etaxonomy.taxeditor.operation.AbstractPostOperation.postExecute(AbstractPostOperation.java:72)
    at eu.etaxonomy.taxeditor.editor.name.operation.ChangeConceptRelationshipTypeOperation.execute(ChangeConceptRelationshipTypeOperation.java:91)
    at eu.etaxonomy.taxeditor.model.AbstractUtility.lambda$3(AbstractUtility.java:141)
    at eu.etaxonomy.taxeditor.model.AbstractUtility$$Lambda$55/942125169.run(Unknown Source)
    at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
    at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 24 more

Related issues

Copied to Edit - feature request #7609: drag & drop misapplied names from one name editor to another editor New 07/31/2018

Associated revisions

Revision b7e704af (diff)
Added by Katja Luther 4 months ago

fix #7544: do not allow d&d for misapplied names

History

#1 Updated by Andreas Müller 4 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.2

#2 Updated by Katja Luther 4 months ago

  • Status changed from New to In Progress
  • Priority changed from New to Highest

I removed the possiblity to drop at a misapplied name, but should it be possible to drag a misapplied name and drop it on an homotypical group?

then a new synonyme would be created and the concept relation is gone.

#3 Updated by Andreas Müller 4 months ago

Katja Luther wrote:

I removed the possiblity to drop at a misapplied name, but should it be possible to drag a misapplied name and drop it on an homotypical group?

then a new synonyme would be created and the concept relation is gone.

To me it does not make sense to d&d a misapplication (or a ppSyn) within a name editor at all. We may think about allowing to move it from one taxon/name editor to another taxon/name editor. Probably this is not yet possible via any direct functionality in the TaxEditor? Maybe also not very important.

#4 Updated by Katja Luther 4 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

#5 Updated by Katja Luther 4 months ago

  • Status changed from Resolved to In Progress
  • % Done changed from 50 to 0

As a first implementation d&d for concept relations are not provided anymore.
For d&d to another name editor I create a new ticket (#7609).

#6 Updated by Katja Luther 4 months ago

  • Related to feature request #7609: drag & drop misapplied names from one name editor to another editor added

#7 Updated by Katja Luther 4 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

#8 Updated by Andreas Müller 4 months ago

  • Related to deleted (feature request #7609: drag & drop misapplied names from one name editor to another editor)

#9 Updated by Andreas Müller 4 months ago

  • Copied to feature request #7609: drag & drop misapplied names from one name editor to another editor added

#10 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 100

Disabling d&d seems to work. Advanced features copied to #7609 so we can close this ticket.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)