Project

General

Profile

bug #7481

ReferenceEditor: filter inReferences by applicable reference type

Added by Andreas Kohlbecker about 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
06/15/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

Currently the inReferences combobox offers all references which are in the system.
This could be limited to the references which are applicable to the chosen reference type.

  • Article -> Journal
  • Book -> PrintSeries | Journal
  • BookSection -> Book
  • InProceedings -> Proceedings
  • Section -> Article | Book | Thesis | Patent | Report | Webpage | inProceedings | BookSection

References of the type Generic and null should also be included. (Note: after release of this feature, this has been rejected: see #8149)

picture977-1.png View (45.3 KB) Wolf-Henning Kusber, 01/30/2019 03:43 PM


Related issues

Related to Edit - feature request #7613: Vaadin: Fehlervermeidung bei Anlegen einer Referenz New 08/01/2018
Related to Edit - bug #8149: ReferenceEditor: filter inReferences ONLY by applicable reference type suppess Generic and NULL Closed 02/27/2019

Associated revisions

Revision 9bbd60ec (diff)
Added by Andreas Kohlbecker 8 months ago

ref #7481 inReference options filtered by applicable type

Revision bc7a1271 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #7481 inReference constraints added as method to ReferenceType

Revision 5b9c1d33 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #7481 moving inReference constraints to cdmlib-model

Revision 9eb3b85d (diff)
Added by Andreas Kohlbecker 8 months ago

ref #7481 inReference constraints added as method to ReferenceType - making method static

Revision 5dd877d3 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #7481 adding validator for in reference type constraints

Revision afb7802b (diff)
Added by Andreas Kohlbecker 7 months ago

ref #7481 adding BookSection to inReference constraints

History

#1 Updated by Andreas Kohlbecker 9 months ago

#2 Updated by Andreas Kohlbecker 8 months ago

  • Subject changed from ReferenceEditor: filter inReferences by applicable reference type? to ReferenceEditor: filter inReferences by applicable reference type
  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.5

#3 Updated by Andreas Kohlbecker 8 months ago

  • Description updated (diff)
  • % Done changed from 0 to 10

#4 Updated by Andreas Kohlbecker 8 months ago

  • Status changed from New to Feedback
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

Hi Henning, do you agree with the constraints as mentioned in the issue description? Anything missing?

#5 Updated by Andreas Kohlbecker 8 months ago

  • Description updated (diff)

#6 Updated by Wolf-Henning Kusber 8 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

Two comments

AK: Section -> Article | Book | Thesis | Patent | Report | Webpage
W-H.K.: missing: inProceedings | inBookSection

Question: What about a very rare but existing case:
In Ehrenberg's times some articles (prior to publication in a journal) werde printed and delivered to colleagues and libraries (published preprints). Is it possible to handle these as (small) books? If yes, there is no problem.

#7 Updated by Andreas Kohlbecker 8 months ago

  • Description updated (diff)

Wolf-Henning Kusber wrote:

Two comments

AK: Section -> Article | Book | Thesis | Patent | Report | Webpage
W-H.K.: missing: inProceedings | inBookSection

  1. There is no such type named inBookSection in the cdm
  2. inProceedings, good point, I will add this to the list of possible in-reference types for Section

Question: What about a very rare but existing case:
In Ehrenberg's times some articles (prior to publication in a journal) were printed and delivered to colleagues and libraries (published preprints). Is it possible to handle these as (small) books? If yes, there is no problem.

So we also need to extent Book in this way

  • Book -> PrintSeries | Journal

#8 Updated by Andreas Kohlbecker 8 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

validator added

ready for reviewing

#9 Updated by Andreas Kohlbecker 8 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 10 to 50

#10 Updated by Wolf-Henning Kusber 7 months ago

Comment: "There is no such type named inBookSection in the cdm"
Warning "BookSection is not a suitable in-reference type for section"
Workaround: not "in section in book" but " section in book"

Section in inproceedings in proceedings is working.

internal problems with old data:
info: inproceeding can not be linked to the Reference of the Proceedings volume if it is marked as "book"

#11 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Resolved to Feedback
  • % Done changed from 50 to 60

Wolf-Henning Kusber wrote:

Comment: "There is no such type named inBookSection in the cdm"
Warning "BookSection is not a suitable in-reference type for section"
Workaround: not "in section in book" but " section in book"

Please can you elaborate why the general section is not suitable in this case?

I think that "Section -in-> BookSection -in-> Book" would be suitable is most cases, and if not you still could use the general section twice: "Section -in-> Section -in-> Book"

Please open a new ticket for the missing type inBookSection so that we can discuss this independently from this UI specific ticket. The new issue should be referenced by this issue via the "Copied to" relation.

#12 Updated by Wolf-Henning Kusber 7 months ago

May be a Vaadin problem.

I reproduced the above mentioned
1st step: enter Reference (book)
2nd step: enter Reference (book section in book, see 1st step)
3rd step: enter a new name AND (because of different authorship) try to make a section for the new name.

Vaadin: Warning "BookSection is not a suitable in-reference type for section"

I think that "Section -in-> BookSection -in-> Book" would be suitable is most cases... Comment: Yes, I tried.

AK: "and if not you still could use the general section twice: "Section -in-> Section -in-> Book"
Comming from "New" reference, I cannot select "section", just "book section".
This way it is not working.

#13 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

Ah ok! We will extend the allowed inref types for section by adding BookSection:

Section -> Article | Book | Thesis | Patent | Report | Webpage | inProceedings | BookSection

#14 Updated by Andreas Kohlbecker 7 months ago

  • Description updated (diff)

#15 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 60 to 70

BookSection is now added to the allowed inReference types for Section.

please review again.

#16 Updated by Wolf-Henning Kusber 7 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 70 to 100

Section in Booksection is now possible. Ticket can be closed.

#17 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Resolved to Closed

#18 Updated by Andreas Kohlbecker 6 months ago

  • Description updated (diff)

#19 Updated by Andreas Kohlbecker 6 months ago

  • Description updated (diff)

#20 Updated by Andreas Kohlbecker 6 months ago

  • Related to bug #8149: ReferenceEditor: filter inReferences ONLY by applicable reference type suppess Generic and NULL added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)