Project

General

Profile

bug #7475

error when saving Reference editor with new empty Person in Team when OK or NEW was not pressed

Added by Andreas Kohlbecker 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
06/14/2018
Due date:
% Done:

50%

Severity:
major
Found in Version:
Tags:

Description

...Dazu wollte ich zunächst eine neue Referenz erstellen.
Neues Autorenteam mit einem neu erstellten Autor, hatte beim 2. Autor „OK“ vergessen, siehe ScreenShot 1
Beim Speichern:

...
...

Caused by: org.hibernate.exception.ConstraintViolationException: could not execute statement
               at org.hibernate.exception.internal.SQLExceptionTypeDelegate.convert(SQLExceptionTypeDelegate.java:59)
               at org.hibernate.exception.internal.StandardSQLExceptionConverter.convert(StandardSQLExceptionConverter.java:42)
               at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:109)
               at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:95)
               at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.executeUpdate(ResultSetReturnImpl.java:207)
               at org.hibernate.engine.jdbc.batch.internal.NonBatchingBatch.addToBatch(NonBatchingBatch.java:45)
               at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2886)
               at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:3386)
               at org.hibernate.action.internal.EntityInsertAction.execute(EntityInsertAction.java:89)
               at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:560)
               at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:434)
               at org.hibernate.event.internal.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:337)
               at org.hibernate.event.internal.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:39)
               at org.hibernate.internal.SessionImpl.flush(SessionImpl.java:1282)
               at org.hibernate.envers.internal.synchronization.AuditProcess.doBeforeTransactionCompletion(AuditProcess.java:156)
               at org.hibernate.envers.internal.synchronization.AuditProcessManager$1.doBeforeTransactionCompletion(AuditProcessManager.java:46)
               at org.hibernate.engine.spi.ActionQueue$BeforeTransactionCompletionProcessQueue.beforeTransactionCompletion(ActionQueue.java:899)
               at org.hibernate.engine.spi.ActionQueue.beforeTransactionCompletion(ActionQueue.java:481)
               at org.hibernate.internal.SessionImpl.beforeTransactionCompletion(SessionImpl.java:2340)
               at org.hibernate.engine.jdbc.internal.JdbcCoordinatorImpl.beforeTransactionCompletion(JdbcCoordinatorImpl.java:485)
               at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl.beforeCompletionCallback(JdbcResourceLocalTransactionCoordinatorImpl.java:147)
               at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl.access$100(JdbcResourceLocalTransactionCoordinatorImpl.java:38)
               at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl$TransactionDriverControlImpl.commit(JdbcResourceLocalTransactionCoordinatorImpl.java:231)
               at org.hibernate.engine.transaction.internal.TransactionImpl.commit(TransactionImpl.java:65)
               at org.springframework.orm.hibernate5.HibernateTransactionManager.doCommit(HibernateTransactionManager.java:581)
               ... 100 more
Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLIntegrityConstraintViolationException: Column 'teamMembers_id' cannot be null
               at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
               at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
               at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
               at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
               at com.mysql.jdbc.Util.handleNewInstance(Util.java:404)
               at com.mysql.jdbc.Util.getInstance(Util.java:387)
               at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:932)
               at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3878)
               at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3814)
               at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:2478)
               at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2625)
               at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2551)
               at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:1861)
               at com.mysql.jdbc.PreparedStatement.executeUpdateInternal(PreparedStatement.java:2073)
               at com.mysql.jdbc.PreparedStatement.executeUpdateInternal(PreparedStatement.java:2009)
               at com.mysql.jdbc.PreparedStatement.executeLargeUpdate(PreparedStatement.java:5094)
               at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:1994)
               at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.executeUpdate(NewProxyPreparedStatement.java:384)
               at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.executeUpdate(ResultSetReturnImpl.java:204)
               ... 120 more

picture713-1.png View (69.3 KB) Andreas Kohlbecker, 06/14/2018 02:31 PM


Related issues

Related to Edit - bug #7477: TeamOrPersonField: ToManyRelatedEntitiesListSelect blocks removing new entries Closed 06/14/2018
Duplicated by Edit - bug #7327: ReferencePopupEditor: multiple exceptions and problems during creation of a journal section Duplicate 03/23/2018

Associated revisions

Revision eded01b7 (diff)
Added by Andreas Kohlbecker 6 months ago

fix #7475 removing empty rows from ToManyRelatedEntitiesListSelect on commit

History

#1 Updated by Andreas Kohlbecker 6 months ago

  • Duplicated by bug #7327: ReferencePopupEditor: multiple exceptions and problems during creation of a journal section added

#2 Updated by Andreas Kohlbecker 6 months ago

  • Related to bug #7477: TeamOrPersonField: ToManyRelatedEntitiesListSelect blocks removing new entries added

#3 Updated by Andreas Kohlbecker 6 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#4 Updated by Andreas Kohlbecker 6 months ago

problem solved please review

#5 Updated by Wolf-Henning Kusber 6 months ago

Ausgewählte authors ohne OK werden ignoriert, es gibt keinen Fehler und speichern ist möglich.
Das author team kann im Überarbeitungsmodus korrigiert werden.

Kein Fehler mehr, aber fehlerhafte Eingabe ist möglich, insofern müssen wir weiterhin auf usability achten.

#6 Updated by Andreas Kohlbecker 6 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

Vorschläge zu besserer Usability sollten wir in ein neues Ticket erfassen, dieses hier bezieht sich auf den Fehlerfall, der nicht mehr auftritt. Damit können wir es also schließen.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)